How to install packages from GitHubb

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

How to install packages from GitHubb

Patrick Connolly-4
R-3.4.1

Running the train function from the latest version of the caret
package on CRAN fails with this message:

 unable to find variable "optimismBoot"
The purported workaround is to use
devtools::install_github('topepo/caret/pkg/caret') to get  the development version.

However, that evidently has the same problem with southern hemisphere
timezones that install.packages() does -- via download.packages().
i.e. it hangs.  The workaround with that one is to use method =
"internal". What is the  equivalent for install_github()?

TIA
--
~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.  
   ___    Patrick Connolly  
 {~._.~}                   Great minds discuss ideas    
 _( Y )_           Average minds discuss events
(:_~*~_:)                  Small minds discuss people  
 (_)-(_)                        ..... Eleanor Roosevelt
         
~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.