Quantcast

How to integrate OpenBLAS LAPACK to my RStudio in WINDOWS 7?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

How to integrate OpenBLAS LAPACK to my RStudio in WINDOWS 7?

R help mailing list-2
Hi.
I have installed OpenBLAS and LAPACK. It's working correctly in Python.
I also want OpenBLAS and LAPACK to be used in R to speed up computational time but i can't find the installation guide for RStudio in Windows7. Does it mean that RStudio automatically detect the installed OpenBLAS and use it?

Please let me know.
THANKS

*Note: I Have installed RTools but i don't set R's mingw, cygwn in the environment path because i have installed those two beforehand. My RSTUDIO=3.4

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: How to integrate OpenBLAS LAPACK to my RStudio in WINDOWS 7?

David Winsemius

> On Apr 15, 2017, at 7:27 PM, Allan Tanaka via R-help <[hidden email]> wrote:
>
> Hi.
> I have installed OpenBLAS and LAPACK. It's working correctly in Python.
> I also want OpenBLAS and LAPACK to be used in R to speed up computational time but i can't find the installation guide for RStudio in Windows7. Does it mean that RStudio automatically detect the installed OpenBLAS and use it?

Seems unlikely that RStudio has much to do with this matter. I'm reasonably sure that you would need to compile R to link to OpenBLAS but I think LAPACK is the default math package (although you can use an "external" version).

Search for:
A.3.1.3 Goto and OpenBLAS   # in the 'R Installation and Administration' manual

And
A.3.2 LAPACK


>
> Please let me know.
> THANKS
>
> *Note: I Have installed RTools but i don't set R's mingw, cygwn in the environment path because i have installed those two beforehand. My RSTUDIO=3.4

I thought R's binary wasn't set up to run under Cygwin?

And I didn't change my mind after reading Section:
C.8 Cygwin

I think follow-up question on this matter would be more appropriate on R-devel, but they really do expect you to RTM.

--
David Winsemius
Alameda, CA, USA

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Loading...