Install BMR package - Mac

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Install BMR package - Mac

Beatrice Monti
Hi all,
I am having problems installing the BMR package.

I have been trying the following:

        install.packages("devtools”)
        library(devtools)
        install_github("kthohr/BMR")

This is the error I get:

        clang: error: unsupported option ‘-fopenmp'

I have dowloaded and installed both gfortran and clang-6.0.0 from   https://cran.r-project.org/bin/macosx/tools/ <https://cran.r-project.org/bin/macosx/tools/>   but I still get the same error.
I am using R version 3.5.1 on Mac OS X.

Any suggestion to solve this problem - which steps am I missing?
ps: my apologies if I missed important information - let me know if further details are needed to explain the problem!

Thank you so much for your help!
        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: Install BMR package - Mac

Bert Gunter-2
As this appears to be a Mac specific issue, if you don't get help here, you
should try posting on the r-sig-mac list. Maybe even better would be to
contact the maintainer of the BMR package, who might not monitor either
list.


Cheers,
Bert



Bert Gunter

"The trouble with having an open mind is that people keep coming along and
sticking things into it."
-- Opus (aka Berkeley Breathed in his "Bloom County" comic strip )

On Sat, Jul 21, 2018 at 6:00 AM, Beatrice Monti <[hidden email]>
wrote:

> Hi all,
> I am having problems installing the BMR package.
>
> I have been trying the following:
>
>         install.packages("devtools”)
>         library(devtools)
>         install_github("kthohr/BMR")
>
> This is the error I get:
>
>         clang: error: unsupported option ‘-fopenmp'
>
> I have dowloaded and installed both gfortran and clang-6.0.0 from
> https://cran.r-project.org/bin/macosx/tools/ <https://cran.r-project.org/
> bin/macosx/tools/>   but I still get the same error.
> I am using R version 3.5.1 on Mac OS X.
>
> Any suggestion to solve this problem - which steps am I missing?
> ps: my apologies if I missed important information - let me know if
> further details are needed to explain the problem!
>
> Thank you so much for your help!
>         [[alternative HTML version deleted]]
>
> ______________________________________________
> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/
> posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.
>

        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: Install BMR package - Mac

Jeff Newmiller
Agree with Bert, but Google sez [1] might also be helpful.

[1] https://github.com/Microsoft/LightGBM/issues/3

On July 21, 2018 7:28:55 AM PDT, Bert Gunter <[hidden email]> wrote:

>As this appears to be a Mac specific issue, if you don't get help here,
>you
>should try posting on the r-sig-mac list. Maybe even better would be to
>contact the maintainer of the BMR package, who might not monitor either
>list.
>
>
>Cheers,
>Bert
>
>
>
>Bert Gunter
>
>"The trouble with having an open mind is that people keep coming along
>and
>sticking things into it."
>-- Opus (aka Berkeley Breathed in his "Bloom County" comic strip )
>
>On Sat, Jul 21, 2018 at 6:00 AM, Beatrice Monti
><[hidden email]>
>wrote:
>
>> Hi all,
>> I am having problems installing the BMR package.
>>
>> I have been trying the following:
>>
>>         install.packages("devtools”)
>>         library(devtools)
>>         install_github("kthohr/BMR")
>>
>> This is the error I get:
>>
>>         clang: error: unsupported option ‘-fopenmp'
>>
>> I have dowloaded and installed both gfortran and clang-6.0.0 from
>> https://cran.r-project.org/bin/macosx/tools/
><https://cran.r-project.org/
>> bin/macosx/tools/>   but I still get the same error.
>> I am using R version 3.5.1 on Mac OS X.
>>
>> Any suggestion to solve this problem - which steps am I missing?
>> ps: my apologies if I missed important information - let me know if
>> further details are needed to explain the problem!
>>
>> Thank you so much for your help!
>>         [[alternative HTML version deleted]]
>>
>> ______________________________________________
>> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
>> https://stat.ethz.ch/mailman/listinfo/r-help
>> PLEASE do read the posting guide http://www.R-project.org/
>> posting-guide.html
>> and provide commented, minimal, self-contained, reproducible code.
>>
>
> [[alternative HTML version deleted]]
>
>______________________________________________
>[hidden email] mailing list -- To UNSUBSCRIBE and more, see
>https://stat.ethz.ch/mailman/listinfo/r-help
>PLEASE do read the posting guide
>http://www.R-project.org/posting-guide.html
>and provide commented, minimal, self-contained, reproducible code.

--
Sent from my phone. Please excuse my brevity.

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.