Quantcast

Is ImageMagick package not compatible with R 3.3.2?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Is ImageMagick package not compatible with R 3.3.2?

tmrsg11
Dear list,

I am trying to use saveGIF() from library animation.
https://cran.r-project.org/web/packages/animation/animation.pdf

saveGIF() has dependency on package ImageMagick.

I got the following,
> install.packages("ImageMagick")
Warning in install.packages :
  package ‘ImageMagick’ is not available (for R version 3.3.2)

Does that mean I can't use saveGIF() anymore? It seems that this is the
only package capable in R.

Thank you in advance!

        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Is ImageMagick package not compatible with R 3.3.2?

Hervé Pagès-2
Hi,

ImageMagick is an external software that you need to install on your
system. It's not an *R* package so trying to install it with
install.packages() won't work.

Note the difference between things listed in the SystemRequirements
field (the animation package has many of these system requirements)
vs things listed in the Depends or Imports field. The former are
external softwares (typically standalone programs or system libraries).
The latter are R packages that can be found with available.packages()
and installed with install.packages().

H.


On 03/14/2017 10:21 PM, C W wrote:

> Dear list,
>
> I am trying to use saveGIF() from library animation.
> https://urldefense.proofpoint.com/v2/url?u=https-3A__cran.r-2Dproject.org_web_packages_animation_animation.pdf&d=DwIGaQ&c=eRAMFD45gAfqt84VtBcfhQ&r=BK7q3XeAvimeWdGbWY_wJYbW0WYiZvSXAJJKaaPhzWA&m=sLEnaUtX6fn9Y_qSSEHFl-W9OaFf4_3oSFFTpbvjAd4&s=4BYi2BW4av2AKvz57RFr0v7j-zxc2Z7AzHvutypbh_s&e=
>
> saveGIF() has dependency on package ImageMagick.
>
> I got the following,
>> install.packages("ImageMagick")
> Warning in install.packages :
>   package ‘ImageMagick’ is not available (for R version 3.3.2)
>
> Does that mean I can't use saveGIF() anymore? It seems that this is the
> only package capable in R.
>
> Thank you in advance!
>
> [[alternative HTML version deleted]]
>
> ______________________________________________
> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
> https://urldefense.proofpoint.com/v2/url?u=https-3A__stat.ethz.ch_mailman_listinfo_r-2Dhelp&d=DwIGaQ&c=eRAMFD45gAfqt84VtBcfhQ&r=BK7q3XeAvimeWdGbWY_wJYbW0WYiZvSXAJJKaaPhzWA&m=sLEnaUtX6fn9Y_qSSEHFl-W9OaFf4_3oSFFTpbvjAd4&s=_h7qcvAynH-5nBWCTLad-rzILkVVQe8Ymt5a0-DOGXY&e=
> PLEASE do read the posting guide https://urldefense.proofpoint.com/v2/url?u=http-3A__www.R-2Dproject.org_posting-2Dguide.html&d=DwIGaQ&c=eRAMFD45gAfqt84VtBcfhQ&r=BK7q3XeAvimeWdGbWY_wJYbW0WYiZvSXAJJKaaPhzWA&m=sLEnaUtX6fn9Y_qSSEHFl-W9OaFf4_3oSFFTpbvjAd4&s=PliR-mnRNhRqRnpIX6OFVtcpBlOR2rBkBKtemPQ-NMw&e=
> and provide commented, minimal, self-contained, reproducible code.
>

--
Hervé Pagès

Program in Computational Biology
Division of Public Health Sciences
Fred Hutchinson Cancer Research Center
1100 Fairview Ave. N, M1-B514
P.O. Box 19024
Seattle, WA 98109-1024

E-mail: [hidden email]
Phone:  (206) 667-5791
Fax:    (206) 667-1319

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Is ImageMagick package not compatible with R 3.3.2?

Bert Gunter-2
In reply to this post by tmrsg11
A google search on "ImageMagick Package R" brought this up, which
seems relevant:

https://cran.r-project.org/web/packages/magick/vignettes/intro.html

-- Bert


Bert Gunter

"The trouble with having an open mind is that people keep coming along
and sticking things into it."
-- Opus (aka Berkeley Breathed in his "Bloom County" comic strip )


On Tue, Mar 14, 2017 at 10:21 PM, C W <[hidden email]> wrote:

> Dear list,
>
> I am trying to use saveGIF() from library animation.
> https://cran.r-project.org/web/packages/animation/animation.pdf
>
> saveGIF() has dependency on package ImageMagick.
>
> I got the following,
>> install.packages("ImageMagick")
> Warning in install.packages :
>   package ‘ImageMagick’ is not available (for R version 3.3.2)
>
> Does that mean I can't use saveGIF() anymore? It seems that this is the
> only package capable in R.
>
> Thank you in advance!
>
>         [[alternative HTML version deleted]]
>
> ______________________________________________
> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Is ImageMagick package not compatible with R 3.3.2?

Yihui Xie-2
I'm the author of the animation package, and I do plan to switch to
the magick package in the future instead of using ImageMagick as a
system dependency.

Regards,
Yihui
--
https://yihui.name


On Wed, Mar 15, 2017 at 12:32 AM, Bert Gunter <[hidden email]> wrote:

> A google search on "ImageMagick Package R" brought this up, which
> seems relevant:
>
> https://cran.r-project.org/web/packages/magick/vignettes/intro.html
>
> -- Bert
>
>
> Bert Gunter
>
> "The trouble with having an open mind is that people keep coming along
> and sticking things into it."
> -- Opus (aka Berkeley Breathed in his "Bloom County" comic strip )
>
>
> On Tue, Mar 14, 2017 at 10:21 PM, C W <[hidden email]> wrote:
>> Dear list,
>>
>> I am trying to use saveGIF() from library animation.
>> https://cran.r-project.org/web/packages/animation/animation.pdf
>>
>> saveGIF() has dependency on package ImageMagick.
>>
>> I got the following,
>>> install.packages("ImageMagick")
>> Warning in install.packages :
>>   package ‘ImageMagick’ is not available (for R version 3.3.2)
>>
>> Does that mean I can't use saveGIF() anymore? It seems that this is the
>> only package capable in R.
>>
>> Thank you in advance!
>>
>>         [[alternative HTML version deleted]]
>>
>> ______________________________________________
>> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
>> https://stat.ethz.ch/mailman/listinfo/r-help
>> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
>> and provide commented, minimal, self-contained, reproducible code.
>
> ______________________________________________
> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Is ImageMagick package not compatible with R 3.3.2?

Duncan Murdoch-2
On 15/03/2017 8:58 AM, Yihui Xie wrote:
> I'm the author of the animation package, and I do plan to switch to
> the magick package in the future instead of using ImageMagick as a
> system dependency.

I did that in rgl (as a Suggests); it's very easy, as the functions
mirror the command line options.

Duncan Murdoch

>
> Regards,
> Yihui
> --
> https://yihui.name
>
>
> On Wed, Mar 15, 2017 at 12:32 AM, Bert Gunter <[hidden email]> wrote:
>> A google search on "ImageMagick Package R" brought this up, which
>> seems relevant:
>>
>> https://cran.r-project.org/web/packages/magick/vignettes/intro.html
>>
>> -- Bert
>>
>>
>> Bert Gunter
>>
>> "The trouble with having an open mind is that people keep coming along
>> and sticking things into it."
>> -- Opus (aka Berkeley Breathed in his "Bloom County" comic strip )
>>
>>
>> On Tue, Mar 14, 2017 at 10:21 PM, C W <[hidden email]> wrote:
>>> Dear list,
>>>
>>> I am trying to use saveGIF() from library animation.
>>> https://cran.r-project.org/web/packages/animation/animation.pdf
>>>
>>> saveGIF() has dependency on package ImageMagick.
>>>
>>> I got the following,
>>>> install.packages("ImageMagick")
>>> Warning in install.packages :
>>>   package ‘ImageMagick’ is not available (for R version 3.3.2)
>>>
>>> Does that mean I can't use saveGIF() anymore? It seems that this is the
>>> only package capable in R.
>>>
>>> Thank you in advance!
>>>
>>>         [[alternative HTML version deleted]]
>>>
>>> ______________________________________________
>>> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
>>> https://stat.ethz.ch/mailman/listinfo/r-help
>>> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
>>> and provide commented, minimal, self-contained, reproducible code.
>>
>> ______________________________________________
>> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
>> https://stat.ethz.ch/mailman/listinfo/r-help
>> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
>> and provide commented, minimal, self-contained, reproducible code.
>
> ______________________________________________
> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.
>

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Is ImageMagick package not compatible with R 3.3.2?

tmrsg11
In reply to this post by Yihui Xie-2
Thanks Hervé, Bert, and Yihui.

I installed ImageMagick using the Bert link provided.

I am still not able to produce gif.

The saveGIF() example, from
https://cran.r-project.org/web/packages/animation/animation.pdf

saveGIF({
 for (i in 1:10) plot(runif(10), ylim = 0:1)
})

However, my for loop is INSIDE plot, for example,
saveGIF({plot(-4:4, -4:4, type = "n")

for(i in 1:10){
  x[i] <- rnorm(1)
  y[i] <- rnorm(1)
  points(x[i], y[i])

}
})

Is this possible?


On Wed, Mar 15, 2017 at 8:58 AM, Yihui Xie <[hidden email]> wrote:

> I'm the author of the animation package, and I do plan to switch to
> the magick package in the future instead of using ImageMagick as a
> system dependency.
>
> Regards,
> Yihui
> --
> https://yihui.name
>
>
> On Wed, Mar 15, 2017 at 12:32 AM, Bert Gunter <[hidden email]>
> wrote:
> > A google search on "ImageMagick Package R" brought this up, which
> > seems relevant:
> >
> > https://cran.r-project.org/web/packages/magick/vignettes/intro.html
> >
> > -- Bert
> >
> >
> > Bert Gunter
> >
> > "The trouble with having an open mind is that people keep coming along
> > and sticking things into it."
> > -- Opus (aka Berkeley Breathed in his "Bloom County" comic strip )
> >
> >
> > On Tue, Mar 14, 2017 at 10:21 PM, C W <[hidden email]> wrote:
> >> Dear list,
> >>
> >> I am trying to use saveGIF() from library animation.
> >> https://cran.r-project.org/web/packages/animation/animation.pdf
> >>
> >> saveGIF() has dependency on package ImageMagick.
> >>
> >> I got the following,
> >>> install.packages("ImageMagick")
> >> Warning in install.packages :
> >>   package ‘ImageMagick’ is not available (for R version 3.3.2)
> >>
> >> Does that mean I can't use saveGIF() anymore? It seems that this is the
> >> only package capable in R.
> >>
> >> Thank you in advance!
> >>
> >>         [[alternative HTML version deleted]]
> >>
> >> ______________________________________________
> >> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
> >> https://stat.ethz.ch/mailman/listinfo/r-help
> >> PLEASE do read the posting guide http://www.R-project.org/
> posting-guide.html
> >> and provide commented, minimal, self-contained, reproducible code.
> >
> > ______________________________________________
> > [hidden email] mailing list -- To UNSUBSCRIBE and more, see
> > https://stat.ethz.ch/mailman/listinfo/r-help
> > PLEASE do read the posting guide http://www.R-project.org/
> posting-guide.html
> > and provide commented, minimal, self-contained, reproducible code.
>

        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Is ImageMagick package not compatible with R 3.3.2?

tmrsg11
I figured it out.  You can first do,

saveGIF({
  for (j in 1:20){
    plot(-4:4, -4:4, type = "n")
    for(i in 1:10){
      x[i] <- rnorm(1)
      y[i] <- rnorm(1)
      points(x[i], y[i])
    }
  }
 })

It looks like you have to re-plot every time.


On Wed, Mar 15, 2017 at 1:41 PM, C W <[hidden email]> wrote:

> Thanks Hervé, Bert, and Yihui.
>
> I installed ImageMagick using the Bert link provided.
>
> I am still not able to produce gif.
>
> The saveGIF() example, from https://cran.r-project.org/
> web/packages/animation/animation.pdf
>
> saveGIF({
>  for (i in 1:10) plot(runif(10), ylim = 0:1)
> })
>
> However, my for loop is INSIDE plot, for example,
> saveGIF({plot(-4:4, -4:4, type = "n")
>
> for(i in 1:10){
>   x[i] <- rnorm(1)
>   y[i] <- rnorm(1)
>   points(x[i], y[i])
>
> }
> })
>
> Is this possible?
>
>
> On Wed, Mar 15, 2017 at 8:58 AM, Yihui Xie <[hidden email]> wrote:
>
>> I'm the author of the animation package, and I do plan to switch to
>> the magick package in the future instead of using ImageMagick as a
>> system dependency.
>>
>> Regards,
>> Yihui
>> --
>> https://yihui.name
>>
>>
>> On Wed, Mar 15, 2017 at 12:32 AM, Bert Gunter <[hidden email]>
>> wrote:
>> > A google search on "ImageMagick Package R" brought this up, which
>> > seems relevant:
>> >
>> > https://cran.r-project.org/web/packages/magick/vignettes/intro.html
>> >
>> > -- Bert
>> >
>> >
>> > Bert Gunter
>> >
>> > "The trouble with having an open mind is that people keep coming along
>> > and sticking things into it."
>> > -- Opus (aka Berkeley Breathed in his "Bloom County" comic strip )
>> >
>> >
>> > On Tue, Mar 14, 2017 at 10:21 PM, C W <[hidden email]> wrote:
>> >> Dear list,
>> >>
>> >> I am trying to use saveGIF() from library animation.
>> >> https://cran.r-project.org/web/packages/animation/animation.pdf
>> >>
>> >> saveGIF() has dependency on package ImageMagick.
>> >>
>> >> I got the following,
>> >>> install.packages("ImageMagick")
>> >> Warning in install.packages :
>> >>   package ‘ImageMagick’ is not available (for R version 3.3.2)
>> >>
>> >> Does that mean I can't use saveGIF() anymore? It seems that this is the
>> >> only package capable in R.
>> >>
>> >> Thank you in advance!
>> >>
>> >>         [[alternative HTML version deleted]]
>> >>
>> >> ______________________________________________
>> >> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
>> >> https://stat.ethz.ch/mailman/listinfo/r-help
>> >> PLEASE do read the posting guide http://www.R-project.org/posti
>> ng-guide.html
>> >> and provide commented, minimal, self-contained, reproducible code.
>> >
>> > ______________________________________________
>> > [hidden email] mailing list -- To UNSUBSCRIBE and more, see
>> > https://stat.ethz.ch/mailman/listinfo/r-help
>> > PLEASE do read the posting guide http://www.R-project.org/posti
>> ng-guide.html
>> > and provide commented, minimal, self-contained, reproducible code.
>>
>
>

        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Loading...