Packages required but not available:

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Packages required but not available:

Roger Koenker-3
I’m trying to get my empirical Bayes package, REBayes, back in compliance with CRAN.
However, I’m not sure what to do about the following from R CMD check —as-cran on
the current R-devel:

Strong dependencies not in mainstream repositories:
  pogs
* checking package namespace information ... OK
* checking package dependencies ... ERROR
Packages required but not available: 'Rmosek' 'reliaR' ‘pogs'

pogs is available here:  http://foges.github.io/pogs/ref/admm
Rmosek seems to be back on CRAN but perhaps not happily on osx
reliaR seems to be on CRAN

All three of these packages appear on the imports line of my DESCRIPTION file.
Could someone clue me in on what to do?
Thanks,
Roger


url:    www.econ.uiuc.edu/~roger            Roger Koenker
email    [hidden email]            Department of Economics
vox:     217-333-4558                University of Illinois
fax:       217-244-6678                Urbana, IL 61801

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Reply | Threaded
Open this post in threaded view
|

Re: Packages required but not available:

RKoenker
I misunderstood this message, and now realize that it was attributable to the (obvious) fact that these extra
packages were not installed on MY machine since I'd just upgraded to R-devel.  The pogs package still produces
a NOTE, but hopefully that is not a deal breaker for CRAN.
Reply | Threaded
Open this post in threaded view
|

Re: Packages required but not available:

hadley wickham
Note this bullet in the CRAN policies:

Packages on which a CRAN package depends should be available from a
mainstream repository: if any mentioned in ‘Suggests’ or ‘Enhances’
fields are not from such a repository, where to obtain them at a
repository should be specified in an ‘Additional_repositories’ field
of the DESCRIPTION file (as a comma-separated list of repository URLs)
or for other means of access, described in the ‘Description’ field.


A number of people have had success using Dirk's drat package to make
such additional repositories.

Hadley

On Mon, Aug 31, 2015 at 1:21 PM, RKoenker <[hidden email]> wrote:

> I misunderstood this message, and now realize that it was attributable to the
> (obvious) fact that these extra
> packages were not installed on MY machine since I'd just upgraded to
> R-devel.  The pogs package still produces
> a NOTE, but hopefully that is not a deal breaker for CRAN.
>
>
>
> --
> View this message in context: http://r.789695.n4.nabble.com/Packages-required-but-not-available-tp4711662p4711685.html
> Sent from the R devel mailing list archive at Nabble.com.
>
> ______________________________________________
> [hidden email] mailing list
> https://stat.ethz.ch/mailman/listinfo/r-devel



--
http://had.co.nz/

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel