R Graphics: Device 2 (Active)

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

R Graphics: Device 2 (Active)

jacksonmrodrigues@gmail.com
Hi,

after updating R and RStudio I am no longer able to see my plots in the
plot pane. Instead a new window opens called: R Graphics: Device 2 (Active).

I tried to use dev.off(), reinstalling, update again and etc but it does
not help.

I've checked this discussion list but I could not find any solution.

The following are some info about my R version

> sessionInfo()

R version 3.3.2 (2016-10-31)

Platform: x86_64-w64-mingw32/x64 (64-bit)

Running under: Windows >= 8 x64 (build 9200)

locale:

[1] LC_COLLATE=Portuguese_Brazil.1252  LC_CTYPE=Portuguese_Brazil.1252

[3] LC_MONETARY=Portuguese_Brazil.1252 LC_NUMERIC=C

[5] LC_TIME=Portuguese_Brazil.1252


attached base packages:

[1] stats     graphics  grDevices utils     datasets  methods   base

other attached packages:

 [1] RColorBrewer_1.1-2 labdsv_1.8-0       cluster_2.0.5      MASS_7.3-45


 [5] mgcv_1.8-15        nlme_3.1-128       analogue_0.17-0    vegan_2.4-1


 [9] lattice_0.20-34    permute_0.9-4

loaded via a namespace (and not attached):

[1] Matrix_1.2-7.1   parallel_3.3.2   tools_3.3.2      brglm_0.5-9

[5] grid_3.3.2       princurve_1.1-12


$version

[1] ‘0.99.441’


Any help are very welcome.

Thanks

Jackson

        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: R Graphics: Device 2 (Active)

Rui Barradas
Hello,

That's a question for R Studio, ask here: https://support.rstudio.com

Hope this helps,

Rui Barradas


Em 23-01-2017 18:19, Jackson Rodrigues escreveu:

> Hi,
>
> after updating R and RStudio I am no longer able to see my plots in the
> plot pane. Instead a new window opens called: R Graphics: Device 2 (Active).
>
> I tried to use dev.off(), reinstalling, update again and etc but it does
> not help.
>
> I've checked this discussion list but I could not find any solution.
>
> The following are some info about my R version
>
>> sessionInfo()
>
> R version 3.3.2 (2016-10-31)
>
> Platform: x86_64-w64-mingw32/x64 (64-bit)
>
> Running under: Windows >= 8 x64 (build 9200)
>
> locale:
>
> [1] LC_COLLATE=Portuguese_Brazil.1252  LC_CTYPE=Portuguese_Brazil.1252
>
> [3] LC_MONETARY=Portuguese_Brazil.1252 LC_NUMERIC=C
>
> [5] LC_TIME=Portuguese_Brazil.1252
>
>
> attached base packages:
>
> [1] stats     graphics  grDevices utils     datasets  methods   base
>
> other attached packages:
>
>   [1] RColorBrewer_1.1-2 labdsv_1.8-0       cluster_2.0.5      MASS_7.3-45
>
>
>   [5] mgcv_1.8-15        nlme_3.1-128       analogue_0.17-0    vegan_2.4-1
>
>
>   [9] lattice_0.20-34    permute_0.9-4
>
> loaded via a namespace (and not attached):
>
> [1] Matrix_1.2-7.1   parallel_3.3.2   tools_3.3.2      brglm_0.5-9
>
> [5] grid_3.3.2       princurve_1.1-12
>
>
> $version
>
> [1] ‘0.99.441’
>
>
> Any help are very welcome.
>
> Thanks
>
> Jackson
>
> [[alternative HTML version deleted]]
>
> ______________________________________________
> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.
>

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: R Graphics: Device 2 (Active)

Jeff Newmiller
In reply to this post by jacksonmrodrigues@gmail.com
You need to be clear in your own mind about the distinction between RStudio and R before you can communicate clearly about it.  Specifically, we don't know how to debug problems with RStudio here, and what you describe sounds completely normal for the R Gui program that ships with R.

It sounds to me like you need to communicate with RStudio support, but providing a reproducible example here, run from R Gui rather than RStudio, could make the issue more clear.
--
Sent from my phone. Please excuse my brevity.

On January 23, 2017 10:19:02 AM PST, Jackson Rodrigues <[hidden email]> wrote:

>Hi,
>
>after updating R and RStudio I am no longer able to see my plots in the
>plot pane. Instead a new window opens called: R Graphics: Device 2
>(Active).
>
>I tried to use dev.off(), reinstalling, update again and etc but it
>does
>not help.
>
>I've checked this discussion list but I could not find any solution.
>
>The following are some info about my R version
>
>> sessionInfo()
>
>R version 3.3.2 (2016-10-31)
>
>Platform: x86_64-w64-mingw32/x64 (64-bit)
>
>Running under: Windows >= 8 x64 (build 9200)
>
>locale:
>
>[1] LC_COLLATE=Portuguese_Brazil.1252  LC_CTYPE=Portuguese_Brazil.1252
>
>[3] LC_MONETARY=Portuguese_Brazil.1252 LC_NUMERIC=C
>
>[5] LC_TIME=Portuguese_Brazil.1252
>
>
>attached base packages:
>
>[1] stats     graphics  grDevices utils     datasets  methods   base
>
>other attached packages:
>
>[1] RColorBrewer_1.1-2 labdsv_1.8-0       cluster_2.0.5    
>MASS_7.3-45
>
>
>[5] mgcv_1.8-15        nlme_3.1-128       analogue_0.17-0  
>vegan_2.4-1
>
>
> [9] lattice_0.20-34    permute_0.9-4
>
>loaded via a namespace (and not attached):
>
>[1] Matrix_1.2-7.1   parallel_3.3.2   tools_3.3.2      brglm_0.5-9
>
>[5] grid_3.3.2       princurve_1.1-12
>
>
>$version
>
>[1] ‘0.99.441’
>
>
>Any help are very welcome.
>
>Thanks
>
>Jackson
>
> [[alternative HTML version deleted]]
>
>______________________________________________
>[hidden email] mailing list -- To UNSUBSCRIBE and more, see
>https://stat.ethz.ch/mailman/listinfo/r-help
>PLEASE do read the posting guide
>http://www.R-project.org/posting-guide.html
>and provide commented, minimal, self-contained, reproducible code.

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: R Graphics: Device 2 (Active)

Bert Gunter-2
In reply to this post by jacksonmrodrigues@gmail.com
This sounds like an RStudio issue to me (just a not-so-informed guess,
though). Did you reinstall that, too? Did you look/post on RStudio's
site?

Cheers,
Bert


Bert Gunter

"The trouble with having an open mind is that people keep coming along
and sticking things into it."
-- Opus (aka Berkeley Breathed in his "Bloom County" comic strip )


On Mon, Jan 23, 2017 at 10:19 AM, Jackson Rodrigues
<[hidden email]> wrote:

> Hi,
>
> after updating R and RStudio I am no longer able to see my plots in the
> plot pane. Instead a new window opens called: R Graphics: Device 2 (Active).
>
> I tried to use dev.off(), reinstalling, update again and etc but it does
> not help.
>
> I've checked this discussion list but I could not find any solution.
>
> The following are some info about my R version
>
>> sessionInfo()
>
> R version 3.3.2 (2016-10-31)
>
> Platform: x86_64-w64-mingw32/x64 (64-bit)
>
> Running under: Windows >= 8 x64 (build 9200)
>
> locale:
>
> [1] LC_COLLATE=Portuguese_Brazil.1252  LC_CTYPE=Portuguese_Brazil.1252
>
> [3] LC_MONETARY=Portuguese_Brazil.1252 LC_NUMERIC=C
>
> [5] LC_TIME=Portuguese_Brazil.1252
>
>
> attached base packages:
>
> [1] stats     graphics  grDevices utils     datasets  methods   base
>
> other attached packages:
>
>  [1] RColorBrewer_1.1-2 labdsv_1.8-0       cluster_2.0.5      MASS_7.3-45
>
>
>  [5] mgcv_1.8-15        nlme_3.1-128       analogue_0.17-0    vegan_2.4-1
>
>
>  [9] lattice_0.20-34    permute_0.9-4
>
> loaded via a namespace (and not attached):
>
> [1] Matrix_1.2-7.1   parallel_3.3.2   tools_3.3.2      brglm_0.5-9
>
> [5] grid_3.3.2       princurve_1.1-12
>
>
> $version
>
> [1] ‘0.99.441’
>
>
> Any help are very welcome.
>
> Thanks
>
> Jackson
>
>         [[alternative HTML version deleted]]
>
> ______________________________________________
> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: R Graphics: Device 2 (Active)

glsnow
In reply to this post by jacksonmrodrigues@gmail.com
What is the result of running:

getOption("device")

?

It should be something like: "RStudioGD".  It sounds like this has
been changed to something else, if that is the case it is a matter of
either changing it back, or figuring out where the change is being
made and fixing that.

On Mon, Jan 23, 2017 at 11:19 AM, Jackson Rodrigues
<[hidden email]> wrote:

> Hi,
>
> after updating R and RStudio I am no longer able to see my plots in the
> plot pane. Instead a new window opens called: R Graphics: Device 2 (Active).
>
> I tried to use dev.off(), reinstalling, update again and etc but it does
> not help.
>
> I've checked this discussion list but I could not find any solution.
>
> The following are some info about my R version
>
>> sessionInfo()
>
> R version 3.3.2 (2016-10-31)
>
> Platform: x86_64-w64-mingw32/x64 (64-bit)
>
> Running under: Windows >= 8 x64 (build 9200)
>
> locale:
>
> [1] LC_COLLATE=Portuguese_Brazil.1252  LC_CTYPE=Portuguese_Brazil.1252
>
> [3] LC_MONETARY=Portuguese_Brazil.1252 LC_NUMERIC=C
>
> [5] LC_TIME=Portuguese_Brazil.1252
>
>
> attached base packages:
>
> [1] stats     graphics  grDevices utils     datasets  methods   base
>
> other attached packages:
>
>  [1] RColorBrewer_1.1-2 labdsv_1.8-0       cluster_2.0.5      MASS_7.3-45
>
>
>  [5] mgcv_1.8-15        nlme_3.1-128       analogue_0.17-0    vegan_2.4-1
>
>
>  [9] lattice_0.20-34    permute_0.9-4
>
> loaded via a namespace (and not attached):
>
> [1] Matrix_1.2-7.1   parallel_3.3.2   tools_3.3.2      brglm_0.5-9
>
> [5] grid_3.3.2       princurve_1.1-12
>
>
> $version
>
> [1] ‘0.99.441’
>
>
> Any help are very welcome.
>
> Thanks
>
> Jackson
>
>         [[alternative HTML version deleted]]
>
> ______________________________________________
> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.



--
Gregory (Greg) L. Snow Ph.D.
[hidden email]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.