RExcel issues

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

RExcel issues

Michael Ashton-3
Hi -

For a while I've used RExcel without problems to run a repeating portfolio optimization problem where I solve for a portfolio allocation targeting a particular risk, then solve for a different risk, etc. I call the commands with (e.g.) rinterface.Rrun "(R command)"

Recently that macro started blowing up, returning #RErrors, and when I try to trace the error I find that it is some kind of OLE error. I can't seem to find anything about it online and it's hard to replicate for someone else since you'd have to have my installation and my spreadsheet.

But I thought I'd ask the community and see if anyone else has had this problem recently with Rexcel. I'm calling solnp from within the RRun command, but again...it worked for a long time and I don't think it's the inputs that are wonky. Perhaps an update of R was incompatible with Rexcel? I've updated Rexcel to 3.2.16 but it made no difference.

Any suggestions of what to try will be warmly entertained!

Thanks,

Mike

Michael Ashton, CFA
Managing Principal

Enduring Investments LLC
W: 973.457.4602
C: 551.655.8006


        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: RExcel issues

David Winsemius

> On Mar 1, 2018, at 2:02 PM, Michael Ashton <[hidden email]> wrote:
>
> Hi -
>
> For a while I've used RExcel without problems to run a repeating portfolio optimization problem where I solve for a portfolio allocation targeting a particular risk, then solve for a different risk, etc. I call the commands with (e.g.) rinterface.Rrun "(R command)"
>
> Recently that macro started blowing up, returning #RErrors, and when I try to trace the error I find that it is some kind of OLE error. I can't seem to find anything about it online and it's hard to replicate for someone else since you'd have to have my installation and my spreadsheet.
>
> But I thought I'd ask the community and see if anyone else has had this problem recently with Rexcel. I'm calling solnp from within the RRun command, but again...it worked for a long time and I don't think it's the inputs that are wonky. Perhaps an update of R was incompatible with Rexcel? I've updated Rexcel to 3.2.16 but it made no difference.

I'm pretty sure that RExcel is a commercial program and I assume that licensed users are expected to bring problems to the vendor.

http://rcom.univie.ac.at/contact.html


>
> Any suggestions of what to try will be warmly entertained!
>
> Thanks,
>
> Mike
>
> Michael Ashton, CFA
> Managing Principal
>
> Enduring Investments LLC
> W: 973.457.4602
> C: 551.655.8006

I assume with that address you have a commercial license.

--

David Winsemius
Alameda, CA, USA

'Any technology distinguishable from magic is insufficiently advanced.'   -Gehm's Corollary to Clarke's Third Law

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: RExcel issues

Michael Ashton-3
No, this is home use. I wasn’t even aware there was a commercial license.

> On Mar 1, 2018, at 5:37 PM, David Winsemius <[hidden email]> wrote:
>
>
>> On Mar 1, 2018, at 2:02 PM, Michael Ashton <[hidden email]> wrote:
>>
>> Hi -
>>
>> For a while I've used RExcel without problems to run a repeating portfolio optimization problem where I solve for a portfolio allocation targeting a particular risk, then solve for a different risk, etc. I call the commands with (e.g.) rinterface.Rrun "(R command)"
>>
>> Recently that macro started blowing up, returning #RErrors, and when I try to trace the error I find that it is some kind of OLE error. I can't seem to find anything about it online and it's hard to replicate for someone else since you'd have to have my installation and my spreadsheet.
>>
>> But I thought I'd ask the community and see if anyone else has had this problem recently with Rexcel. I'm calling solnp from within the RRun command, but again...it worked for a long time and I don't think it's the inputs that are wonky. Perhaps an update of R was incompatible with Rexcel? I've updated Rexcel to 3.2.16 but it made no difference.
>
> I'm pretty sure that RExcel is a commercial program and I assume that licensed users are expected to bring problems to the vendor.
>
> http://rcom.univie.ac.at/contact.html
>
>
>>
>> Any suggestions of what to try will be warmly entertained!
>>
>> Thanks,
>>
>> Mike
>>
>> Michael Ashton, CFA
>> Managing Principal
>>
>> Enduring Investments LLC
>> W: 973.457.4602
>> C: 551.655.8006
>
> I assume with that address you have a commercial license.
>
> --
>
> David Winsemius
> Alameda, CA, USA
>
> 'Any technology distinguishable from magic is insufficiently advanced.'   -Gehm's Corollary to Clarke's Third Law
>
>
>
>

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: RExcel issues

Michael Ashton-3
In reply to this post by David Winsemius
Thanks though - didn’t know there was that ecosystem. I will try that list.

> On Mar 1, 2018, at 5:37 PM, David Winsemius <[hidden email]> wrote:
>
>
>> On Mar 1, 2018, at 2:02 PM, Michael Ashton <[hidden email]> wrote:
>>
>> Hi -
>>
>> For a while I've used RExcel without problems to run a repeating portfolio optimization problem where I solve for a portfolio allocation targeting a particular risk, then solve for a different risk, etc. I call the commands with (e.g.) rinterface.Rrun "(R command)"
>>
>> Recently that macro started blowing up, returning #RErrors, and when I try to trace the error I find that it is some kind of OLE error. I can't seem to find anything about it online and it's hard to replicate for someone else since you'd have to have my installation and my spreadsheet.
>>
>> But I thought I'd ask the community and see if anyone else has had this problem recently with Rexcel. I'm calling solnp from within the RRun command, but again...it worked for a long time and I don't think it's the inputs that are wonky. Perhaps an update of R was incompatible with Rexcel? I've updated Rexcel to 3.2.16 but it made no difference.
>
> I'm pretty sure that RExcel is a commercial program and I assume that licensed users are expected to bring problems to the vendor.
>
> http://rcom.univie.ac.at/contact.html
>
>
>>
>> Any suggestions of what to try will be warmly entertained!
>>
>> Thanks,
>>
>> Mike
>>
>> Michael Ashton, CFA
>> Managing Principal
>>
>> Enduring Investments LLC
>> W: 973.457.4602
>> C: 551.655.8006
>
> I assume with that address you have a commercial license.
>
> --
>
> David Winsemius
> Alameda, CA, USA
>
> 'Any technology distinguishable from magic is insufficiently advanced.'   -Gehm's Corollary to Clarke's Third Law
>
>
>
>

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.