TEXINFO error when building R-3.4.0

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

TEXINFO error when building R-3.4.0

Avraham Adler
Hello.

I am trying to build 64 bit R-3.4.0 (specifically
R-patched_2017-04-23) on Windows 64 and have run into an issue with
building the html files. I am using Rtools34 version 1962, the texinfo
zip from <http://www.stats.ox.ac.uk/pub/Rtools/> unzipped into
C:\R\texinfo, and Strawberry perl 5.24.1.1-64bit. In my MkRules.local
I have the following, which worked for building R in 3.3.x:

# set this to YES to build static HTML help
BUILD_HTML = YES

# unset this if you are *not* using MiKTeX
MIKTEX = TRUE
# Recent MiKTEX does not provide texi2dvi and needs something like
TEXI2DVI = TEXINDEX=C:/Rtools/bin/texindex.exe texify

# for texinfo >= 5.1. If the texinfo files are installed at /packages/texinfo,
TEXI2ANY = C:/Strawberry/perl/bin/perl.exe -I/C:/R/texinfo C:/R/texinfo/texi2any
# if you do not have texinfo (default),
# TEXI2ANY = missing

Nevertheless, while building R-3.4 I get the following error:


------ Making HTML documentation ------
creating doc/manual/version.texi
creating doc/manual/R-FAQ.html
Can't locate Texinfo/Convert/Texinfo.pm in @INC (you may need to install the Tex
info::Convert::Texinfo module) (@INC contains: \usr\local\share\texinfo\lib\Text
-Unidecode\lib \usr\local\share\texinfo\lib\Unicode-EastAsianWidth\lib \usr\loca
l\share\texinfo\lib\libintl-perl\lib \usr\local\share\texinfo /C:/R/texinfo C:/S
trawberry/perl/site/lib C:/Strawberry/perl/vendor/lib C:/Strawberry/perl/lib .)
at C:/R/texinfo/texi2any line 100.
BEGIN failed--compilation aborted at C:/R/texinfo/texi2any line 100.
sed: can't read R-FAQ.html.tmp: No such file or directory
make[3]: *** [R-FAQ.html] Error 2
make[2]: *** [htmldocs] Error 2
make[1]: *** [all] Error 2
make: *** [distribution] Error 2

If it helps, Convert seems to be found in C:\R\texinfo\Texinfo\Convert
which is not in the list of @INC. Any and all help would be
appreciated.

Thank you,

Avi

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Reply | Threaded
Open this post in threaded view
|

Re: TEXINFO error when building R-3.4.0

Avraham Adler
The fault was mine.

-I/C:/R/texinfo should have been -IC:/R/texinfo

Thank you,

Avi

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel