Ubuntu 18.04 / R 3.4.4 / shinyjs / V8

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Ubuntu 18.04 / R 3.4.4 / shinyjs / V8

Sigbert Klinke
Hi,

if I want to use shinyjs package then I need the V8 package.
Therefore I installed

apt-get install libv8-3.14-dev

and tried

install.packages("V8")

and get

** preparing package for lazy loading
Error in dyn.load(file, DLLpath = DLLpath, ...) :
   kann shared object
'/home/sigbert/R/x86_64-pc-linux-gnu-library/3.4/curl/libs/curl.so'
nicht laden:
   /usr/lib/x86_64-linux-gnu/libcurl.so.4: version `CURL_OPENSSL_3' not
found (required by
/home/sigbert/R/x86_64-pc-linux-gnu-library/3.4/curl/libs/curl.so)
ERROR: lazy loading failed for package ‘V8’

I also tried to install curl3, but when I install R 3.4.4 then curl3 is
replaced by curl4 :(

Any ideas what I could do?

Thanks

Sigbert

--
Sprechstunde: Fr 12-13, SPA1, R308
https://hu.berlin/sk
https://hu.berlin/mmstat3


______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: Ubuntu 18.04 / R 3.4.4 / shinyjs / V8

Sigbert Klinke
Hi,

found myself a workaround:

Replaced the javascript functionality by calls of
session$sendCustomMesssage(...) & Sys.sleep(...) and deleted
library(shinyjs) from my code.

Best Sigbert

Am 06.06.2018 um 10:33 schrieb Sigbert Klinke:

> Hi,
>
> if I want to use shinyjs package then I need the V8 package.
> Therefore I installed
>
> apt-get install libv8-3.14-dev
>
> and tried
>
> install.packages("V8")
>
> and get
>
> ** preparing package for lazy loading
> Error in dyn.load(file, DLLpath = DLLpath, ...) :
>    kann shared object
> '/home/sigbert/R/x86_64-pc-linux-gnu-library/3.4/curl/libs/curl.so'
> nicht laden:
>    /usr/lib/x86_64-linux-gnu/libcurl.so.4: version `CURL_OPENSSL_3' not
> found (required by
> /home/sigbert/R/x86_64-pc-linux-gnu-library/3.4/curl/libs/curl.so)
> ERROR: lazy loading failed for package ‘V8’
>
> I also tried to install curl3, but when I install R 3.4.4 then curl3 is
> replaced by curl4 :(
>
> Any ideas what I could do?
>
> Thanks
>
> Sigbert
>
>
>
> ______________________________________________
> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.
>

--
Sprechstunde: Fr 12-13, SPA1, R308
https://hu.berlin/sk
https://hu.berlin/mmstat3


______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.