UseDevel: version requires a more recent R

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

UseDevel: version requires a more recent R

Gneuro
Hello R experts:

I need a developer version of a Bioconductor library.

> sessionInfo()
R version 3.4.2 (2017-09-28)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 7 x64 (build 7601) Service Pack 1

When I try to useDevel it fails.

I've removed packages and again loaded but I get the same error message.

remove.packages("BiocInstaller")
source("https://bioconductor.org/biocLite.R")
library(BiocInstaller)

Bioconductor version 3.6 (BiocInstaller 1.28.0), ?biocLite for help


> useDevel()

Error: 'devel' version requires a more recent R

I'm running into this error for few days now. I close R after removing biocInstaller and proceed with following steps.

Please guide me to fix this.

Thanks,
SS

        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: UseDevel: version requires a more recent R

Martin Morgan-3
Ask questions about Bioconductor on the support site

   https://support.bioconductor.org

Bioconductor versions are tied to particular R versions. The current
Bioc-devel requires use of R-devel. You're using R-3.4.2, so need to
install the devel version of R.

Additional information is at

   http://bioconductor.org/developers/how-to/useDevel/

Martin Morgan

On 01/09/2018 01:32 PM, Sariya, Sanjeev wrote:

> Hello R experts:
>
> I need a developer version of a Bioconductor library.
>
>> sessionInfo()
> R version 3.4.2 (2017-09-28)
> Platform: x86_64-w64-mingw32/x64 (64-bit)
> Running under: Windows 7 x64 (build 7601) Service Pack 1
>
> When I try to useDevel it fails.
>
> I've removed packages and again loaded but I get the same error message.
>
> remove.packages("BiocInstaller")
> source("https://bioconductor.org/biocLite.R")
> library(BiocInstaller)
>
> Bioconductor version 3.6 (BiocInstaller 1.28.0), ?biocLite for help
>
>
>> useDevel()
>
> Error: 'devel' version requires a more recent R
>
> I'm running into this error for few days now. I close R after removing biocInstaller and proceed with following steps.
>
> Please guide me to fix this.
>
> Thanks,
> SS
>
> [[alternative HTML version deleted]]
>
> ______________________________________________
> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.
>


This email message may contain legally privileged and/or...{{dropped:2}}

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: UseDevel: version requires a more recent R

Bert Gunter-2
In reply to this post by Gneuro
Obvious response:

Post this on the Bioconductor support site, not here:

https://support.bioconductor.org/

Cheers,
Bert


Bert Gunter

"The trouble with having an open mind is that people keep coming along
and sticking things into it."
-- Opus (aka Berkeley Breathed in his "Bloom County" comic strip )


On Tue, Jan 9, 2018 at 10:32 AM, Sariya, Sanjeev
<[hidden email]> wrote:

> Hello R experts:
>
> I need a developer version of a Bioconductor library.
>
>> sessionInfo()
> R version 3.4.2 (2017-09-28)
> Platform: x86_64-w64-mingw32/x64 (64-bit)
> Running under: Windows 7 x64 (build 7601) Service Pack 1
>
> When I try to useDevel it fails.
>
> I've removed packages and again loaded but I get the same error message.
>
> remove.packages("BiocInstaller")
> source("https://bioconductor.org/biocLite.R")
> library(BiocInstaller)
>
> Bioconductor version 3.6 (BiocInstaller 1.28.0), ?biocLite for help
>
>
>> useDevel()
>
> Error: 'devel' version requires a more recent R
>
> I'm running into this error for few days now. I close R after removing biocInstaller and proceed with following steps.
>
> Please guide me to fix this.
>
> Thanks,
> SS
>
>         [[alternative HTML version deleted]]
>
> ______________________________________________
> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: UseDevel: version requires a more recent R

Jeff Newmiller
In reply to this post by Gneuro
Wrong forum.

https://support.bioconductor.org/
--
Sent from my phone. Please excuse my brevity.

On January 9, 2018 10:32:15 AM PST, "Sariya, Sanjeev" <[hidden email]> wrote:

>Hello R experts:
>
>I need a developer version of a Bioconductor library.
>
>> sessionInfo()
>R version 3.4.2 (2017-09-28)
>Platform: x86_64-w64-mingw32/x64 (64-bit)
>Running under: Windows 7 x64 (build 7601) Service Pack 1
>
>When I try to useDevel it fails.
>
>I've removed packages and again loaded but I get the same error
>message.
>
>remove.packages("BiocInstaller")
>source("https://bioconductor.org/biocLite.R")
>library(BiocInstaller)
>
>Bioconductor version 3.6 (BiocInstaller 1.28.0), ?biocLite for help
>
>
>> useDevel()
>
>Error: 'devel' version requires a more recent R
>
>I'm running into this error for few days now. I close R after removing
>biocInstaller and proceed with following steps.
>
>Please guide me to fix this.
>
>Thanks,
>SS
>
> [[alternative HTML version deleted]]
>
>______________________________________________
>[hidden email] mailing list -- To UNSUBSCRIBE and more, see
>https://stat.ethz.ch/mailman/listinfo/r-help
>PLEASE do read the posting guide
>http://www.R-project.org/posting-guide.html
>and provide commented, minimal, self-contained, reproducible code.

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.