building with atlas version of blas and lapack

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

building with atlas version of blas and lapack

kl.vanw
I'd like to build R using my optimized blas and lapack libraries. It seems
know matter what I do, the configure script uses the blas supplied with the
source. My blas and lapack libraries are in /usr/local/atlas/lib. How can I
get configure to use these?

        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.

Reply | Threaded
Open this post in threaded view
|

Re: building with atlas version of blas and lapack

kl.vanw
Looks like the list-server didn't like whatever gmail does to the
formating. Sorry. So here's my post in plain text:

On 9/11/07, K Vanw <[hidden email]> wrote:
> I'd like to build R using my optimized blas and lapack libraries. It seems know matter what I
> do, the configure script uses the blas supplied with the source. My blas and lapack libraries
> are in /usr/local/atlas/lib. How can I get configure to use these?

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.

Reply | Threaded
Open this post in threaded view
|

Re: building with atlas version of blas and lapack

Yuelin Li
In reply to this post by kl.vanw
On my linux machine (Ubuntu Feisty on i-686) this works:

     ./configure --with-blas="lf77blas -latlas"

Yuelin.

-- K Vanw wrote --|Tue (Sep/11/2007)[03:56]|--:
   I'd like to build R using my optimized blas and lapack libraries. It seems
   know matter what I do, the configure script uses the blas supplied with the
   source. My blas and lapack libraries are in /usr/local/atlas/lib. How can I
   get configure to use these?
   
    [[alternative HTML version deleted]]
   
   ______________________________________________
   [hidden email] mailing list
   https://stat.ethz.ch/mailman/listinfo/r-help
   PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
   and provide commented, minimal, self-contained, reproducible code.
   

 
     =====================================================================
     
     Please note that this e-mail and any files transmitted with it may be
     privileged, confidential, and protected from disclosure under
     applicable law. If the reader of this message is not the intended
     recipient, or an employee or agent responsible for delivering this
     message to the intended recipient, you are hereby notified that any
     reading, dissemination, distribution, copying, or other use of this
     communication or any of its attachments is strictly prohibited.  If
     you have received this communication in error, please notify the
     sender immediately by replying to this message and deleting this
     message, any attachments, and all copies and backups from your
     computer.

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.

Reply | Threaded
Open this post in threaded view
|

Re: building with atlas version of blas and lapack

Uwe Ligges


Yuelin Li wrote:
> On my linux machine (Ubuntu Feisty on i-686) this works:
>
>      ./configure --with-blas="lf77blas -latlas"


Flags should be
   --with-blas="-L/usr/local/atlas/lib -lf77blas -latlas"
I guess, because /usr/local/atlas/lib is not found unless some
environment variables have been set. This is documented in the R
Installation and Administration manual, so you probably overlooked it.

Uwe Ligges


> Yuelin.
>
> -- K Vanw wrote --|Tue (Sep/11/2007)[03:56]|--:
>    I'd like to build R using my optimized blas and lapack libraries. It seems
>    know matter what I do, the configure script uses the blas supplied with the
>    source. My blas and lapack libraries are in /usr/local/atlas/lib. How can I
>    get configure to use these?
>    
>     [[alternative HTML version deleted]]
>    
>    ______________________________________________
>    [hidden email] mailing list
>    https://stat.ethz.ch/mailman/listinfo/r-help
>    PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
>    and provide commented, minimal, self-contained, reproducible code.
>    
>
>  
>      =====================================================================
>      
>      Please note that this e-mail and any files transmitted with it may be
>      privileged, confidential, and protected from disclosure under
>      applicable law. If the reader of this message is not the intended
>      recipient, or an employee or agent responsible for delivering this
>      message to the intended recipient, you are hereby notified that any
>      reading, dissemination, distribution, copying, or other use of this
>      communication or any of its attachments is strictly prohibited.  If
>      you have received this communication in error, please notify the
>      sender immediately by replying to this message and deleting this
>      message, any attachments, and all copies and backups from your
>      computer.
>
> ______________________________________________
> [hidden email] mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.

Reply | Threaded
Open this post in threaded view
|

Re: building with atlas version of blas and lapack

kl.vanw
On 9/12/07, Uwe Ligges <[hidden email]> wrote:
>
> Flags should be
>    --with-blas="-L/usr/local/atlas/lib -lf77blas -latlas"

That worked. Thanks.

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.