can not install package "matie"

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

can not install package "matie"

R help mailing list-2
Dear R-experts,

I can not install the package "matie". If somebody can tell me where the problem is.

> install.packages("matie")
Installing package into ‘/Users/Caro/Library/R/3.3/library’
(as ‘lib’ is unspecified)
essai de l'URL 'https://cran.rstudio.com/bin/macosx/mavericks/contrib/3.3/matie_1.2.tgz'
Content type 'application/x-gzip' length 80151 bytes (78 KB)
==================================================
downloaded 78 KB


The downloaded binary packages are in
    /var/folders/hj/11q7wt055rg83y2vj45whdmw0000gn/T//RtmpqjqsFe/downloaded_packages

> library(matie)
Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) :
  aucun package nommé ‘proxy’ n'est trouvé
Erreur : le chargement du package ou de l'espace de noms a échoué pour ‘matie’

Here is my sessionInfo

> sessionInfo()
R version 3.3.2 (2016-10-31)
Platform: x86_64-apple-darwin13.4.0 (64-bit)
Running under: macOS Sierra 10.12.4

locale:
[1] fr_CH.UTF-8/fr_CH.UTF-8/fr_CH.UTF-8/C/fr_CH.UTF-8/fr_CH.UTF-8

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
 [1] Rcpp_0.12.7        DEoptimR_1.0-6     plyr_1.8.4         viridis_0.3.4      class_7.3-14      
 [6] bitops_1.0-6       iterators_1.0.8    tools_3.3.2        prabclus_2.2-6     dendextend_1.7.0  
[11] mclust_5.4         tibble_1.2         gtable_0.2.0       lattice_0.20-34    pkgconfig_2.0.1   
[16] igraph_1.1.2       foreach_1.4.3      registry_0.5       mvtnorm_1.0-5      seriation_1.2-2   
[21] TSP_1.1-5          gridExtra_2.2.1    trimcluster_0.1-2  cluster_2.0.5      gtools_3.5.0      
[26] caTools_1.17.1     fpc_2.1-11         diptest_0.75-7     stats4_3.3.2       grid_3.3.2        
[31] nnet_7.3-12        robustbase_0.92-8  flexmix_2.3-14     dfoptim_2017.12-1  gdata_2.18.0      
[36] kernlab_0.9-25     ggplot2_2.2.1      magrittr_1.5       whisker_0.3-2      scales_0.4.1      
[41] gplots_3.0.1       codetools_0.2-15   gclus_1.3.1        modeltools_0.2-21  MASS_7.3-48       
[46] assertthat_0.1     colorspace_1.2-7   KernSmooth_2.23-15 lazyeval_0.2.0     munsell_0.4.3     

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: can not install package "matie"

Duncan Murdoch-2
On 28/03/2018 6:27 PM, varin sacha via R-help wrote:

> Dear R-experts,
>
> I can not install the package "matie". If somebody can tell me where the problem is.
>
>> install.packages("matie")
> Installing package into ‘/Users/Caro/Library/R/3.3/library’
> (as ‘lib’ is unspecified)
> essai de l'URL 'https://cran.rstudio.com/bin/macosx/mavericks/contrib/3.3/matie_1.2.tgz'
> Content type 'application/x-gzip' length 80151 bytes (78 KB)
> ==================================================
> downloaded 78 KB
>
>
> The downloaded binary packages are in
>      /var/folders/hj/11q7wt055rg83y2vj45whdmw0000gn/T//RtmpqjqsFe/downloaded_packages
>
>> library(matie)
> Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) :
>    aucun package nommé ‘proxy’ n'est trouvé
> Erreur : le chargement du package ou de l'espace de noms a échoué pour ‘matie’

The 'matie' package depends on 'proxy', and 'proxy' depends on R version
3.4.0 or more.  You could try installing 'proxy' using
install.pacakges("proxy"), but I'm guessing it will fail unless you
update your R version first.

Duncan Murdoch


>
> Here is my sessionInfo
>
>> sessionInfo()
> R version 3.3.2 (2016-10-31)
> Platform: x86_64-apple-darwin13.4.0 (64-bit)
> Running under: macOS Sierra 10.12.4
>
> locale:
> [1] fr_CH.UTF-8/fr_CH.UTF-8/fr_CH.UTF-8/C/fr_CH.UTF-8/fr_CH.UTF-8
>
> attached base packages:
> [1] stats     graphics  grDevices utils     datasets  methods   base
>
> loaded via a namespace (and not attached):
>   [1] Rcpp_0.12.7        DEoptimR_1.0-6     plyr_1.8.4         viridis_0.3.4      class_7.3-14
>   [6] bitops_1.0-6       iterators_1.0.8    tools_3.3.2        prabclus_2.2-6     dendextend_1.7.0
> [11] mclust_5.4         tibble_1.2         gtable_0.2.0       lattice_0.20-34    pkgconfig_2.0.1
> [16] igraph_1.1.2       foreach_1.4.3      registry_0.5       mvtnorm_1.0-5      seriation_1.2-2
> [21] TSP_1.1-5          gridExtra_2.2.1    trimcluster_0.1-2  cluster_2.0.5      gtools_3.5.0
> [26] caTools_1.17.1     fpc_2.1-11         diptest_0.75-7     stats4_3.3.2       grid_3.3.2
> [31] nnet_7.3-12        robustbase_0.92-8  flexmix_2.3-14     dfoptim_2017.12-1  gdata_2.18.0
> [36] kernlab_0.9-25     ggplot2_2.2.1      magrittr_1.5       whisker_0.3-2      scales_0.4.1
> [41] gplots_3.0.1       codetools_0.2-15   gclus_1.3.1        modeltools_0.2-21  MASS_7.3-48
> [46] assertthat_0.1     colorspace_1.2-7   KernSmooth_2.23-15 lazyeval_0.2.0     munsell_0.4.3
>
> ______________________________________________
> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.
>

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: can not install package "matie"

Jeff Newmiller
Varin

In the teaching you to fish department, you can find those dependencies Duncan appeared to pull out of thin air by looking at the CRAN contributed packages web pages, which can easily be found with Google. Start at the matie page and follow the dependency links and look at dependencies. In particular the error message mentioning the proxy package is a clue that dependencies might be a problem.
--
Sent from my phone. Please excuse my brevity.

On March 28, 2018 3:38:27 PM PDT, Duncan Murdoch <[hidden email]> wrote:

>On 28/03/2018 6:27 PM, varin sacha via R-help wrote:
>> Dear R-experts,
>>
>> I can not install the package "matie". If somebody can tell me where
>the problem is.
>>
>>> install.packages("matie")
>> Installing package into ‘/Users/Caro/Library/R/3.3/library’
>> (as ‘lib’ is unspecified)
>> essai de l'URL
>'https://cran.rstudio.com/bin/macosx/mavericks/contrib/3.3/matie_1.2.tgz'
>> Content type 'application/x-gzip' length 80151 bytes (78 KB)
>> ==================================================
>> downloaded 78 KB
>>
>>
>> The downloaded binary packages are in
>>    
> /var/folders/hj/11q7wt055rg83y2vj45whdmw0000gn/T//RtmpqjqsFe/downloaded_packages
>>
>>> library(matie)
>> Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck =
>vI[[i]]) :
>>    aucun package nommé ‘proxy’ n'est trouvé
>> Erreur : le chargement du package ou de l'espace de noms a échoué
>pour ‘matie’
>
>The 'matie' package depends on 'proxy', and 'proxy' depends on R
>version
>3.4.0 or more.  You could try installing 'proxy' using
>install.pacakges("proxy"), but I'm guessing it will fail unless you
>update your R version first.
>
>Duncan Murdoch
>
>
>>
>> Here is my sessionInfo
>>
>>> sessionInfo()
>> R version 3.3.2 (2016-10-31)
>> Platform: x86_64-apple-darwin13.4.0 (64-bit)
>> Running under: macOS Sierra 10.12.4
>>
>> locale:
>> [1] fr_CH.UTF-8/fr_CH.UTF-8/fr_CH.UTF-8/C/fr_CH.UTF-8/fr_CH.UTF-8
>>
>> attached base packages:
>> [1] stats     graphics  grDevices utils     datasets  methods   base
>>
>> loaded via a namespace (and not attached):
>>   [1] Rcpp_0.12.7        DEoptimR_1.0-6     plyr_1.8.4        
>viridis_0.3.4      class_7.3-14
>>   [6] bitops_1.0-6       iterators_1.0.8    tools_3.3.2       
>prabclus_2.2-6     dendextend_1.7.0
>> [11] mclust_5.4         tibble_1.2         gtable_0.2.0      
>lattice_0.20-34    pkgconfig_2.0.1
>> [16] igraph_1.1.2       foreach_1.4.3      registry_0.5      
>mvtnorm_1.0-5      seriation_1.2-2
>> [21] TSP_1.1-5          gridExtra_2.2.1    trimcluster_0.1-2 
>cluster_2.0.5      gtools_3.5.0
>> [26] caTools_1.17.1     fpc_2.1-11         diptest_0.75-7    
>stats4_3.3.2       grid_3.3.2
>> [31] nnet_7.3-12        robustbase_0.92-8  flexmix_2.3-14    
>dfoptim_2017.12-1  gdata_2.18.0
>> [36] kernlab_0.9-25     ggplot2_2.2.1      magrittr_1.5      
>whisker_0.3-2      scales_0.4.1
>> [41] gplots_3.0.1       codetools_0.2-15   gclus_1.3.1       
>modeltools_0.2-21  MASS_7.3-48
>> [46] assertthat_0.1     colorspace_1.2-7   KernSmooth_2.23-15
>lazyeval_0.2.0     munsell_0.4.3
>>
>> ______________________________________________
>> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
>> https://stat.ethz.ch/mailman/listinfo/r-help
>> PLEASE do read the posting guide
>http://www.R-project.org/posting-guide.html
>> and provide commented, minimal, self-contained, reproducible code.
>>
>
>______________________________________________
>[hidden email] mailing list -- To UNSUBSCRIBE and more, see
>https://stat.ethz.ch/mailman/listinfo/r-help
>PLEASE do read the posting guide
>http://www.R-project.org/posting-guide.html
>and provide commented, minimal, self-contained, reproducible code.

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: can not install package "matie"

R help mailing list-2
Dear Jeff & Duncan,

May thanks, the R update was necessary...

Best,



Le jeudi 29 mars 2018 à 02:37:01 UTC+2, Jeff Newmiller <[hidden email]> a écrit :





Varin

In the teaching you to fish department, you can find those dependencies Duncan appeared to pull out of thin air by looking at the CRAN contributed packages web pages, which can easily be found with Google. Start at the matie page and follow the dependency links and look at dependencies. In particular the error message mentioning the proxy package is a clue that dependencies might be a problem.
--
Sent from my phone. Please excuse my brevity.

On March 28, 2018 3:38:27 PM PDT, Duncan Murdoch <[hidden email]> wrote:

>On 28/03/2018 6:27 PM, varin sacha via R-help wrote:
>> Dear R-experts,
>>
>> I can not install the package "matie". If somebody can tell me where
>the problem is.
>>
>>> install.packages("matie")
>> Installing package into ‘/Users/Caro/Library/R/3.3/library’
>> (as ‘lib’ is unspecified)
>> essai de l'URL
>'https://cran.rstudio.com/bin/macosx/mavericks/contrib/3.3/matie_1.2.tgz'
>> Content type 'application/x-gzip' length 80151 bytes (78 KB)
>> ==================================================
>> downloaded 78 KB
>>
>>
>> The downloaded binary packages are in
>>    
> /var/folders/hj/11q7wt055rg83y2vj45whdmw0000gn/T//RtmpqjqsFe/downloaded_packages
>>
>>> library(matie)
>> Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck =
>vI[[i]]) :
>>    aucun package nommé ‘proxy’ n'est trouvé
>> Erreur : le chargement du package ou de l'espace de noms a échoué
>pour ‘matie’
>
>The 'matie' package depends on 'proxy', and 'proxy' depends on R
>version
>3.4.0 or more.  You could try installing 'proxy' using
>install.pacakges("proxy"), but I'm guessing it will fail unless you
>update your R version first.
>
>Duncan Murdoch
>
>
>>
>> Here is my sessionInfo
>>
>>> sessionInfo()
>> R version 3.3.2 (2016-10-31)
>> Platform: x86_64-apple-darwin13.4.0 (64-bit)
>> Running under: macOS Sierra 10.12.4
>>
>> locale:
>> [1] fr_CH.UTF-8/fr_CH.UTF-8/fr_CH.UTF-8/C/fr_CH.UTF-8/fr_CH.UTF-8
>>
>> attached base packages:
>> [1] stats     graphics  grDevices utils     datasets  methods   base
>>
>> loaded via a namespace (and not attached):
>>   [1] Rcpp_0.12.7        DEoptimR_1.0-6     plyr_1.8.4        
>viridis_0.3.4      class_7.3-14
>>   [6] bitops_1.0-6       iterators_1.0.8    tools_3.3.2       
>prabclus_2.2-6     dendextend_1.7.0
>> [11] mclust_5.4         tibble_1.2         gtable_0.2.0      
>lattice_0.20-34    pkgconfig_2.0.1
>> [16] igraph_1.1.2       foreach_1.4.3      registry_0.5      
>mvtnorm_1.0-5      seriation_1.2-2
>> [21] TSP_1.1-5          gridExtra_2.2.1    trimcluster_0.1-2 
>cluster_2.0.5      gtools_3.5.0
>> [26] caTools_1.17.1     fpc_2.1-11         diptest_0.75-7    
>stats4_3.3.2       grid_3.3.2
>> [31] nnet_7.3-12        robustbase_0.92-8  flexmix_2.3-14    
>dfoptim_2017.12-1  gdata_2.18.0
>> [36] kernlab_0.9-25     ggplot2_2.2.1      magrittr_1.5      
>whisker_0.3-2      scales_0.4.1
>> [41] gplots_3.0.1       codetools_0.2-15   gclus_1.3.1       
>modeltools_0.2-21  MASS_7.3-48
>> [46] assertthat_0.1     colorspace_1.2-7   KernSmooth_2.23-15
>lazyeval_0.2.0     munsell_0.4.3
>>
>> ______________________________________________
>> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
>> https://stat.ethz.ch/mailman/listinfo/r-help
>> PLEASE do read the posting guide
>http://www.R-project.org/posting-guide.html
>> and provide commented, minimal, self-contained, reproducible code.

>>
>
>______________________________________________
>[hidden email] mailing list -- To UNSUBSCRIBE and more, see
>https://stat.ethz.ch/mailman/listinfo/r-help
>PLEASE do read the posting guide
>http://www.R-project.org/posting-guide.html
>and provide commented, minimal, self-contained, reproducible code.

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.