hpc r configure not recognizing zlib

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

hpc r configure not recognizing zlib

Hamidi, Bashir
System: Red Hat Enterprise Linux Server release 6.5 (Santiago)

I’ve installed zlib 1.2.11 on the home folder of a Red Hat HPC as part of the process for installing R base 3.4.0.

I get this error even after successful install of zlib
checking for inflateInit2_ in -lz... no
checking whether zlib support suffices... configure: error: zlib library and headers are required

 I’ve checked R documentation and configure file for the issue of R requiring version newer than 1.2.6 but not lexicographically recognizing 1.2.11 as >1.2.6, and that particular bug was patched in 3.4.

Any suggestion and/or input would be much appreciated.

Regards,


Bashir





        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Reply | Threaded
Open this post in threaded view
|

Re: hpc r configure not recognizing zlib

Martyn Plummer-3
You do not need to compile R from source on RHEL 6. If you enable the
EPEL repository then you can install the binary RPM via yum. See

https://fedoraproject.org/wiki/EPEL

Tom Callaway, who maintains the Red Hat binaries of R, statically links
up-to-date versions of bzip2, xz, pcre, and curl into R.

Martyn

PS The R-SIG-Fedora list is a more appropriate mailing list for this
topic: https://stat.ethz.ch/mailman/listinfo/r-sig-fedora


On Thu, 2017-06-22 at 14:19 +0000, Hamidi, Bashir wrote:

> System: Red Hat Enterprise Linux Server release 6.5 (Santiago)
>
> I’ve installed zlib 1.2.11 on the home folder of a Red Hat HPC as
> part of the process for installing R base 3.4.0.
>
> I get this error even after successful install of zlib
> checking for inflateInit2_ in -lz... no
> checking whether zlib support suffices... configure: error: zlib
> library and headers are required
>
>  I’ve checked R documentation and configure file for the issue of R
> requiring version newer than 1.2.6 but not lexicographically
> recognizing 1.2.11 as >1.2.6, and that particular bug was patched in
> 3.4.
>
> Any suggestion and/or input would be much appreciated.
>
> Regards,
>
>
> Bashir
>
>
>
>
>
> [[alternative HTML version deleted]]
>
> ______________________________________________
> [hidden email] mailing list
> https://stat.ethz.ch/mailman/listinfo/r-devel
______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel