installation question/problem

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

installation question/problem

dw-5
Hello,

Can anybody tell me why I am getting the error below when I run "make
check" and if it has any consequences I may regret later?

I run:

#  ./configure --enable-R-shlib
# make
# make check
# make install


configure, make and make install all work without errors, and it seems
to install ok, and I even test the R binary after install, so I guess
it's working. But I want to make sure. I'm not going to be using R, but
I'm the net admin who has been tasked with installing it our servers, so
I don't want any nasty surprises.

I wonder if it's possible that I'm missing libraries because I'm not
running X on the servers?

This is:
FreeBSD 5.4 p8
R-2.2.1


make check output:

(snip)
.....
running code in 'grDevices-Ex.R' ... OK
comparing 'grDevices-Ex.Rout' to 'grDevices-Ex.Rout.prev' ... OK
running code in 'graphics-Ex.R' ... OK
comparing 'graphics-Ex.Rout' to 'graphics-Ex.Rout.prev' ... OK
running code in 'stats-Ex.R' ...*** Error code 1

Stop in /usr/home/dwinner/tmp/R-2.2.1/tests/Examples.
*** Error code 1

Stop in /usr/home/dwinner/tmp/R-2.2.1/tests/Examples.
*** Error code 1

Stop in /usr/home/dwinner/tmp/R-2.2.1/tests.
*** Error code 1

Stop in /usr/home/dwinner/tmp/R-2.2.1/tests.
*** Error code 1

Stop in /usr/home/dwinner/tmp/R-2.2.1.



Thanks for any info,
DW

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html
Reply | Threaded
Open this post in threaded view
|

Re: installation question/problem

Peter Dalgaard
DW <[hidden email]> writes:

> Hello,
>
> Can anybody tell me why I am getting the error below when I run "make
> check" and if it has any consequences I may regret later?
>
> I run:
>
> #  ./configure --enable-R-shlib
> # make
> # make check
> # make install
>
>
> configure, make and make install all work without errors, and it seems
> to install ok, and I even test the R binary after install, so I guess
> it's working. But I want to make sure. I'm not going to be using R, but
> I'm the net admin who has been tasked with installing it our servers, so
> I don't want any nasty surprises.
>
> I wonder if it's possible that I'm missing libraries because I'm not
> running X on the servers?
>
> This is:
> FreeBSD 5.4 p8
> R-2.2.1
>
>
> make check output:
>
> (snip)
> .....
> running code in 'grDevices-Ex.R' ... OK
> comparing 'grDevices-Ex.Rout' to 'grDevices-Ex.Rout.prev' ... OK
> running code in 'graphics-Ex.R' ... OK
> comparing 'graphics-Ex.Rout' to 'graphics-Ex.Rout.prev' ... OK
> running code in 'stats-Ex.R' ...*** Error code 1
 
Ouch.

Please look for stats-Ex.Rout.fail at tell us what is in it (you
should find it in tests/Examples in your builddir, interesting stuff
should be towards the end of the file).

--
   O__  ---- Peter Dalgaard             Øster Farimagsgade 5, Entr.B
  c/ /'_ --- Dept. of Biostatistics     PO Box 2099, 1014 Cph. K
 (*) \(*) -- University of Copenhagen   Denmark          Ph:  (+45) 35327918
~~~~~~~~~~ - ([hidden email])                  FAX: (+45) 35327907

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html
Reply | Threaded
Open this post in threaded view
|

Re: installation question/problem

dw-5
Peter Dalgaard wrote:

>DW <[hidden email]> writes:
>
>  
>
>>Hello,
>>
>>Can anybody tell me why I am getting the error below when I run "make
>>check" and if it has any consequences I may regret later?
>>
>>I run:
>>
>>#  ./configure --enable-R-shlib
>># make
>># make check
>># make install
>>
>>
>>configure, make and make install all work without errors, and it seems
>>to install ok, and I even test the R binary after install, so I guess
>>it's working. But I want to make sure. I'm not going to be using R, but
>>I'm the net admin who has been tasked with installing it our servers, so
>>I don't want any nasty surprises.
>>
>>I wonder if it's possible that I'm missing libraries because I'm not
>>running X on the servers?
>>
>>This is:
>>FreeBSD 5.4 p8
>>R-2.2.1
>>
>>
>>make check output:
>>
>>(snip)
>>.....
>>running code in 'grDevices-Ex.R' ... OK
>>comparing 'grDevices-Ex.Rout' to 'grDevices-Ex.Rout.prev' ... OK
>>running code in 'graphics-Ex.R' ... OK
>>comparing 'graphics-Ex.Rout' to 'graphics-Ex.Rout.prev' ... OK
>>running code in 'stats-Ex.R' ...*** Error code 1
>>    
>>
>
>Ouch.
>
>Please look for stats-Ex.Rout.fail at tell us what is in it (you
>should find it in tests/Examples in your builddir, interesting stuff
>should be towards the end of the file).
>
>  
>
Here is what I found:

 > ## using the nl2sol algorithm
 > fm4DNase1 <- nls( density ~ Asym/(1 + exp((xmid - log(conc))/scal)),
+                   data = DNase1,
+                   start = list(Asym = 3, xmid = 0, scal = 1),
+                   trace = TRUE, algorithm = "port")
  0      0.00000:  3.00000  0.00000  1.00000
Error in nls(density ~ Asym/(1 + exp((xmid - log(conc))/scal)), data =
DNase1,  :
        Convergence failure: See PORT documentation.  Code (27)
Execution halted


Thanks,
DW

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html
Reply | Threaded
Open this post in threaded view
|

Re: installation question/problem

Peter Dalgaard
DW <[hidden email]> writes:

> Peter Dalgaard wrote:
>
> >DW <[hidden email]> writes:
> >
> >
> >>Hello,
> >>
> >> Can anybody tell me why I am getting the error below when I run
> >> "make check" and if it has any consequences I may regret later?
> >>
> >>I run:
> >>
> >>#  ./configure --enable-R-shlib
> >># make
> >># make check
> >># make install
> >>
> >>
> >> configure, make and make install all work without errors, and it
> >> seems to install ok, and I even test the R binary after install, so
> >> I guess it's working. But I want to make sure. I'm not going to be
> >> using R, but I'm the net admin who has been tasked with installing
> >> it our servers, so I don't want any nasty surprises.
> >>
> >> I wonder if it's possible that I'm missing libraries because I'm
> >> not running X on the servers?
> >>
> >>This is:
> >>FreeBSD 5.4 p8
> >>R-2.2.1
> >>
> >>
> >>make check output:
> >>
> >>(snip)
> >>.....
> >>running code in 'grDevices-Ex.R' ... OK
> >>comparing 'grDevices-Ex.Rout' to 'grDevices-Ex.Rout.prev' ... OK
> >>running code in 'graphics-Ex.R' ... OK
> >>comparing 'graphics-Ex.Rout' to 'graphics-Ex.Rout.prev' ... OK
> >>running code in 'stats-Ex.R' ...*** Error code 1
> >>
> > Ouch.
> >
> >Please look for stats-Ex.Rout.fail at tell us what is in it (you
> >should find it in tests/Examples in your builddir, interesting stuff
> >should be towards the end of the file).
> >
> >
> Here is what I found:
>
>  > ## using the nl2sol algorithm
>  > fm4DNase1 <- nls( density ~ Asym/(1 + exp((xmid - log(conc))/scal)),
> +                   data = DNase1,
> +                   start = list(Asym = 3, xmid = 0, scal = 1),
> +                   trace = TRUE, algorithm = "port")
>   0      0.00000:  3.00000  0.00000  1.00000
> Error in nls(density ~ Asym/(1 + exp((xmid - log(conc))/scal)), data =
> DNase1,  :
>         Convergence failure: See PORT documentation.  Code (27)
> Execution halted
>
>
> Thanks,
> DW

Hmm. Faint bell ringing:

We had a thread in R-core involving that error message (code 27 too)
in a different context, back in August. It could indicate that you are
tickling an intermittent bug in nlminb. Are you any good with a
debugger?

--
   O__  ---- Peter Dalgaard             Øster Farimagsgade 5, Entr.B
  c/ /'_ --- Dept. of Biostatistics     PO Box 2099, 1014 Cph. K
 (*) \(*) -- University of Copenhagen   Denmark          Ph:  (+45) 35327918
~~~~~~~~~~ - ([hidden email])                  FAX: (+45) 35327907

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html
Reply | Threaded
Open this post in threaded view
|

Re: installation question/problem

dw-5
Peter Dalgaard wrote:

>DW <[hidden email]> writes:
>
>  
>
>>Peter Dalgaard wrote:
>>
>>    
>>
>>>DW <[hidden email]> writes:
>>>
>>>
>>>      
>>>
>>>>Hello,
>>>>
>>>>Can anybody tell me why I am getting the error below when I run
>>>>"make check" and if it has any consequences I may regret later?
>>>>
>>>>I run:
>>>>
>>>>#  ./configure --enable-R-shlib
>>>># make
>>>># make check
>>>># make install
>>>>
>>>>
>>>>configure, make and make install all work without errors, and it
>>>>seems to install ok, and I even test the R binary after install, so
>>>>I guess it's working. But I want to make sure. I'm not going to be
>>>>using R, but I'm the net admin who has been tasked with installing
>>>>it our servers, so I don't want any nasty surprises.
>>>>
>>>>I wonder if it's possible that I'm missing libraries because I'm
>>>>not running X on the servers?
>>>>
>>>>This is:
>>>>FreeBSD 5.4 p8
>>>>R-2.2.1
>>>>
>>>>
>>>>make check output:
>>>>
>>>>(snip)
>>>>.....
>>>>running code in 'grDevices-Ex.R' ... OK
>>>>comparing 'grDevices-Ex.Rout' to 'grDevices-Ex.Rout.prev' ... OK
>>>>running code in 'graphics-Ex.R' ... OK
>>>>comparing 'graphics-Ex.Rout' to 'graphics-Ex.Rout.prev' ... OK
>>>>running code in 'stats-Ex.R' ...*** Error code 1
>>>>
>>>>        
>>>>
>>>Ouch.
>>>
>>>Please look for stats-Ex.Rout.fail at tell us what is in it (you
>>>should find it in tests/Examples in your builddir, interesting stuff
>>>should be towards the end of the file).
>>>
>>>
>>>      
>>>
>>Here is what I found:
>>
>> > ## using the nl2sol algorithm
>> > fm4DNase1 <- nls( density ~ Asym/(1 + exp((xmid - log(conc))/scal)),
>>+                   data = DNase1,
>>+                   start = list(Asym = 3, xmid = 0, scal = 1),
>>+                   trace = TRUE, algorithm = "port")
>>  0      0.00000:  3.00000  0.00000  1.00000
>>Error in nls(density ~ Asym/(1 + exp((xmid - log(conc))/scal)), data =
>>DNase1,  :
>>        Convergence failure: See PORT documentation.  Code (27)
>>Execution halted
>>
>>
>>Thanks,
>>DW
>>    
>>
>
>Hmm. Faint bell ringing:
>
>We had a thread in R-core involving that error message (code 27 too)
>in a different context, back in August. It could indicate that you are
>tickling an intermittent bug in nlminb. Are you any good with a
>debugger?
>
>  
>
(laughs) No, wish I was though. I can write "Hello World" in about 5
different languages, but that's about the extent of my coding skills.
But if there is anything else I can do to provide helpful info
(following instructions, replicating things, etc.), I'd be more than
happy to help.

-DW

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html
Reply | Threaded
Open this post in threaded view
|

Re: installation question/problem

dw-5
In reply to this post by Peter Dalgaard
Peter Dalgaard wrote:

>DW <[hidden email]> writes:
>
>  
>
>>Peter Dalgaard wrote:
>>
>>    
>>
>>>DW <[hidden email]> writes:
>>>
>>>
>>>      
>>>
>>>>Hello,
>>>>
>>>>Can anybody tell me why I am getting the error below when I run
>>>>"make check" and if it has any consequences I may regret later?
>>>>
>>>>I run:
>>>>
>>>>#  ./configure --enable-R-shlib
>>>># make
>>>># make check
>>>># make install
>>>>
>>>>
>>>>configure, make and make install all work without errors, and it
>>>>seems to install ok, and I even test the R binary after install, so
>>>>I guess it's working. But I want to make sure. I'm not going to be
>>>>using R, but I'm the net admin who has been tasked with installing
>>>>it our servers, so I don't want any nasty surprises.
>>>>
>>>>I wonder if it's possible that I'm missing libraries because I'm
>>>>not running X on the servers?
>>>>
>>>>This is:
>>>>FreeBSD 5.4 p8
>>>>R-2.2.1
>>>>
>>>>
>>>>make check output:
>>>>
>>>>(snip)
>>>>.....
>>>>running code in 'grDevices-Ex.R' ... OK
>>>>comparing 'grDevices-Ex.Rout' to 'grDevices-Ex.Rout.prev' ... OK
>>>>running code in 'graphics-Ex.R' ... OK
>>>>comparing 'graphics-Ex.Rout' to 'graphics-Ex.Rout.prev' ... OK
>>>>running code in 'stats-Ex.R' ...*** Error code 1
>>>>
>>>>        
>>>>
>>>Ouch.
>>>
>>>Please look for stats-Ex.Rout.fail at tell us what is in it (you
>>>should find it in tests/Examples in your builddir, interesting stuff
>>>should be towards the end of the file).
>>>
>>>
>>>      
>>>
>>Here is what I found:
>>
>> > ## using the nl2sol algorithm
>> > fm4DNase1 <- nls( density ~ Asym/(1 + exp((xmid - log(conc))/scal)),
>>+                   data = DNase1,
>>+                   start = list(Asym = 3, xmid = 0, scal = 1),
>>+                   trace = TRUE, algorithm = "port")
>>  0      0.00000:  3.00000  0.00000  1.00000
>>Error in nls(density ~ Asym/(1 + exp((xmid - log(conc))/scal)), data =
>>DNase1,  :
>>        Convergence failure: See PORT documentation.  Code (27)
>>Execution halted
>>
>>
>>Thanks,
>>DW
>>    
>>
>
>Hmm. Faint bell ringing:
>
>We had a thread in R-core involving that error message (code 27 too)
>in a different context, back in August. It could indicate that you are
>tickling an intermittent bug in nlminb. Are you any good with a
>debugger?
>
>  
>
Also, for whatever it's worth, I tried this on FreeBSD 6.0 and it worked.

I then went back and tried again on a 3rd machine running FreeBSD 5.4
with Xorg (because I'm running X on the 6.0 box and thought maybe the
problem is a missing library or some other component), and it produced
the same error as the first 5.4 box.

-DW

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html