lty dots pdf issue

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

lty dots pdf issue

RKoenker
I'm trying to redo an old plot with:

>  sessionInfo()
R version 2.11.0 Under development (unstable) (2010-02-09 r51113)
x86_64-apple-darwin9.8.0

When I do:


pdf("lty.pdf",height = 6, width = 8)
u <- 1:100/100
y <- matrix(rep(1:10,each = 100),100)
matplot(u,y,lwd = 2,type ="l")
dev.off()

the line types that have dots are difficult to distinguish because the "dots"
that should appear are rendered as very thin vertical lines and it appears
that the dashes are rendered without the lend "round" feature even though
par() reports that that is the setting.  I'm viewing all this with Acrobat 9 pro,
but my printer produces something quite consistent with what is viewable
on the screen.  

Apologies in advance if this has an obvious resolution, I didn't see anything
in the r-help archive.

Roger


url:    www.econ.uiuc.edu/~roger            Roger Koenker
email    [hidden email]            Department of Economics
vox:     217-333-4558                University of Illinois
fax:       217-244-6678                Urbana, IL 61801

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: lty dots pdf issue

Ken Knoblauch
Roger Koenker <rkoenker <at> uiuc.edu> writes:

> I'm trying to redo an old plot with:
> >  sessionInfo()
> R version 2.11.0 Under development (unstable) (2010-02-09 r51113)
> x86_64-apple-darwin9.8.0
> When I do:
>
> pdf("lty.pdf",height = 6, width = 8)
> u <- 1:100/100
> y <- matrix(rep(1:10,each = 100),100)
> matplot(u,y,lwd = 2,type ="l")
> dev.off()
>
> the line types that have dots are difficult to distinguish
because the "dots"
> that should appear are rendered as very thin vertical l
ines and it appears
> that the dashes are rendered without the lend "round"
 feature even though
> par() reports that that is the setting.  I'm viewing all
this with Acrobat 9 pro,
> but my printer produces something quite consistent
with what is viewable
> on the screen.  

Hi,

Could this be related to the problem that was driving me crazy last week

https://www.stat.math.ethz.ch/pipermail/r-sig-mac/2010-February/007123.html

but resolved in the latest patched version?

HTH,

Ken


> Apologies in advance if this has an obvious resolution, I didn't see anything
> in the r-help archive.
>
> Roger
>
> url:    www.econ.uiuc.edu/~roger            Roger Koenker
> email    rkoenker <at> uiuc.edu            Department of Economics
> vox:     217-333-4558                University of Illinois
> fax:       217-244-6678                Urbana, IL 61801
>
>

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: lty dots pdf issue

RKoenker
Thanks Ken,  that was it.
I've updated to R version 2.11.0 Under development (unstable) (2010-02-18 r51149)
x86_64-apple-darwin9.8.0
and everything looks fine now.  Thanks too to Simon for sorting this out!

Roger