mpi.h errors on Mavericks packages

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

mpi.h errors on Mavericks packages

Daniel Fuka
Dear mac folks,

I have started porting a large legacy toolset maintained in windows
and heavily mpi laden so it can be used across platforms in R... so I
am building a package out of it. On this note, I am noticing that
almost all of the mpi dependent packages do not compile on the CRAN
repositories.... with the basic issue that it appears it can not find
mpi installed:

configure: error: "Cannot find mpi.h header file"

I do not see any chatter about mpi issues in the lists since the
inception of mavericks.. and possibly this question should go to
Simon.. but in case I missed a discussion, or if anyone has any
suggestions on how to proceed, or what might be missing from the Rmpi,
npRmpi, etc. packages for compilation on Mavericks, it would be
greatly appreciated if you could let me know.. and maybe I can help
fix the other packages as well.

Thanks for any help or pointers to guide me!
dan

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Reply | Threaded
Open this post in threaded view
|

Re: mpi.h errors on Mavericks packages

Martin Morgan
On 10/03/2014 04:17 PM, Daniel Fuka wrote:

> Dear mac folks,
>
> I have started porting a large legacy toolset maintained in windows
> and heavily mpi laden so it can be used across platforms in R... so I
> am building a package out of it. On this note, I am noticing that
> almost all of the mpi dependent packages do not compile on the CRAN
> repositories.... with the basic issue that it appears it can not find
> mpi installed:
>
> configure: error: "Cannot find mpi.h header file"

Hi Dan -- not a mac folk, or particularly expert on the subject, but have you
looked at section 1.2.1.1 of RShowDoc("R-exts")? The basic idea is

a) check for compiler support via a src/Makevars file that might be like

PKG_CFLAGS = $(SHLIB_OPENMP_CFLAGS)
PKG_LIBS = $(SHLIB_OPENMP_CFLAGS)

b) conditionally include mpi header files and execute mpi code with

#ifdef SUPPORT_OPENMP
#include <mpi.h>
#endif

and similarly for #pragma's and other mpi-isms littered through your code?
Likely this gets quite tedious for projects making extensive use of openMP.

Martin


>
> I do not see any chatter about mpi issues in the lists since the
> inception of mavericks.. and possibly this question should go to
> Simon.. but in case I missed a discussion, or if anyone has any
> suggestions on how to proceed, or what might be missing from the Rmpi,
> npRmpi, etc. packages for compilation on Mavericks, it would be
> greatly appreciated if you could let me know.. and maybe I can help
> fix the other packages as well.
>
> Thanks for any help or pointers to guide me!
> dan
>
> ______________________________________________
> [hidden email] mailing list
> https://stat.ethz.ch/mailman/listinfo/r-devel
>


--
Computational Biology / Fred Hutchinson Cancer Research Center
1100 Fairview Ave. N.
PO Box 19024 Seattle, WA 98109

Location: Arnold Building M1 B861
Phone: (206) 667-2793

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Reply | Threaded
Open this post in threaded view
|

Re: mpi.h errors on Mavericks packages

Martin Morgan
On 10/03/2014 04:58 PM, Martin Morgan wrote:

> On 10/03/2014 04:17 PM, Daniel Fuka wrote:
>> Dear mac folks,
>>
>> I have started porting a large legacy toolset maintained in windows
>> and heavily mpi laden so it can be used across platforms in R... so I
>> am building a package out of it. On this note, I am noticing that
>> almost all of the mpi dependent packages do not compile on the CRAN
>> repositories.... with the basic issue that it appears it can not find
>> mpi installed:
>>
>> configure: error: "Cannot find mpi.h header file"
>

sorry for the noise! you're after mpi and not openMP. Arrgh Martin

> Hi Dan -- not a mac folk, or particularly expert on the subject, but have you
> looked at section 1.2.1.1 of RShowDoc("R-exts")? The basic idea is
>
> a) check for compiler support via a src/Makevars file that might be like
>
> PKG_CFLAGS = $(SHLIB_OPENMP_CFLAGS)
> PKG_LIBS = $(SHLIB_OPENMP_CFLAGS)
>
> b) conditionally include mpi header files and execute mpi code with
>
> #ifdef SUPPORT_OPENMP
> #include <mpi.h>
> #endif
>
> and similarly for #pragma's and other mpi-isms littered through your code?
> Likely this gets quite tedious for projects making extensive use of openMP.
>
> Martin
>
>
>>
>> I do not see any chatter about mpi issues in the lists since the
>> inception of mavericks.. and possibly this question should go to
>> Simon.. but in case I missed a discussion, or if anyone has any
>> suggestions on how to proceed, or what might be missing from the Rmpi,
>> npRmpi, etc. packages for compilation on Mavericks, it would be
>> greatly appreciated if you could let me know.. and maybe I can help
>> fix the other packages as well.
>>
>> Thanks for any help or pointers to guide me!
>> dan
>>
>> ______________________________________________
>> [hidden email] mailing list
>> https://stat.ethz.ch/mailman/listinfo/r-devel
>>
>
>


--
Computational Biology / Fred Hutchinson Cancer Research Center
1100 Fairview Ave. N.
PO Box 19024 Seattle, WA 98109

Location: Arnold Building M1 B861
Phone: (206) 667-2793

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Reply | Threaded
Open this post in threaded view
|

Re: mpi.h errors on Mavericks packages

Simon Urbanek
In reply to this post by Daniel Fuka
Daniel,

On Oct 3, 2014, at 7:17 PM, Daniel Fuka <[hidden email]> wrote:

> Dear mac folks,
>
> I have started porting a large legacy toolset maintained in windows
> and heavily mpi laden so it can be used across platforms in R... so I
> am building a package out of it. On this note, I am noticing that
> almost all of the mpi dependent packages do not compile on the CRAN
> repositories.... with the basic issue that it appears it can not find
> mpi installed:
>
> configure: error: "Cannot find mpi.h header file"
>
> I do not see any chatter about mpi issues in the lists since the
> inception of mavericks.. and possibly this question should go to
> Simon.. but in case I missed a discussion, or if anyone has any
> suggestions on how to proceed, or what might be missing from the Rmpi,
> npRmpi, etc. packages for compilation on Mavericks, it would be
> greatly appreciated if you could let me know.. and maybe I can help
> fix the other packages as well.


Apple has removed MPI from recent OS X versions so it is not available there.

So currently, you have to install whatever MPI implementation you prefer from sources since neither the libraries nor the toolchain are available. What Apple used to ship was OpenMPI which still exists, but to my best knowledge there is no official, maintained binary for OS X so on Mavericks we have nothing to build CRAN binaries against, so you have to install everything from sources.

Cheers,
Simon

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Reply | Threaded
Open this post in threaded view
|

Re: mpi.h errors on Mavericks packages

Wei-Chen Chen
FYI
https://groups.google.com/forum/#!topic/rbigdataprogramming/k1uZWmzd1L8
or FAQ, Section 8.3, question 10 at
https://github.com/snoweye/pbdMPI/blob/master/inst/doc/pbdMPI-guide.pdf?raw=true
may be useful.

On Fri, Oct 3, 2014 at 9:10 PM, Simon Urbanek <[hidden email]>
wrote:

> Daniel,
>
> On Oct 3, 2014, at 7:17 PM, Daniel Fuka <[hidden email]> wrote:
>
> > Dear mac folks,
> >
> > I have started porting a large legacy toolset maintained in windows
> > and heavily mpi laden so it can be used across platforms in R... so I
> > am building a package out of it. On this note, I am noticing that
> > almost all of the mpi dependent packages do not compile on the CRAN
> > repositories.... with the basic issue that it appears it can not find
> > mpi installed:
> >
> > configure: error: "Cannot find mpi.h header file"
> >
> > I do not see any chatter about mpi issues in the lists since the
> > inception of mavericks.. and possibly this question should go to
> > Simon.. but in case I missed a discussion, or if anyone has any
> > suggestions on how to proceed, or what might be missing from the Rmpi,
> > npRmpi, etc. packages for compilation on Mavericks, it would be
> > greatly appreciated if you could let me know.. and maybe I can help
> > fix the other packages as well.
>
>
> Apple has removed MPI from recent OS X versions so it is not available
> there.
>
> So currently, you have to install whatever MPI implementation you prefer
> from sources since neither the libraries nor the toolchain are available.
> What Apple used to ship was OpenMPI which still exists, but to my best
> knowledge there is no official, maintained binary for OS X so on Mavericks
> we have nothing to build CRAN binaries against, so you have to install
> everything from sources.
>
> Cheers,
> Simon
>
> ______________________________________________
> [hidden email] mailing list
> https://stat.ethz.ch/mailman/listinfo/r-devel
>

        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel