(no subject)

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

(no subject)

Brayford, David
When I try to install gsl in R I get the error Need GSL version >= 1.12 . However, I have version 2.3 of gsl installed on the system, which is picked up earlier in the configure process (see below). Is it possible for someone to fix this error in the configure script?

checking for gsl-config... /lrz/sys/libraries/gsl/2.3/bin/gsl-config
checking if GSL version >= 1.12... checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
configure: error: Need GSL version >= 1.12
ERROR: configuration failed for package �gsl�


David


        [[alternative HTML version deleted]]


______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: (no subject)

Berend Hasselman

> On 13 Sep 2017, at 11:23, Brayford, David <[hidden email]> wrote:
>
> When I try to install gsl in R I get the error Need GSL version >= 1.12 . However, I have version 2.3 of gsl installed on the system, which is picked up earlier in the configure process (see below). Is it possible for someone to fix this error in the configure script?
>
> checking for gsl-config... /lrz/sys/libraries/gsl/2.3/bin/gsl-config
> checking if GSL version >= 1.12... checking for gcc... gcc
> checking for C compiler default output file name... a.out
> checking whether the C compiler works... yes
> checking whether we are cross compiling... no
> checking for suffix of executables...
> checking for suffix of object files... o
> checking whether we are using the GNU C compiler... yes
> checking whether gcc accepts -g... yes
> checking for gcc option to accept ISO C89... none needed
> configure: error: Need GSL version >= 1.12
> ERROR: configuration failed for package �gsl�
>

Why don't you send an email to the maintainer of the package?


Berend Hasselman

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: (no subject)

Suzen, Mehmet
In reply to this post by Brayford, David
Hello David,

As error message says you have a version dependency not satisfied.
"error: Need GSL version >= 1.12". If you are using Ubuntu for example
you could do;
sudo apt-get install libgsl2

Or you can compile by yourself, I am sure there are people in LRZ can
help you on this:)

Best,
Mehmet

On 13 September 2017 at 11:23, Brayford, David <[hidden email]> wrote:

> When I try to install gsl in R I get the error Need GSL version >= 1.12 . However, I have version 2.3 of gsl installed on the system, which is picked up earlier in the configure process (see below). Is it possible for someone to fix this error in the configure script?
>
> checking for gsl-config... /lrz/sys/libraries/gsl/2.3/bin/gsl-config
> checking if GSL version >= 1.12... checking for gcc... gcc
> checking for C compiler default output file name... a.out
> checking whether the C compiler works... yes
> checking whether we are cross compiling... no
> checking for suffix of executables...
> checking for suffix of object files... o
> checking whether we are using the GNU C compiler... yes
> checking whether gcc accepts -g... yes
> checking for gcc option to accept ISO C89... none needed
> configure: error: Need GSL version >= 1.12
> ERROR: configuration failed for package ‘gsl’
>
>
> David
>
>
>         [[alternative HTML version deleted]]
>
>
> ______________________________________________
> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: (no subject)

Duncan Murdoch-2
In reply to this post by Brayford, David
On 13/09/2017 5:23 AM, Brayford, David wrote:

> When I try to install gsl in R I get the error Need GSL version >= 1.12 . However, I have version 2.3 of gsl installed on the system, which is picked up earlier in the configure process (see below). Is it possible for someone to fix this error in the configure script?
>
> checking for gsl-config... /lrz/sys/libraries/gsl/2.3/bin/gsl-config
> checking if GSL version >= 1.12... checking for gcc... gcc
> checking for C compiler default output file name... a.out
> checking whether the C compiler works... yes
> checking whether we are cross compiling... no
> checking for suffix of executables...
> checking for suffix of object files... o
> checking whether we are using the GNU C compiler... yes
> checking whether gcc accepts -g... yes
> checking for gcc option to accept ISO C89... none needed
> configure: error: Need GSL version >= 1.12
> ERROR: configuration failed for package �gsl�
>


As Berend said, this should be talked about with the maintainer.  It
would be helpful if you could show more detail of the test that failed.

For example, what does

/lrz/sys/libraries/gsl/2.3/bin/gsl-config --version --cflags

print?  For me, the second line from gsl-config is

-I/usr/local/Cellar/gsl/1.16/include

and I can see using

less /usr/local/Cellar/gsl/1.16/include/gsl/gsl_version.h

that the macros are defined as

#define GSL_VERSION "1.16"
#define GSL_MAJOR_VERSION 1
#define GSL_MINOR_VERSION 16

Presumably you'll get something else...

Duncan Murdoch

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: (no subject)

Brayford, David
Hi Duncan,

The output of gsl-config --version
2.3

The output of gsl-config --cflags
-I/lrz/sys/libraries/gsl/2.3/include

The output of gsl-config --libs
-L/lrz/sys/libraries/gsl/2.3/lib -lgsl -lgslcblas -lm

gsl_version.h cat output
#define GSL_VERSION "2.3"
#define GSL_MAJOR_VERSION 2
#define GSL_MINOR_VERSION 3

It's puzzling.

David

On 09/13/2017 02:57 PM, Duncan Murdoch wrote:

> On 13/09/2017 5:23 AM, Brayford, David wrote:
>> When I try to install gsl in R I get the error Need GSL version >=
>> 1.12 . However, I have version 2.3 of gsl installed on the system,
>> which is picked up earlier in the configure process (see below). Is
>> it possible for someone to fix this error in the configure script?
>>
>> checking for gsl-config... /lrz/sys/libraries/gsl/2.3/bin/gsl-config
>> checking if GSL version >= 1.12... checking for gcc... gcc
>> checking for C compiler default output file name... a.out
>> checking whether the C compiler works... yes
>> checking whether we are cross compiling... no
>> checking for suffix of executables...
>> checking for suffix of object files... o
>> checking whether we are using the GNU C compiler... yes
>> checking whether gcc accepts -g... yes
>> checking for gcc option to accept ISO C89... none needed
>> configure: error: Need GSL version >= 1.12
>> ERROR: configuration failed for package �gsl�
>>
>
>
> As Berend said, this should be talked about with the maintainer. It
> would be helpful if you could show more detail of the test that failed.
>
> For example, what does
>
> /lrz/sys/libraries/gsl/2.3/bin/gsl-config --version --cflags
>
> print?  For me, the second line from gsl-config is
>
> -I/usr/local/Cellar/gsl/1.16/include
>
> and I can see using
>
> less /usr/local/Cellar/gsl/1.16/include/gsl/gsl_version.h
>
> that the macros are defined as
>
> #define GSL_VERSION "1.16"
> #define GSL_MAJOR_VERSION 1
> #define GSL_MINOR_VERSION 16
>
> Presumably you'll get something else...
>
> Duncan Murdoch
>

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: (no subject)

Duncan Murdoch-2
On 13/09/2017 9:10 AM, David Brayford wrote:

> Hi Duncan,
>
> The output of gsl-config --version
> 2.3
>
> The output of gsl-config --cflags
> -I/lrz/sys/libraries/gsl/2.3/include
>
> The output of gsl-config --libs
> -L/lrz/sys/libraries/gsl/2.3/lib -lgsl -lgslcblas -lm
>
> gsl_version.h cat output
> #define GSL_VERSION "2.3"
> #define GSL_MAJOR_VERSION 2
> #define GSL_MINOR_VERSION 3
>
> It's puzzling.

Sure is.  I can't see what would be going wrong.

Duncan Murdoch

>
> David
>
> On 09/13/2017 02:57 PM, Duncan Murdoch wrote:
>> On 13/09/2017 5:23 AM, Brayford, David wrote:
>>> When I try to install gsl in R I get the error Need GSL version >=
>>> 1.12 . However, I have version 2.3 of gsl installed on the system,
>>> which is picked up earlier in the configure process (see below). Is
>>> it possible for someone to fix this error in the configure script?
>>>
>>> checking for gsl-config... /lrz/sys/libraries/gsl/2.3/bin/gsl-config
>>> checking if GSL version >= 1.12... checking for gcc... gcc
>>> checking for C compiler default output file name... a.out
>>> checking whether the C compiler works... yes
>>> checking whether we are cross compiling... no
>>> checking for suffix of executables...
>>> checking for suffix of object files... o
>>> checking whether we are using the GNU C compiler... yes
>>> checking whether gcc accepts -g... yes
>>> checking for gcc option to accept ISO C89... none needed
>>> configure: error: Need GSL version >= 1.12
>>> ERROR: configuration failed for package �gsl�
>>>
>>
>>
>> As Berend said, this should be talked about with the maintainer. It
>> would be helpful if you could show more detail of the test that failed.
>>
>> For example, what does
>>
>> /lrz/sys/libraries/gsl/2.3/bin/gsl-config --version --cflags
>>
>> print?  For me, the second line from gsl-config is
>>
>> -I/usr/local/Cellar/gsl/1.16/include
>>
>> and I can see using
>>
>> less /usr/local/Cellar/gsl/1.16/include/gsl/gsl_version.h
>>
>> that the macros are defined as
>>
>> #define GSL_VERSION "1.16"
>> #define GSL_MAJOR_VERSION 1
>> #define GSL_MINOR_VERSION 16
>>
>> Presumably you'll get something else...
>>
>> Duncan Murdoch
>>
>

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: (no subject)

Peter Dalgaard-2

> On 13 Sep 2017, at 16:01 , Duncan Murdoch <[hidden email]> wrote:
>
> On 13/09/2017 9:10 AM, David Brayford wrote:
>> Hi Duncan,
>> The output of gsl-config --version
>> 2.3
>> The output of gsl-config --cflags
>> -I/lrz/sys/libraries/gsl/2.3/include
>> The output of gsl-config --libs
>> -L/lrz/sys/libraries/gsl/2.3/lib -lgsl -lgslcblas -lm
>> gsl_version.h cat output
>> #define GSL_VERSION "2.3"
>> #define GSL_MAJOR_VERSION 2
>> #define GSL_MINOR_VERSION 3
>> It's puzzling.
>
> Sure is.  I can't see what would be going wrong.


Two ideas:

1. The include file might be there but not the actual library (or a different version gets picked up via an -L setting)
2. The error message can be spurious and reflect a completely different problem. It looks a little odd that the ERROR does not appear immediately after "checking if GSL version >= 1.12..." (is some sort of parallel make going on, perchance?)

If push comes to shove, you may have to learn how to decipher config.log etc. to see exactly which test is failing and why.

-pd


>
> Duncan Murdoch
>
>> David
>> On 09/13/2017 02:57 PM, Duncan Murdoch wrote:
>>> On 13/09/2017 5:23 AM, Brayford, David wrote:
>>>> When I try to install gsl in R I get the error Need GSL version >=
>>>> 1.12 . However, I have version 2.3 of gsl installed on the system,
>>>> which is picked up earlier in the configure process (see below). Is
>>>> it possible for someone to fix this error in the configure script?
>>>>
>>>> checking for gsl-config... /lrz/sys/libraries/gsl/2.3/bin/gsl-config
>>>> checking if GSL version >= 1.12... checking for gcc... gcc
>>>> checking for C compiler default output file name... a.out
>>>> checking whether the C compiler works... yes
>>>> checking whether we are cross compiling... no
>>>> checking for suffix of executables...
>>>> checking for suffix of object files... o
>>>> checking whether we are using the GNU C compiler... yes
>>>> checking whether gcc accepts -g... yes
>>>> checking for gcc option to accept ISO C89... none needed
>>>> configure: error: Need GSL version >= 1.12
>>>> ERROR: configuration failed for package �gsl�
>>>>
>>>
>>>
>>> As Berend said, this should be talked about with the maintainer. It
>>> would be helpful if you could show more detail of the test that failed.
>>>
>>> For example, what does
>>>
>>> /lrz/sys/libraries/gsl/2.3/bin/gsl-config --version --cflags
>>>
>>> print?  For me, the second line from gsl-config is
>>>
>>> -I/usr/local/Cellar/gsl/1.16/include
>>>
>>> and I can see using
>>>
>>> less /usr/local/Cellar/gsl/1.16/include/gsl/gsl_version.h
>>>
>>> that the macros are defined as
>>>
>>> #define GSL_VERSION "1.16"
>>> #define GSL_MAJOR_VERSION 1
>>> #define GSL_MINOR_VERSION 16
>>>
>>> Presumably you'll get something else...
>>>
>>> Duncan Murdoch
>>>
>>
>
> ______________________________________________
> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

--
Peter Dalgaard, Professor,
Center for Statistics, Copenhagen Business School
Solbjerg Plads 3, 2000 Frederiksberg, Denmark
Phone: (+45)38153501
Office: A 4.23
Email: [hidden email]  Priv: [hidden email]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.