Quantcast

package ca/rgl for ubuntu?

classic Classic list List threaded Threaded
3 messages Options
kat
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

package ca/rgl for ubuntu?

kat
hi,
for some unknown reason i cannot install the package ca in R running in a ubuntu mint system. i keep getting the following error message:

configure: error: missing required header GL/gl.h
ERROR: configuration failed for package ‘rgl’
* removing ‘/home/kat/R/i486-pc-linux-gnu-library/2.12/rgl’
ERROR: dependency ‘rgl’ is not available for package ‘ca’
* removing ‘/home/kat/R/i486-pc-linux-gnu-library/2.12/ca’

Die heruntergeladenen Pakete sind in
        ‘/tmp/Rtmp7r6s3h/downloaded_packages’
Warnmeldungen:
1: In install.packages("ca") :
  Installation des Pakets 'rgl' hatte Exit-Status ungleich 0
2: In install.packages("ca") :
  Installation des Pakets 'ca' hatte Exit-Status ungleich 0

thanks a lot for your help!
katharina

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: package ca/rgl for ubuntu?

Duncan Murdoch-2
On 06/12/2010 1:45 PM, Manderscheid Katharina wrote:
> hi,
> for some unknown reason i cannot install the package ca in R running in a ubuntu mint system. i keep getting the following error message:

You need the development package for OpenGL or MesaGL to install rgl.  I
don't know Ubuntu so I don't know how to ask for it, but that's what you
want (unless you choose to install a binary; I believe some are
available for Ubuntu).

Duncan Murdoch

> configure: error: missing required header GL/gl.h
> ERROR: configuration failed for package ‘rgl’
> * removing ‘/home/kat/R/i486-pc-linux-gnu-library/2.12/rgl’
> ERROR: dependency ‘rgl’ is not available for package ‘ca’
> * removing ‘/home/kat/R/i486-pc-linux-gnu-library/2.12/ca’
>
> Die heruntergeladenen Pakete sind in
> ‘/tmp/Rtmp7r6s3h/downloaded_packages’
> Warnmeldungen:
> 1: In install.packages("ca") :
>    Installation des Pakets 'rgl' hatte Exit-Status ungleich 0
> 2: In install.packages("ca") :
>    Installation des Pakets 'ca' hatte Exit-Status ungleich 0
>
> thanks a lot for your help!
> katharina
>
> ______________________________________________
> [hidden email] mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
kat
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: package ca/rgl for ubuntu?

kat
thanks a lot, duncan for that super-fast reply and help!
i could install rgl via synaptic and afterwards ca in R directly. and it works! :-)

have a nice evening, kat
________________________________________
Von: Duncan Murdoch [[hidden email]]
Gesendet: Montag, 6. Dezember 2010 19:55
An: Manderscheid Katharina
Cc: [hidden email]
Betreff: Re: [R] package ca/rgl for ubuntu?

On 06/12/2010 1:45 PM, Manderscheid Katharina wrote:
> hi,
> for some unknown reason i cannot install the package ca in R running in a ubuntu mint system. i keep getting the following error message:

You need the development package for OpenGL or MesaGL to install rgl.  I
don't know Ubuntu so I don't know how to ask for it, but that's what you
want (unless you choose to install a binary; I believe some are
available for Ubuntu).

Duncan Murdoch

> configure: error: missing required header GL/gl.h
> ERROR: configuration failed for package ‘rgl’
> * removing ‘/home/kat/R/i486-pc-linux-gnu-library/2.12/rgl’
> ERROR: dependency ‘rgl’ is not available for package ‘ca’
> * removing ‘/home/kat/R/i486-pc-linux-gnu-library/2.12/ca’
>
> Die heruntergeladenen Pakete sind in
>       ‘/tmp/Rtmp7r6s3h/downloaded_packages’
> Warnmeldungen:
> 1: In install.packages("ca") :
>    Installation des Pakets 'rgl' hatte Exit-Status ungleich 0
> 2: In install.packages("ca") :
>    Installation des Pakets 'ca' hatte Exit-Status ungleich 0
>
> thanks a lot for your help!
> katharina
>
> ______________________________________________
> [hidden email] mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Loading...