rgarch package problems

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

rgarch package problems

zoe_zhang
Hello, R users,
sorry to bother.
 I am trying to use rgarch package. But I have problems to load it. Could you please give me some guidance?
I download the rgarch package from https://r-forge.r-project.org/R/?group_id=339 and then put it in the library but it still doesn't work. saying,
errors in library(rgarch) : rgarch' is not effective installed package

Thank you so much

cheers,
Zoe
Reply | Threaded
Open this post in threaded view
|

Re: rgarch package problems

soren wilkening
if you need help with your installation, you will at least have to provide

the R version  that you are using
Windows or *nix ?
the command(s) you used for the installation of the package
the exact text output=error you got

then someone *may* volunteer to help you


> Hello, R users,
> sorry to bother.
>  I am trying to use rgarch package. But I have problems to load it. Could
> you please give me some guidance?
> I download the rgarch package from
> https://r-forge.r-project.org/R/?group_id=339 and then put it in the
> library
> but it still doesn't work. saying,
> errors in library(rgarch) : rgarch' is not effective installed package
>
> Thank you so much
>
> cheers,
> Zoe
>
> --
> View this message in context:
> http://r.789695.n4.nabble.com/rgarch-package-problems-tp3684477p3684477.html
> Sent from the Rmetrics mailing list archive at Nabble.com.
>
> _______________________________________________
> [hidden email] mailing list
> https://stat.ethz.ch/mailman/listinfo/r-sig-finance
> -- Subscriber-posting only. If you want to post, subscribe first.
> -- Also note that this is not the r-help list where general R questions
> should go.
>


--
http://censix.com

_______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-sig-finance
-- Subscriber-posting only. If you want to post, subscribe first.
-- Also note that this is not the r-help list where general R questions should go.
Reply | Threaded
Open this post in threaded view
|

Re: rgarch package problems

braverock
In reply to this post by zoe_zhang
On Thu, 2011-07-21 at 10:54 -0700, zoe_zhang wrote:
> Hello, R users,
> sorry to bother.
>  I am trying to use rgarch package. But I have problems to load it. Could
> you please give me some guidance?
> I download the rgarch package from
> https://r-forge.r-project.org/R/?group_id=339 and then put it in the library
> but it still doesn't work. saying,
> errors in library(rgarch) : rgarch' is not effective installed package

As noted at the link above, you should:

install.packages("rgarch", repos="http://R-Forge.R-project.org")

note from the DESCRIPTION file that rgarch has a significant number of
dependencies and suggests:

Depends: R (>= 2.10.0), Rcpp (>= 0.8.5), RcppArmadillo (>= 0.2.5),
methods, Matrix, numDeriv, chron, Rsolnp, mvtnorm, Kendall, fftw

Suggests: xts, timeSeries, multicore, snowfall, Bessel, JADE, fastICA,
PearsonICA, ff, spd, sandwich

Some or all of these other packages may need to be installed first.

Regards,

  - Brian

--
Brian G. Peterson
http://braverock.com/brian/
Ph: 773-459-4973
IM: bgpbraverock

_______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-sig-finance
-- Subscriber-posting only. If you want to post, subscribe first.
-- Also note that this is not the r-help list where general R questions should go.
Reply | Threaded
Open this post in threaded view
|

Re: rgarch package problems

zoe_zhang
Thank you, Brian,
I did follow the command as install.packages("rgarch", repos="http://R-Forge.R-project.org"), but it came out
with the warning" In getDependencies(pkgs, dependencies, available, lib) :
  package ‘rgarch’ is not available (for R version 2.13.1)"

I followed your suggestion and installed the dependencies and suggests
>install.packages(c("Rsolnp", "mvtnorm", "Kendall", "fftw","Matrix","xts","timeSeries","multicore","snowfall","Bessel","JADE","fastICA","PearsonICA","ff","spd","sandwich"))

then did install.packages("rgarch", repos="http://R-Forge.R-project.org")  again,
but same warning again.
" In getDependencies(pkgs, dependencies, available, lib) :
  package ‘rgarch’ is not available (for R version 2.13.1)"

 >library(rgarch)
errors in library(rgarch) : rgarch' is not effective installed package

Is there any further more suggestions?
Thank you so much in advance!

Cheers,
Zoe
Reply | Threaded
Open this post in threaded view
|

Re: rgarch package problems

alexios
Currently no windows binaries are building on r-forge from what I gather. This will hopefully be resolved soon.

-Alexios

Sent from my iPhone

On Jul 21, 2011, at 20:13, zoe_zhang <[hidden email]> wrote:

> Thank you, Brian,
> I did follow the command as install.packages("rgarch",
> repos="http://R-Forge.R-project.org"), but it came out
> with the warning" In getDependencies(pkgs, dependencies, available, lib) :
>  package ‘rgarch’ is not available (for R version 2.13.1)"
>
> I followed your suggestion and installed the dependencies and suggests
>> install.packages(c("Rsolnp", "mvtnorm", "Kendall",
> "fftw","Matrix","xts","timeSeries","multicore","snowfall","Bessel","JADE","fastICA","PearsonICA","ff","spd","sandwich"))
>
> then did install.packages("rgarch", repos="http://R-Forge.R-project.org")
> again,
> but same warning again.
> " In getDependencies(pkgs, dependencies, available, lib) :
>  package ‘rgarch’ is not available (for R version 2.13.1)"
>
>> library(rgarch)
> errors in library(rgarch) : rgarch' is not effective installed package
>
> Is there any further more suggestions?
> Thank you so much in advance!
>
> Cheers,
> Zoe
>
> --
> View this message in context: http://r.789695.n4.nabble.com/rgarch-package-problems-tp3684477p3684717.html
> Sent from the Rmetrics mailing list archive at Nabble.com.
>
> _______________________________________________
> [hidden email] mailing list
> https://stat.ethz.ch/mailman/listinfo/r-sig-finance
> -- Subscriber-posting only. If you want to post, subscribe first.
> -- Also note that this is not the r-help list where general R questions should go.

_______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-sig-finance
-- Subscriber-posting only. If you want to post, subscribe first.
-- Also note that this is not the r-help list where general R questions should go.
Reply | Threaded
Open this post in threaded view
|

Re: rgarch package problems

zoe_zhang
In reply to this post by soren wilkening
Thank you for reminding, Soren,
I am doing in Win system using R version 2.13.1 and follow the command which is listed in the link https://r-forge.r-project.org/R/?group_id=339
> install.packages("rgarch", repos="http://R-Forge.R-project.org")
 but came out the warnings " In getDependencies(pkgs, dependencies, available, lib) :
  package ‘rgarch’ is not available (for R version 2.13.1) "
> library(rgarch)
errors in library(rgarch) : rgarch' is not effective installed package

Tried Brian's guidance
instal the dependencies and suggests in advance, but still came out with same warnings and errors

I wonder if there's something wrong with my installation.

Again, i appreciate your time

Cheers,
Zoe
Reply | Threaded
Open this post in threaded view
|

Re: rgarch package problems

Arun.stat
Hi Zoe, from the page 'https://r-forge.r-project.org/R/?group_id=339' it is evident that windows binary is not available for this package. However you can download the source file in the form of tar-gz and extract the functions and the help pages from that and then can use them.

Thanks and regards,
_____________________________________________________

Arun Kumar Saha, FRM
QUANTITATIVE RISK AND HEDGE CONSULTING SPECIALIST
Visit me at: http://in.linkedin.com/in/ArunFRM
_____________________________________________________
Reply | Threaded
Open this post in threaded view
|

Re: rgarch package problems

alexios
There are some problems with a dependency on r-forge which is currently
preventing the build. Downloading the src and extracting the functions
is not the way to go.
I have uploaded pre-build windows binaries and the source to the
package's website :

http://rgarch.r-forge.r-project.org/download.html

Regards,

Alexios

PS Give it a couple of hours until r-forge  refeshes the website.

On 31/07/2011 14:19, Arun.stat wrote:

> Hi Zoe, from the page 'https://r-forge.r-project.org/R/?group_id=339' it is
> evident that windows binary is not available for this package. However you
> can download the source file in the form of tar-gz and extract the functions
> and the help pages from that and then can use them.
>
> Thanks and regards,
> _____________________________________________________
>
> Arun Kumar Saha, FRM
> QUANTITATIVE RISK AND HEDGE CONSULTING SPECIALIST
> Visit me at: http://in.linkedin.com/in/ArunFRM
> _____________________________________________________
>
>
> --
> View this message in context: http://r.789695.n4.nabble.com/rgarch-package-problems-tp3684477p3707733.html
> Sent from the Rmetrics mailing list archive at Nabble.com.
>
> _______________________________________________
> [hidden email] mailing list
> https://stat.ethz.ch/mailman/listinfo/r-sig-finance
> -- Subscriber-posting only. If you want to post, subscribe first.
> -- Also note that this is not the r-help list where general R questions should go.
>
>

_______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-sig-finance
-- Subscriber-posting only. If you want to post, subscribe first.
-- Also note that this is not the r-help list where general R questions should go.
Reply | Threaded
Open this post in threaded view
|

Re: rgarch package problems

zoe_zhang
In reply to this post by Arun.stat
Thank you Arun! I finally got it!

cheers,
Zoe