Annoying startup error message

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Annoying startup error message

Lars Bishop-2
Hello,

Just installed R version 3.2.3, and I'm getting the error message below
every time I start R. I had SparkR installed in the prior version. I
googled this problem, but didn;t find anything useful.

Any help would be very appreciated.

Error in library(SparkR) : there is no package called ‘SparkR’
[R.app GUI 1.66 (7060) x86_64-apple-darwin13.4.0]


Best,
Lars.

        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: Annoying startup error message

Ulrik Stervbo-2
Hi Lars,

The error tells you that SparkR is not installed.

I believe you can install it like this:

library(devtools)
install_github("amplab-extras/SparkR-pkg", subdir="pkg")

I took it from https://github.com/amplab-extras/SparkR-pkg and I haven't
tried it myself.

Hope this helps,
Ulrik

On Fri, 26 Feb 2016 at 17:40 Lars Bishop <[hidden email]> wrote:

> Hello,
>
> Just installed R version 3.2.3, and I'm getting the error message below
> every time I start R. I had SparkR installed in the prior version. I
> googled this problem, but didn;t find anything useful.
>
> Any help would be very appreciated.
>
> Error in library(SparkR) : there is no package called ‘SparkR’
> [R.app GUI 1.66 (7060) x86_64-apple-darwin13.4.0]
>
>
> Best,
> Lars.
>
>         [[alternative HTML version deleted]]
>
> ______________________________________________
> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide
> http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: Annoying startup error message

Lars Bishop-2
Thank you Ulrik. I actually don't want to install SparkR, just don't want
to have that error message when R starts. For some reason, R is trying to
load the package every time it starts...

Thanks
Lars.

On Fri, Feb 26, 2016 at 11:53 AM, Ulrik Stervbo <[hidden email]>
wrote:

> Hi Lars,
>
> The error tells you that SparkR is not installed.
>
> I believe you can install it like this:
>
> library(devtools)
> install_github("amplab-extras/SparkR-pkg", subdir="pkg")
>
> I took it from https://github.com/amplab-extras/SparkR-pkg and I haven't
> tried it myself.
>
> Hope this helps,
> Ulrik
>
> On Fri, 26 Feb 2016 at 17:40 Lars Bishop <[hidden email]> wrote:
>
>> Hello,
>>
>> Just installed R version 3.2.3, and I'm getting the error message below
>> every time I start R. I had SparkR installed in the prior version. I
>> googled this problem, but didn;t find anything useful.
>>
>> Any help would be very appreciated.
>>
>> Error in library(SparkR) : there is no package called ‘SparkR’
>> [R.app GUI 1.66 (7060) x86_64-apple-darwin13.4.0]
>>
>>
>> Best,
>> Lars.
>>
>>         [[alternative HTML version deleted]]
>>
>> ______________________________________________
>> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
>> https://stat.ethz.ch/mailman/listinfo/r-help
>> PLEASE do read the posting guide
>> http://www.R-project.org/posting-guide.html
>> and provide commented, minimal, self-contained, reproducible code.
>
>

        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: Annoying startup error message

Sarah Goslee
Perhaps you at one point added it to your .RProfile so the package is
loaded at startup. You can check by starting R from the command line
with
R --vanilla
which doesn't load any of the profile files.

https://stat.ethz.ch/R-manual/R-devel/library/base/html/Startup.html

Sarah

On Fri, Feb 26, 2016 at 12:01 PM, Lars Bishop <[hidden email]> wrote:

> Thank you Ulrik. I actually don't want to install SparkR, just don't want
> to have that error message when R starts. For some reason, R is trying to
> load the package every time it starts...
>
> Thanks
> Lars.
>
> On Fri, Feb 26, 2016 at 11:53 AM, Ulrik Stervbo <[hidden email]>
> wrote:
>
>> Hi Lars,
>>
>> The error tells you that SparkR is not installed.
>>
>> I believe you can install it like this:
>>
>> library(devtools)
>> install_github("amplab-extras/SparkR-pkg", subdir="pkg")
>>
>> I took it from https://github.com/amplab-extras/SparkR-pkg and I haven't
>> tried it myself.
>>
>> Hope this helps,
>> Ulrik
>>
>> On Fri, 26 Feb 2016 at 17:40 Lars Bishop <[hidden email]> wrote:
>>
>>> Hello,
>>>
>>> Just installed R version 3.2.3, and I'm getting the error message below
>>> every time I start R. I had SparkR installed in the prior version. I
>>> googled this problem, but didn;t find anything useful.
>>>
>>> Any help would be very appreciated.
>>>
>>> Error in library(SparkR) : there is no package called ‘SparkR’
>>> [R.app GUI 1.66 (7060) x86_64-apple-darwin13.4.0]
>>>
>>>
>>> Best,
>>> Lars.
>>>

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: Annoying startup error message

Lars Bishop-2
yes! Thanks!

On Fri, Feb 26, 2016 at 12:07 PM, Sarah Goslee <[hidden email]>
wrote:

> Perhaps you at one point added it to your .RProfile so the package is
> loaded at startup. You can check by starting R from the command line
> with
> R --vanilla
> which doesn't load any of the profile files.
>
> https://stat.ethz.ch/R-manual/R-devel/library/base/html/Startup.html
>
> Sarah
>
> On Fri, Feb 26, 2016 at 12:01 PM, Lars Bishop <[hidden email]> wrote:
> > Thank you Ulrik. I actually don't want to install SparkR, just don't want
> > to have that error message when R starts. For some reason, R is trying to
> > load the package every time it starts...
> >
> > Thanks
> > Lars.
> >
> > On Fri, Feb 26, 2016 at 11:53 AM, Ulrik Stervbo <[hidden email]
> >
> > wrote:
> >
> >> Hi Lars,
> >>
> >> The error tells you that SparkR is not installed.
> >>
> >> I believe you can install it like this:
> >>
> >> library(devtools)
> >> install_github("amplab-extras/SparkR-pkg", subdir="pkg")
> >>
> >> I took it from https://github.com/amplab-extras/SparkR-pkg and I
> haven't
> >> tried it myself.
> >>
> >> Hope this helps,
> >> Ulrik
> >>
> >> On Fri, 26 Feb 2016 at 17:40 Lars Bishop <[hidden email]> wrote:
> >>
> >>> Hello,
> >>>
> >>> Just installed R version 3.2.3, and I'm getting the error message below
> >>> every time I start R. I had SparkR installed in the prior version. I
> >>> googled this problem, but didn;t find anything useful.
> >>>
> >>> Any help would be very appreciated.
> >>>
> >>> Error in library(SparkR) : there is no package called ‘SparkR’
> >>> [R.app GUI 1.66 (7060) x86_64-apple-darwin13.4.0]
> >>>
> >>>
> >>> Best,
> >>> Lars.
> >>>
>

        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: Annoying startup error message

Duncan Murdoch-2
In reply to this post by Sarah Goslee
On 26/02/2016 12:07 PM, Sarah Goslee wrote:
> Perhaps you at one point added it to your .RProfile so the package is
> loaded at startup. You can check by starting R from the command line
> with
> R --vanilla
> which doesn't load any of the profile files.
>
> https://stat.ethz.ch/R-manual/R-devel/library/base/html/Startup.html

Another possibility is that SparkR defines some S4 classes, and you have
an object of that type in your workspace.  To read it might need SparkR
installed.

The solution here is to run R --vanilla as above, or to delete the
object from the workspace, or the whole workspace.

Duncan Murdoch

>
> Sarah
>
> On Fri, Feb 26, 2016 at 12:01 PM, Lars Bishop <[hidden email]> wrote:
> > Thank you Ulrik. I actually don't want to install SparkR, just don't want
> > to have that error message when R starts. For some reason, R is trying to
> > load the package every time it starts...
> >
> > Thanks
> > Lars.
> >
> > On Fri, Feb 26, 2016 at 11:53 AM, Ulrik Stervbo <[hidden email]>
> > wrote:
> >
> >> Hi Lars,
> >>
> >> The error tells you that SparkR is not installed.
> >>
> >> I believe you can install it like this:
> >>
> >> library(devtools)
> >> install_github("amplab-extras/SparkR-pkg", subdir="pkg")
> >>
> >> I took it from https://github.com/amplab-extras/SparkR-pkg and I haven't
> >> tried it myself.
> >>
> >> Hope this helps,
> >> Ulrik
> >>
> >> On Fri, 26 Feb 2016 at 17:40 Lars Bishop <[hidden email]> wrote:
> >>
> >>> Hello,
> >>>
> >>> Just installed R version 3.2.3, and I'm getting the error message below
> >>> every time I start R. I had SparkR installed in the prior version. I
> >>> googled this problem, but didn;t find anything useful.
> >>>
> >>> Any help would be very appreciated.
> >>>
> >>> Error in library(SparkR) : there is no package called ‘SparkR’
> >>> [R.app GUI 1.66 (7060) x86_64-apple-darwin13.4.0]
> >>>
> >>>
> >>> Best,
> >>> Lars.
> >>>
>
> ______________________________________________
> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: Annoying startup error message

Lars Bishop-2
I understand the solution would be to unset my "SPARK_HOME" environment
variable. I can do this with Sys.unsetenv() but it does not unset
permanently (only in the session). How can I unset permanently?

Sys.getenv("SPARK_HOME")
[1] "/Users/lars/Downloads/spark-1.6.0-bin-hadoop2.6/bin/spark"

Sys.unsetenv("SPARK_HOME")
Sys.getenv("SPARK_HOME")
[1] ""


Thanks again for you help!
Lars.

On Fri, Feb 26, 2016 at 2:11 PM, Duncan Murdoch <[hidden email]>
wrote:

> On 26/02/2016 12:07 PM, Sarah Goslee wrote:
>
>> Perhaps you at one point added it to your .RProfile so the package is
>> loaded at startup. You can check by starting R from the command line
>> with
>> R --vanilla
>> which doesn't load any of the profile files.
>>
>> https://stat.ethz.ch/R-manual/R-devel/library/base/html/Startup.html
>>
>
> Another possibility is that SparkR defines some S4 classes, and you have
> an object of that type in your workspace.  To read it might need SparkR
> installed.
>
> The solution here is to run R --vanilla as above, or to delete the object
> from the workspace, or the whole workspace.
>
> Duncan Murdoch
>
>
>> Sarah
>>
>> On Fri, Feb 26, 2016 at 12:01 PM, Lars Bishop <[hidden email]> wrote:
>> > Thank you Ulrik. I actually don't want to install SparkR, just don't
>> want
>> > to have that error message when R starts. For some reason, R is trying
>> to
>> > load the package every time it starts...
>> >
>> > Thanks
>> > Lars.
>> >
>> > On Fri, Feb 26, 2016 at 11:53 AM, Ulrik Stervbo <
>> [hidden email]>
>> > wrote:
>> >
>> >> Hi Lars,
>> >>
>> >> The error tells you that SparkR is not installed.
>> >>
>> >> I believe you can install it like this:
>> >>
>> >> library(devtools)
>> >> install_github("amplab-extras/SparkR-pkg", subdir="pkg")
>> >>
>> >> I took it from https://github.com/amplab-extras/SparkR-pkg and I
>> haven't
>> >> tried it myself.
>> >>
>> >> Hope this helps,
>> >> Ulrik
>> >>
>> >> On Fri, 26 Feb 2016 at 17:40 Lars Bishop <[hidden email]> wrote:
>> >>
>> >>> Hello,
>> >>>
>> >>> Just installed R version 3.2.3, and I'm getting the error message
>> below
>> >>> every time I start R. I had SparkR installed in the prior version. I
>> >>> googled this problem, but didn;t find anything useful.
>> >>>
>> >>> Any help would be very appreciated.
>> >>>
>> >>> Error in library(SparkR) : there is no package called ‘SparkR’
>> >>> [R.app GUI 1.66 (7060) x86_64-apple-darwin13.4.0]
>> >>>
>> >>>
>> >>> Best,
>> >>> Lars.
>> >>>
>>
>> ______________________________________________
>> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
>> https://stat.ethz.ch/mailman/listinfo/r-help
>> PLEASE do read the posting guide
>> http://www.R-project.org/posting-guide.html
>> and provide commented, minimal, self-contained, reproducible code.
>>
>
>

        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: Annoying startup error message

Duncan Murdoch-2
On 26/02/2016 3:36 PM, Lars Bishop wrote:

> I understand the solution would be to unset my "SPARK_HOME" environment
> variable. I can do this with Sys.unsetenv() but it does not unset
> permanently (only in the session). How can I unset permanently?
>
> Sys.getenv("SPARK_HOME")
> [1] "/Users/lars/Downloads/spark-1.6.0-bin-hadoop2.6/bin/spark"
>
> Sys.unsetenv("SPARK_HOME")
> Sys.getenv("SPARK_HOME")
> [1] ""
>

R doesn't look at that variable, so that would not be the cause.

Duncan Murdoch

>
> Thanks again for you help!
> Lars.
>
> On Fri, Feb 26, 2016 at 2:11 PM, Duncan Murdoch <[hidden email]>
> wrote:
>
>> On 26/02/2016 12:07 PM, Sarah Goslee wrote:
>>
>>> Perhaps you at one point added it to your .RProfile so the package is
>>> loaded at startup. You can check by starting R from the command line
>>> with
>>> R --vanilla
>>> which doesn't load any of the profile files.
>>>
>>> https://stat.ethz.ch/R-manual/R-devel/library/base/html/Startup.html
>>>
>>
>> Another possibility is that SparkR defines some S4 classes, and you have
>> an object of that type in your workspace.  To read it might need SparkR
>> installed.
>>
>> The solution here is to run R --vanilla as above, or to delete the object
>> from the workspace, or the whole workspace.
>>
>> Duncan Murdoch
>>
>>
>>> Sarah
>>>
>>> On Fri, Feb 26, 2016 at 12:01 PM, Lars Bishop <[hidden email]> wrote:
>>>> Thank you Ulrik. I actually don't want to install SparkR, just don't
>>> want
>>>> to have that error message when R starts. For some reason, R is trying
>>> to
>>>> load the package every time it starts...
>>>>
>>>> Thanks
>>>> Lars.
>>>>
>>>> On Fri, Feb 26, 2016 at 11:53 AM, Ulrik Stervbo <
>>> [hidden email]>
>>>> wrote:
>>>>
>>>>> Hi Lars,
>>>>>
>>>>> The error tells you that SparkR is not installed.
>>>>>
>>>>> I believe you can install it like this:
>>>>>
>>>>> library(devtools)
>>>>> install_github("amplab-extras/SparkR-pkg", subdir="pkg")
>>>>>
>>>>> I took it from https://github.com/amplab-extras/SparkR-pkg and I
>>> haven't
>>>>> tried it myself.
>>>>>
>>>>> Hope this helps,
>>>>> Ulrik
>>>>>
>>>>> On Fri, 26 Feb 2016 at 17:40 Lars Bishop <[hidden email]> wrote:
>>>>>
>>>>>> Hello,
>>>>>>
>>>>>> Just installed R version 3.2.3, and I'm getting the error message
>>> below
>>>>>> every time I start R. I had SparkR installed in the prior version. I
>>>>>> googled this problem, but didn;t find anything useful.
>>>>>>
>>>>>> Any help would be very appreciated.
>>>>>>
>>>>>> Error in library(SparkR) : there is no package called ‘SparkR’
>>>>>> [R.app GUI 1.66 (7060) x86_64-apple-darwin13.4.0]
>>>>>>
>>>>>>
>>>>>> Best,
>>>>>> Lars.
>>>>>>
>>>
>>> ______________________________________________
>>> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
>>> https://stat.ethz.ch/mailman/listinfo/r-help
>>> PLEASE do read the posting guide
>>> http://www.R-project.org/posting-guide.html
>>> and provide commented, minimal, self-contained, reproducible code.
>>>
>>
>>
>

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.