Call to R.exe in a Script fails since the upgrade from R 3.6.1 to R 4.0.2

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Call to R.exe in a Script fails since the upgrade from R 3.6.1 to R 4.0.2

Marcel Baumgartner

Dear R Community,  
 
I call R from within a software called “IDEA” ([www.casewareanalytics.com](http://www.casewareanalytics.com)). This language uses its own scripting language, but it is very similar to Visual Basic. The basic call is as shown below:  


R_Command is a string of the form (the Chr(34) creates a double quote):
In my file “script.R”, I then start everything by:
This has worked perfectly up to R 3.6.1. But since I migrated to R 4.0.2, this command does not create the “log.txt” anymore. The script runs, it finds the arguments in the file “nga_config.R”, generates the output data, but then does not write the log.txt. However, when I run this R_command on the command line in Windows, all works fine: the log.txt is created. So the syntax is correct.
In the R windows FAQ, i see this:  
 
### 2.12 Can I use `R CMD BATCH`?  


Yes: use `R CMD BATCH --help` or `?BATCH` for full details.  


You can also set up a batch file using `Rterm.exe`. A sample batch file might contain (as one line)  



I tried this, but I have the same issue: the output file ("log.txt") is not crated. Also, choosing R.exe and Rterm.exe has no impact.  
 
Do you know whether something has changed in R 4.* that could cause this issue?  
 
Thanks for your help. Happy to do a Skype/Teams/Zoom session anytime!  
 
Best regards  
 
Marcel Baumgartner  
 


        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.