Cannot install RPostgreSQL

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Cannot install RPostgreSQL

Drew
Hello everyone,

I am extremely new to R. I have yet to write any complicated code myself, however I have been learning largely by reading code that has already been written. Long story short, I have been running a code that makes use of the RPostgreSQL package for some time now. For some reason I just recently started to get an error. Whenever I try to load the RPostgreSQL package I get:

> library(RPostgreSQL)
Error in library(RPostgreSQL) : there is no package called ‘RPostgreSQL’

I also tried install.packages(RPostgreSQL) and install.packages("RPostgreSQL"). I've attached a text document of the resulting error here.

Error.txt

I'm running R version 2.15.1 on Ubuntu. I can't seem to find a solution to the problem online. And let me be clear, I was able to load this package without an issue no longer than a week ago. Any help you can offer would be much appreciated.

Thanks,

Drew
Reply | Threaded
Open this post in threaded view
|

Re: Cannot install RPostgreSQL

Pascal Oettli-2
Hello,

If you carefully check the error message, it is clearly written:

RS-PostgreSQL.h:23:26: fatal error: libpq-fe.h: No such file or directory

Some header files are missing.
Here is the result of a quick search on the web: "libpq-dev" for Ubuntu.

If I may suggest, you should upgrade the version of R.

Regards,
Pascal


On 13/06/13 03:13, Drew wrote:

> Hello everyone,
>
> I am extremely new to R. I have yet to write any complicated code myself,
> however I have been learning largely by reading code that has already been
> written. Long story short, I have been running a code that makes use of the
> RPostgreSQL package for some time now. For some reason I just recently
> started to get an error. Whenever I try to load the RPostgreSQL package I
> get:
>
>> library(RPostgreSQL)
> Error in library(RPostgreSQL) : there is no package called ‘RPostgreSQL’
>
> I also tried install.packages(RPostgreSQL) and
> install.packages("RPostgreSQL"). I've attached a text document of the
> resulting error here.
>
> Error.txt <http://r.789695.n4.nabble.com/file/n4669380/Error.txt>
>
> I'm running R version 2.15.1 on Ubuntu. I can't seem to find a solution to
> the problem online. And let me be clear, I was able to load this package
> without an issue no longer than a week ago. Any help you can offer would be
> much appreciated.
>
> Thanks,
>
> Drew
>
>
>
> --
> View this message in context: http://r.789695.n4.nabble.com/Cannot-install-RPostgreSQL-tp4669380.html
> Sent from the R help mailing list archive at Nabble.com.
>
> ______________________________________________
> [hidden email] mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.
>

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.