Cannot install dplyr

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Cannot install dplyr

addem
So I've tried many methods to get dyplr installed, I'll detail each of the
methods and issues below.  I'm running a new Linux machine with Pop!_OS.

*From the package manager*

I tried installing r-base from the package manager but it delivers a version
so out of date that when I try to install dyplr it throws an error.  As far
as I can tell from researching the error, the only resolution is to not
install from the package manager.

*From precompiled binaries*

I don't fully get what I'm doing but as I understand it (I am not an
especially tech-savvy person) the precompiled binaries are located here:
Binaries <https://mirrors.nics.utk.edu/cran/>    However, given that my OS
is none of those listed, I was wary of trying this.  I tried anyway,
guessing using the Ubuntu trusty one might do something, got a public key
error.

```
W: GPG error: https://cloud.r-project.org/bin/linux/ubuntu trusty/ Release:
The following signatures couldn't be verified because the public key is not
available: NO_PUBKEY 51716619E084DAB9
```

I searched the error, don't really understand what I read about how to
resolve it.  But I'm guessing it has something to do with needing to already
have a public key and I don't.  So maybe this solution isn't meant for me.

*Compiling from sources*

Trying to follow any (and all) instructions I could find on building from
source files, I downloaded from here:  R souce
<https://cran.r-project.org/src/base/R-3/>  .  I unzipped, navigated in, ran
`sudo ./configure`.  After chasing a lot of errors and trying to resolve
them I eventually got it installed.  Then downloaded RStudio and tried to
install it, but it couldn't find R.  After researching the error I found a
suggestion to run `./configure` with the `--enable-R-shlib`.  Did that, now
I run `make` and get

```
[Some other stuff up above here]
/usr/bin/ld: ../unix/X11.o: relocation R_X86_64_PC32 against symbol
`R_GUIType' can not be used when making a shared object; recompile with
-fPIC
/usr/bin/ld: final link failed: nonrepresentable section on output
collect2: error: ld returned 1 exit status
make[3]: *** [Makefile:177: libR.so] Error 1
make[3]: Leaving directory '/home/addem/Downloads/R-3.6.1/src/main'
make[2]: *** [Makefile:135: R] Error 2
make[2]: Leaving directory '/home/addem/Downloads/R-3.6.1/src/main'
make[1]: *** [Makefile:28: R] Error 1
make[1]: Leaving directory '/home/addem/Downloads/R-3.6.1/src'
make: *** [Makefile:61: R] Error 1
```

After searching this error I can't find a resolution.

-----

And just to be clear about what I'm trying to do here: All I want is R
running with RStudio, and is able to install the dplyr package.  If this can
be done in any way, I don't care which way it's done.

If any log files or whatever would be useful for any one of these three
installation attempts, just ask.

Thanks.

        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Reply | Threaded
Open this post in threaded view
|

Re: Cannot install dplyr

Dirk Eddelbuettel

Adam,

This can indeed be very frustrating.  But depending on the choices you make
it does not have to be that way.  Most Linux distributions have 'something'
it may not be comprehensive or current. So most of the time you need to be
able to compile from source. Which is not that hard, and can be
learned. Maybe there is a user group near you.

Otherwise and not so well known is that Michael Rutter is (single-handedly)
keeping an effort we once called 'cran2deb' alive (in what we could call the
third iteration of this; I had been involved in some earlier ones [1]).

So if you run Ubuntu LTS you get over 4,000 CRAN packages ready-made.  But
you should really run Ubuntu LTS (currently 18.04) or a compatiable release
(ie a new Ubuntu release).

That maybe be best seen rather than read so to complement earlier blog posts
I made a video showing how even installation of the entire tidyverse (and its
80+ packages including dplyr), or rstan (which is also heavy 'from source'
due to loads of C++ compilation), boils down to a single command (!!) and a
mere two minutes of automated downloading and unpackaging.  See

   http://dirk.eddelbuettel.com/blog/2019/06/09#022_rocker_and_ppas

for a few slides and a link to the video you could also jump at directly at

   https://www.youtube.com/watch?v=qIjWirNma-8

Having something like this _comprehensively_ across a few distros is clearly
needed.

But the only active effort I know of appears to be an RStudio effort related
to their their (commercial only, AFAIK) package manager.  Needless to say, I
would much rather have this as an open community effort, but sadly, wishing
alone does not make it so. [1]

Dirk

   
[1] And one potential implementation effort was halted when the R Consortium
ISC lead decided it was better to withdraw the grant they had given me (as
PI) and a few others than to further support the effort.  

--
http://dirk.eddelbuettel.com | @eddelbuettel | [hidden email]

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Reply | Threaded
Open this post in threaded view
|

Re: Cannot install dplyr

Dirk Eddelbuettel

Adam,

Apologies for typos in previous email -- and follow-ups should probably go to
the r-sig-debian list which support R on .deb based distros. I am not sure
have readers from the derivative distro you use, but there is a fairly wide
spread of users there beyond "just" Debian or Ubuntu. Subscribe first, then
post.

Best,  Dirk

--
http://dirk.eddelbuettel.com | @eddelbuettel | [hidden email]

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel