Cannot load vegan and vcd, "object vI not found"

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Cannot load vegan and vcd, "object vI not found"

Camilo Bernardo Garcia Ramirez
Hi: Could you help me with the following issue?:

I downloaded the packages vegan and vcd with R3.6.1. When I try to load
them I got this error messages:

 > library(vegan)
Loading required package: permute
Loading required package: lattice
Error: package or namespace load failed for ‘vegan’ in loadNamespace(j <-
i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
 objeto 'vI' no encontrado (translation: object vI not found - my R is in
Spanish)

> library(vcd)
Loading required package: grid
Error: package or namespace load failed for ‘vcd’ in loadNamespace(j <-
i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
 objeto 'vI' no encontrado (translation: object vI not found - my R is in
Spanish)

Sofar no one knows what that means. I am not an R expert! Could you help
me?.
Regards,
Camilo B. Garcia

--
Camilo B. García, Dr. rer. nat
Profesor Asociado, Departamento de Biología
Universidad Nacional de Colombia - Sede Bogotá

        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: Cannot load vegan and vcd, "object vI not found"

Jeff Newmiller
Try closing all instances of R except for one and then run the update.packages() function. If that doesn't work then post the output of sessionInfo().

On August 19, 2019 5:11:11 AM PDT, Camilo Bernardo Garcia Ramirez <[hidden email]> wrote:

>Hi: Could you help me with the following issue?:
>
>I downloaded the packages vegan and vcd with R3.6.1. When I try to load
>them I got this error messages:
>
> > library(vegan)
>Loading required package: permute
>Loading required package: lattice
>Error: package or namespace load failed for ‘vegan’ in loadNamespace(j
><-
>i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
>objeto 'vI' no encontrado (translation: object vI not found - my R is
>in
>Spanish)
>
>> library(vcd)
>Loading required package: grid
>Error: package or namespace load failed for ‘vcd’ in loadNamespace(j <-
>i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
>objeto 'vI' no encontrado (translation: object vI not found - my R is
>in
>Spanish)
>
>Sofar no one knows what that means. I am not an R expert! Could you
>help
>me?.
>Regards,
>Camilo B. Garcia

--
Sent from my phone. Please excuse my brevity.

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: Cannot load vegan and vcd, "object vI not found"

Martin Maechler
>>>>> Jeff Newmiller
>>>>>     on Mon, 19 Aug 2019 17:38:19 -0700 writes:

    > Try closing all instances of R except for one and then run the update.packages() function. If that doesn't work then post the output of sessionInfo().

I also strongly suspect that some of the packages concerned were
not correctly installed.

    > On August 19, 2019 5:11:11 AM PDT, Camilo Bernardo Garcia Ramirez <[hidden email]> wrote:
    >> Hi: Could you help me with the following issue?:
    >>
    >> I downloaded the packages vegan and vcd with R3.6.1. When I try to load
    >> them I got this error messages:
    >>
    >> > library(vegan)
    >> Loading required package: permute
    >> Loading required package: lattice
    >> Error: package or namespace load failed for ‘vegan’ in loadNamespace(j
    >> <-
    >> i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
    >> objeto 'vI' no encontrado (translation: object vI not found - my R is
    >> in
    >> Spanish)

The error message above comes from base R's function
loadNamespace()  [which calls itself recursively, when importing
from other packages].

I think the error message is not really useful, and indeed I think
should *not* happen at this time:  'vI' is not defined here,
because earlier the 'pkgInfo' result was not really valid.

So I think you may have touched on a "buglet" in R in the sense
that for such semi-validly / invalidly installed packages, you
should get a better error message.

Martin Maechler
ETH Zurich  and  R Core team.


    >>> library(vcd)
    >> Loading required package: grid
    >> Error: package or namespace load failed for ‘vcd’ in loadNamespace(j <-
    >> i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
    >> objeto 'vI' no encontrado (translation: object vI not found - my R is
    >> in
    >> Spanish)
    >>
    >> Sofar no one knows what that means. I am not an R expert! Could you
    >> help
    >> me?.
    >> Regards,
    >> Camilo B. Garcia

    > --
    > Sent from my phone. Please excuse my brevity.

    > ______________________________________________
    > [hidden email] mailing list -- To UNSUBSCRIBE and more, see
    > https://stat.ethz.ch/mailman/listinfo/r-help
    > PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
    > and provide commented, minimal, self-contained, reproducible code.

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: Cannot load vegan and vcd, "object vI not found"

Camilo Bernardo Garcia Ramirez
Hi again: First at all, thanks for your answer. My problem is still there.
Here the session. I did remove and (re)install vegan and then called for
update but no effect in the error. I included the sessionInfo() at the end.
Camilo

> remove.packages("vegan")
Removing package from ‘C:/Users/Camilo/Documents/R/win-library/3.6’
(as ‘lib’ is unspecified)
> install.packages("vegan", dependencies=TRUE)
Installing package into ‘C:/Users/Camilo/Documents/R/win-library/3.6’
(as ‘lib’ is unspecified)
--- Please select a CRAN mirror for use in this session ---
probando la URL '
https://cran.wu.ac.at/bin/windows/contrib/3.6/vegan_2.5-5.zip'
Content type 'application/zip' length 3862370 bytes (3.7 MB)
downloaded 3.7 MB

package ‘vegan’ successfully unpacked and MD5 sums checked

The downloaded binary packages are in
        C:\Users\Camilo\AppData\Local\Temp\Rtmpu0yOZa\downloaded_packages
> update.packages("vegan")
> library(vegan)
Loading required package: permute
Loading required package: lattice
Error: package or namespace load failed for ‘vegan’ in loadNamespace(j <-
i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
 objeto 'vI' no encontrado

> sessionInfo()
R version 3.6.1 (2019-07-05)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 10 x64 (build 17134)

Matrix products: default

locale:
[1] LC_COLLATE=Spanish_Spain.1252  LC_CTYPE=Spanish_Spain.1252
[3] LC_MONETARY=Spanish_Spain.1252 LC_NUMERIC=C
[5] LC_TIME=Spanish_Spain.1252

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base

other attached packages:
[1] lattice_0.20-38 permute_0.9-5

loaded via a namespace (and not attached):
[1] compiler_3.6.1 parallel_3.6.1 tools_3.6.1    grid_3.6.1
>

El mar., 20 ago. 2019 a las 5:31, Martin Maechler (<
[hidden email]>) escribió:

> >>>>> Jeff Newmiller
> >>>>>     on Mon, 19 Aug 2019 17:38:19 -0700 writes:
>
>     > Try closing all instances of R except for one and then run the
> update.packages() function. If that doesn't work then post the output of
> sessionInfo().
>
> I also strongly suspect that some of the packages concerned were
> not correctly installed.
>
>     > On August 19, 2019 5:11:11 AM PDT, Camilo Bernardo Garcia Ramirez <
> [hidden email]> wrote:
>     >> Hi: Could you help me with the following issue?:
>     >>
>     >> I downloaded the packages vegan and vcd with R3.6.1. When I try to
> load
>     >> them I got this error messages:
>     >>
>     >> > library(vegan)
>     >> Loading required package: permute
>     >> Loading required package: lattice
>     >> Error: package or namespace load failed for ‘vegan’ in
> loadNamespace(j
>     >> <-
>     >> i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
>     >> objeto 'vI' no encontrado (translation: object vI not found - my R
> is
>     >> in
>     >> Spanish)
>
> The error message above comes from base R's function
> loadNamespace()  [which calls itself recursively, when importing
> from other packages].
>
> I think the error message is not really useful, and indeed I think
> should *not* happen at this time:  'vI' is not defined here,
> because earlier the 'pkgInfo' result was not really valid.
>
> So I think you may have touched on a "buglet" in R in the sense
> that for such semi-validly / invalidly installed packages, you
> should get a better error message.
>
> Martin Maechler
> ETH Zurich  and  R Core team.
>
>
>     >>> library(vcd)
>     >> Loading required package: grid
>     >> Error: package or namespace load failed for ‘vcd’ in
> loadNamespace(j <-
>     >> i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
>     >> objeto 'vI' no encontrado (translation: object vI not found - my R
> is
>     >> in
>     >> Spanish)
>     >>
>     >> Sofar no one knows what that means. I am not an R expert! Could you
>     >> help
>     >> me?.
>     >> Regards,
>     >> Camilo B. Garcia
>
>     > --
>     > Sent from my phone. Please excuse my brevity.
>
>     > ______________________________________________
>     > [hidden email] mailing list -- To UNSUBSCRIBE and more, see
>     > https://stat.ethz.ch/mailman/listinfo/r-help
>     > PLEASE do read the posting guide
> http://www.R-project.org/posting-guide.html
>     > and provide commented, minimal, self-contained, reproducible code.
>


--
Camilo B. García, Dr. rer. nat
Profesor Asociado, Departamento de Biología
Universidad Nacional de Colombia - Sede Bogotá

        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: Cannot load vegan and vcd, "object vI not found"

Sarah Goslee
Hi,

You misunderstood the suggestion, which was to run update.packages()
to update all packages, not just vegan (which doesn't need updated
because you just reinstalled it).
To make your own life easier, I'd run it as:

update.packages(ask=FALSE, checkBuilt = TRUE)

You could also try reinstalling the packages that vegan requires,
which seems to be where the error actually is. (lattice, perhaps, but
I'd reinstall

Sarah

On Tue, Aug 20, 2019 at 6:27 PM Camilo Bernardo Garcia Ramirez
<[hidden email]> wrote:

>
> Hi again: First at all, thanks for your answer. My problem is still there.
> Here the session. I did remove and (re)install vegan and then called for
> update but no effect in the error. I included the sessionInfo() at the end.
> Camilo
>
> > remove.packages("vegan")
> Removing package from ‘C:/Users/Camilo/Documents/R/win-library/3.6’
> (as ‘lib’ is unspecified)
> > install.packages("vegan", dependencies=TRUE)
> Installing package into ‘C:/Users/Camilo/Documents/R/win-library/3.6’
> (as ‘lib’ is unspecified)
> --- Please select a CRAN mirror for use in this session ---
> probando la URL '
> https://cran.wu.ac.at/bin/windows/contrib/3.6/vegan_2.5-5.zip'
> Content type 'application/zip' length 3862370 bytes (3.7 MB)
> downloaded 3.7 MB
>
> package ‘vegan’ successfully unpacked and MD5 sums checked
>
> The downloaded binary packages are in
>         C:\Users\Camilo\AppData\Local\Temp\Rtmpu0yOZa\downloaded_packages
> > update.packages("vegan")
> > library(vegan)
> Loading required package: permute
> Loading required package: lattice
> Error: package or namespace load failed for ‘vegan’ in loadNamespace(j <-
> i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
>  objeto 'vI' no encontrado
>
> > sessionInfo()
> R version 3.6.1 (2019-07-05)
> Platform: x86_64-w64-mingw32/x64 (64-bit)
> Running under: Windows 10 x64 (build 17134)
>
> Matrix products: default
>
> locale:
> [1] LC_COLLATE=Spanish_Spain.1252  LC_CTYPE=Spanish_Spain.1252
> [3] LC_MONETARY=Spanish_Spain.1252 LC_NUMERIC=C
> [5] LC_TIME=Spanish_Spain.1252
>
> attached base packages:
> [1] stats     graphics  grDevices utils     datasets  methods   base
>
> other attached packages:
> [1] lattice_0.20-38 permute_0.9-5
>
> loaded via a namespace (and not attached):
> [1] compiler_3.6.1 parallel_3.6.1 tools_3.6.1    grid_3.6.1
> >
>
> El mar., 20 ago. 2019 a las 5:31, Martin Maechler (<
> [hidden email]>) escribió:
>
> > >>>>> Jeff Newmiller
> > >>>>>     on Mon, 19 Aug 2019 17:38:19 -0700 writes:
> >
> >     > Try closing all instances of R except for one and then run the
> > update.packages() function. If that doesn't work then post the output of
> > sessionInfo().
> >
> > I also strongly suspect that some of the packages concerned were
> > not correctly installed.
> >
> >     > On August 19, 2019 5:11:11 AM PDT, Camilo Bernardo Garcia Ramirez <
> > [hidden email]> wrote:
> >     >> Hi: Could you help me with the following issue?:
> >     >>
> >     >> I downloaded the packages vegan and vcd with R3.6.1. When I try to
> > load
> >     >> them I got this error messages:
> >     >>
> >     >> > library(vegan)
> >     >> Loading required package: permute
> >     >> Loading required package: lattice
> >     >> Error: package or namespace load failed for ‘vegan’ in
> > loadNamespace(j
> >     >> <-
> >     >> i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
> >     >> objeto 'vI' no encontrado (translation: object vI not found - my R
> > is
> >     >> in
> >     >> Spanish)
> >
> > The error message above comes from base R's function
> > loadNamespace()  [which calls itself recursively, when importing
> > from other packages].
> >
> > I think the error message is not really useful, and indeed I think
> > should *not* happen at this time:  'vI' is not defined here,
> > because earlier the 'pkgInfo' result was not really valid.
> >
> > So I think you may have touched on a "buglet" in R in the sense
> > that for such semi-validly / invalidly installed packages, you
> > should get a better error message.
> >
> > Martin Maechler
> > ETH Zurich  and  R Core team.
> >
> >
> >     >>> library(vcd)
> >     >> Loading required package: grid
> >     >> Error: package or namespace load failed for ‘vcd’ in
> > loadNamespace(j <-
> >     >> i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
> >     >> objeto 'vI' no encontrado (translation: object vI not found - my R
> > is
> >     >> in
> >     >> Spanish)
> >     >>
> >     >> Sofar no one knows what that means. I am not an R expert! Could you
> >     >> help
> >     >> me?.
> >     >> Regards,
> >     >> Camilo B. Garcia
> >
> >     > --

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: Cannot load vegan and vcd, "object vI not found"

Camilo Bernardo Garcia Ramirez
Dear All: Problem solved. Package MASS was not properly installed. Thanks a
lot.
Camilo B. Garcia

El mié., 21 ago. 2019 a las 12:26, Sarah Goslee (<[hidden email]>)
escribió:

> Hi,
>
> You misunderstood the suggestion, which was to run update.packages()
> to update all packages, not just vegan (which doesn't need updated
> because you just reinstalled it).
> To make your own life easier, I'd run it as:
>
> update.packages(ask=FALSE, checkBuilt = TRUE)
>
> You could also try reinstalling the packages that vegan requires,
> which seems to be where the error actually is. (lattice, perhaps, but
> I'd reinstall
>
> Sarah
>
> On Tue, Aug 20, 2019 at 6:27 PM Camilo Bernardo Garcia Ramirez
> <[hidden email]> wrote:
> >
> > Hi again: First at all, thanks for your answer. My problem is still
> there.
> > Here the session. I did remove and (re)install vegan and then called for
> > update but no effect in the error. I included the sessionInfo() at the
> end.
> > Camilo
> >
> > > remove.packages("vegan")
> > Removing package from ‘C:/Users/Camilo/Documents/R/win-library/3.6’
> > (as ‘lib’ is unspecified)
> > > install.packages("vegan", dependencies=TRUE)
> > Installing package into ‘C:/Users/Camilo/Documents/R/win-library/3.6’
> > (as ‘lib’ is unspecified)
> > --- Please select a CRAN mirror for use in this session ---
> > probando la URL '
> > https://cran.wu.ac.at/bin/windows/contrib/3.6/vegan_2.5-5.zip'
> > Content type 'application/zip' length 3862370 bytes (3.7 MB)
> > downloaded 3.7 MB
> >
> > package ‘vegan’ successfully unpacked and MD5 sums checked
> >
> > The downloaded binary packages are in
> >         C:\Users\Camilo\AppData\Local\Temp\Rtmpu0yOZa\downloaded_packages
> > > update.packages("vegan")
> > > library(vegan)
> > Loading required package: permute
> > Loading required package: lattice
> > Error: package or namespace load failed for ‘vegan’ in loadNamespace(j <-
> > i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
> >  objeto 'vI' no encontrado
> >
> > > sessionInfo()
> > R version 3.6.1 (2019-07-05)
> > Platform: x86_64-w64-mingw32/x64 (64-bit)
> > Running under: Windows 10 x64 (build 17134)
> >
> > Matrix products: default
> >
> > locale:
> > [1] LC_COLLATE=Spanish_Spain.1252  LC_CTYPE=Spanish_Spain.1252
> > [3] LC_MONETARY=Spanish_Spain.1252 LC_NUMERIC=C
> > [5] LC_TIME=Spanish_Spain.1252
> >
> > attached base packages:
> > [1] stats     graphics  grDevices utils     datasets  methods   base
> >
> > other attached packages:
> > [1] lattice_0.20-38 permute_0.9-5
> >
> > loaded via a namespace (and not attached):
> > [1] compiler_3.6.1 parallel_3.6.1 tools_3.6.1    grid_3.6.1
> > >
> >
> > El mar., 20 ago. 2019 a las 5:31, Martin Maechler (<
> > [hidden email]>) escribió:
> >
> > > >>>>> Jeff Newmiller
> > > >>>>>     on Mon, 19 Aug 2019 17:38:19 -0700 writes:
> > >
> > >     > Try closing all instances of R except for one and then run the
> > > update.packages() function. If that doesn't work then post the output
> of
> > > sessionInfo().
> > >
> > > I also strongly suspect that some of the packages concerned were
> > > not correctly installed.
> > >
> > >     > On August 19, 2019 5:11:11 AM PDT, Camilo Bernardo Garcia
> Ramirez <
> > > [hidden email]> wrote:
> > >     >> Hi: Could you help me with the following issue?:
> > >     >>
> > >     >> I downloaded the packages vegan and vcd with R3.6.1. When I try
> to
> > > load
> > >     >> them I got this error messages:
> > >     >>
> > >     >> > library(vegan)
> > >     >> Loading required package: permute
> > >     >> Loading required package: lattice
> > >     >> Error: package or namespace load failed for ‘vegan’ in
> > > loadNamespace(j
> > >     >> <-
> > >     >> i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
> > >     >> objeto 'vI' no encontrado (translation: object vI not found -
> my R
> > > is
> > >     >> in
> > >     >> Spanish)
> > >
> > > The error message above comes from base R's function
> > > loadNamespace()  [which calls itself recursively, when importing
> > > from other packages].
> > >
> > > I think the error message is not really useful, and indeed I think
> > > should *not* happen at this time:  'vI' is not defined here,
> > > because earlier the 'pkgInfo' result was not really valid.
> > >
> > > So I think you may have touched on a "buglet" in R in the sense
> > > that for such semi-validly / invalidly installed packages, you
> > > should get a better error message.
> > >
> > > Martin Maechler
> > > ETH Zurich  and  R Core team.
> > >
> > >
> > >     >>> library(vcd)
> > >     >> Loading required package: grid
> > >     >> Error: package or namespace load failed for ‘vcd’ in
> > > loadNamespace(j <-
> > >     >> i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
> > >     >> objeto 'vI' no encontrado (translation: object vI not found -
> my R
> > > is
> > >     >> in
> > >     >> Spanish)
> > >     >>
> > >     >> Sofar no one knows what that means. I am not an R expert! Could
> you
> > >     >> help
> > >     >> me?.
> > >     >> Regards,
> > >     >> Camilo B. Garcia
> > >
> > >     > --
>


--
Camilo B. García, Dr. rer. nat
Profesor Asociado, Departamento de Biología
Universidad Nacional de Colombia - Sede Bogotá

        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.