How to install R 4.0 on chromebook?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

How to install R 4.0 on chromebook?

Luigi
Hello,
I have tried to upgrade R to 4.0. I have added `deb
http://cloud.r-project.org/bin/linux/debian buster-cran40/` to
`/etc/apt/sources.list`
(but I removed cran35). Btu when I run `apt-get update; apt-get install
r-base r-base-dev` I get an error. I think it depends on r-base-core, since
it depends on these obsolete libraries:
```
$ sudo apt-get install r-base-core
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 r-base-core : Depends: libc6 (>= 2.27) but 2.24-11+deb9u4 is to be
installed
               Depends: libcurl4 (>= 7.28.0) but it is not installable
               Depends: libgfortran5 (>= 8) but it is not installable
               Depends: libicu63 (>= 63.1-1~) but it is not installable
               Depends: libpcre2-8-0 (>= 10.32) but it is not going to be
installed
               Recommends: r-recommended but it is not going to be installed
               Recommends: r-base-dev but it is not going to be installed
               Recommends: r-doc-html but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
```
How can I upgrade these libraries on Chromebook?
Thank you

--
Best regards,
Luigi

        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: How to install R 4.0 on chromebook?

R help mailing list-2
Hi,

You appear to have installed Debian on a Chromebook, presumably to overcome the limitations otherwise present in Chrome OS.

Since the questions you pose are specific to Debian, there is an R e-mail list focused on the use of R on Debian based computers:

  https://stat.ethz.ch/mailman/listinfo/r-sig-debian

You should subscribe to that list and post your queries there to avail yourself of a focused audience, which may include folks that have installed a Debian based Linux distribution on a Chromebook.

Regards,

Marc Schwartz


> On May 22, 2020, at 9:49 AM, Luigi Marongiu <[hidden email]> wrote:
>
> Hello,
> I have tried to upgrade R to 4.0. I have added `deb
> http://cloud.r-project.org/bin/linux/debian buster-cran40/` to
> `/etc/apt/sources.list`
> (but I removed cran35). Btu when I run `apt-get update; apt-get install
> r-base r-base-dev` I get an error. I think it depends on r-base-core, since
> it depends on these obsolete libraries:
> ```
> $ sudo apt-get install r-base-core
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
> r-base-core : Depends: libc6 (>= 2.27) but 2.24-11+deb9u4 is to be
> installed
>               Depends: libcurl4 (>= 7.28.0) but it is not installable
>               Depends: libgfortran5 (>= 8) but it is not installable
>               Depends: libicu63 (>= 63.1-1~) but it is not installable
>               Depends: libpcre2-8-0 (>= 10.32) but it is not going to be
> installed
>               Recommends: r-recommended but it is not going to be installed
>               Recommends: r-base-dev but it is not going to be installed
>               Recommends: r-doc-html but it is not going to be installed
> E: Unable to correct problems, you have held broken packages.
> ```
> How can I upgrade these libraries on Chromebook?
> Thank you
>
> --
> Best regards,
> Luigi

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.