Installed Packages not working

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Installed Packages not working

NehaBologna
Hi, suddenly the packages I installed not working. It gives me the error:

Error: package or namespace load failed for ‘farff’ in loadNamespace(i,
c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
 namespace ‘rlang’ 0.4.7 is already loaded, but >= 0.4.10 is required

        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: Installed Packages not working

Jeff Newmiller
Either upgrade rlang or remove farff and install an older version.

On April 17, 2021 12:02:15 PM PDT, Neha gupta <[hidden email]> wrote:

>Hi, suddenly the packages I installed not working. It gives me the
>error:
>
>Error: package or namespace load failed for ‘farff’ in loadNamespace(i,
>c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
> namespace ‘rlang’ 0.4.7 is already loaded, but >= 0.4.10 is required
>
> [[alternative HTML version deleted]]
>
>______________________________________________
>[hidden email] mailing list -- To UNSUBSCRIBE and more, see
>https://stat.ethz.ch/mailman/listinfo/r-help
>PLEASE do read the posting guide
>http://www.R-project.org/posting-guide.html
>and provide commented, minimal, self-contained, reproducible code.

--
Sent from my phone. Please excuse my brevity.

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: Installed Packages not working

Duncan Murdoch-2
In reply to this post by NehaBologna
On 17/04/2021 3:02 p.m., Neha gupta wrote:
> Hi, suddenly the packages I installed not working. It gives me the error:
>
> Error: package or namespace load failed for ‘farff’ in loadNamespace(i,
> c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
>   namespace ‘rlang’ 0.4.7 is already loaded, but >= 0.4.10 is required

Something you are trying to use needs rlang 0.4.10, and you don't have that.

Duncan Murdoch

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: Installed Packages not working

Rui Barradas
In reply to this post by NehaBologna
Hello,

That error message means you need to run

install.packages("rlang")

before running

library(farff)


Hope this helps,

Rui Barradas

Às 20:02 de 17/04/21, Neha gupta escreveu:

> Hi, suddenly the packages I installed not working. It gives me the error:
>
> Error: package or namespace load failed for ‘farff’ in loadNamespace(i,
> c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
>   namespace ‘rlang’ 0.4.7 is already loaded, but >= 0.4.10 is required
>
> [[alternative HTML version deleted]]
>
> ______________________________________________
> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.
>

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: Installed Packages not working

NehaBologna
Thank you. I have installed "rlang" but now giving error message below:

Error: package or namespace load failed for ‘farff’ in loadNamespace(i,
c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
 namespace ‘rlang’ 0.4.7 is already loaded, but >= 0.4.10 is required

On Sat, Apr 17, 2021 at 9:35 PM Rui Barradas <[hidden email]> wrote:

> Hello,
>
> That error message means you need to run
>
> install.packages("rlang")
>
> before running
>
> library(farff)
>
>
> Hope this helps,
>
> Rui Barradas
>
> Às 20:02 de 17/04/21, Neha gupta escreveu:
> > Hi, suddenly the packages I installed not working. It gives me the error:
> >
> > Error: package or namespace load failed for ‘farff’ in loadNamespace(i,
> > c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
> >   namespace ‘rlang’ 0.4.7 is already loaded, but >= 0.4.10 is required
> >
> >       [[alternative HTML version deleted]]
> >
> > ______________________________________________
> > [hidden email] mailing list -- To UNSUBSCRIBE and more, see
> > https://stat.ethz.ch/mailman/listinfo/r-help
> > PLEASE do read the posting guide
> http://www.R-project.org/posting-guide.html
> > and provide commented, minimal, self-contained, reproducible code.
> >
>

        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: Installed Packages not working

NehaBologna
Thank you all.. I installed vctrs and install_dependencies and now its
working

Regards

On Sat, Apr 17, 2021 at 9:52 PM Neha gupta <[hidden email]> wrote:

> Thank you. I have installed "rlang" but now giving error message below:
>
> Error: package or namespace load failed for ‘farff’ in loadNamespace(i,
> c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
>  namespace ‘rlang’ 0.4.7 is already loaded, but >= 0.4.10 is required
>
> On Sat, Apr 17, 2021 at 9:35 PM Rui Barradas <[hidden email]> wrote:
>
>> Hello,
>>
>> That error message means you need to run
>>
>> install.packages("rlang")
>>
>> before running
>>
>> library(farff)
>>
>>
>> Hope this helps,
>>
>> Rui Barradas
>>
>> Às 20:02 de 17/04/21, Neha gupta escreveu:
>> > Hi, suddenly the packages I installed not working. It gives me the
>> error:
>> >
>> > Error: package or namespace load failed for ‘farff’ in loadNamespace(i,
>> > c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
>> >   namespace ‘rlang’ 0.4.7 is already loaded, but >= 0.4.10 is required
>> >
>> >       [[alternative HTML version deleted]]
>> >
>> > ______________________________________________
>> > [hidden email] mailing list -- To UNSUBSCRIBE and more, see
>> > https://stat.ethz.ch/mailman/listinfo/r-help
>> > PLEASE do read the posting guide
>> http://www.R-project.org/posting-guide.html
>> > and provide commented, minimal, self-contained, reproducible code.
>> >
>>
>

        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.