Pcre install

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Pcre install

yueli7
Hello,



I downloaded R-3.6.0.tar.gz from https://cran.r-project.org/src/base/R-3/.


I tried to install R-3.6.0.tar.gz in Ubuntu system.


Thanks in advance for any help!


yue




checking for pcre.h... yes
checking pcre/pcre.h usability... no
checking pcre/pcre.h presence... no
checking for pcre/pcre.h... no
checking if PCRE version >= 8.20, < 10.0 and has UTF-8 support... no
checking whether PCRE support suffices... configure: error: pcre >= 8.20 library and headers are required








        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Reply | Threaded
Open this post in threaded view
|

Re: Pcre install

Simon Urbanek
sudo apt-get install libpcre3-dev

please read the docs [R-admin: A.1 Essential programs and libraries] - you may be missing more dependencies


> On May 14, 2019, at 9:44 AM, yueli <[hidden email]> wrote:
>
> Hello,
>
>
>
> I downloaded R-3.6.0.tar.gz from https://cran.r-project.org/src/base/R-3/.
>
>
> I tried to install R-3.6.0.tar.gz in Ubuntu system.
>
>
> Thanks in advance for any help!
>
>
> yue
>
>
>
>
> checking for pcre.h... yes
> checking pcre/pcre.h usability... no
> checking pcre/pcre.h presence... no
> checking for pcre/pcre.h... no
> checking if PCRE version >= 8.20, < 10.0 and has UTF-8 support... no
> checking whether PCRE support suffices... configure: error: pcre >= 8.20 library and headers are required
>
>
>
>
>
>
>
>
> [[alternative HTML version deleted]]
>
> ______________________________________________
> [hidden email] mailing list
> https://stat.ethz.ch/mailman/listinfo/r-devel
>

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Reply | Threaded
Open this post in threaded view
|

Re: Pcre install

Adi Gherman
In reply to this post by yueli7
Yue,

it looks like you need to compile PCRE using the -enable-utf8 flag. Check out Toby’s post about this (the PCRE error specifically): https://tdhock.github.io/blog/2017/compiling-R/

Hope this helps,
Adi

Adi Gherman, MCS
Research Associate
Johns Hopkins Bloomberg School of Public Health
615 N. Wolfe Street, E3007
Baltimore, MD 21205

On May 14, 2019, at 9:44 AM, yueli <[hidden email]<mailto:[hidden email]>> wrote:


Hello,



I downloaded R-3.6.0.tar.gz from https://cran.r-project.org/src/base/R-3/.


I tried to install R-3.6.0.tar.gz in Ubuntu system.


Thanks in advance for any help!


yue




checking for pcre.h... yes
checking pcre/pcre.h usability... no
checking pcre/pcre.h presence... no
checking for pcre/pcre.h... no
checking if PCRE version >= 8.20, < 10.0 and has UTF-8 support... no
checking whether PCRE support suffices... configure: error: pcre >= 8.20 library and headers are required








[[alternative HTML version deleted]]

______________________________________________
[hidden email]<mailto:[hidden email]> mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel



        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Reply | Threaded
Open this post in threaded view
|

Re: Pcre install

Dirk Eddelbuettel
In reply to this post by yueli7

On 14 May 2019 at 21:44, yueli wrote:
| I downloaded R-3.6.0.tar.gz from https://cran.r-project.org/src/base/R-3/.
|
|
| I tried to install R-3.6.0.tar.gz in Ubuntu system.

You are likely better off to use fully-built and generally
correctly-configured R binary for Ubuntu off the CRAN mirrors. Read

   https://cloud.r-project.org/bin/linux/ubuntu/README.html

I keep the line

   deb https://cloud.r-project.org/bin/linux/ubuntu cosmic-cran35/

in /etc/apt/sources.list.d/cran.list and am on 18.10; the README explains how
to adjust for the other variants.

There is an entire mailing list dedicated to questions should you have any:

   https://stat.ethz.ch/mailman/listinfo/r-sig-debian

Dirk

--
http://dirk.eddelbuettel.com | @eddelbuettel | [hidden email]

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel