Problems with loading 'wordnet' in a standalone pc

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems with loading 'wordnet' in a standalone pc

Lamke
Hi group,

I have the following error code after submitting library(wordnet) in a standalone pc.  rJava is already in place.

Error in .jpackage(pkgname,lib.loc=libname)
unused argument(s) (lib.loc=libname)
Error: .onLoad failed in 'loadNamespace' for 'wordnet'
Error: package/namespace load failed for 'wordnet'

My guess is I miss something from the namespace but unfortunately I can't get to the internet.  Does anyone know what I'm missing (from the namespace?).  Thank you very much!

Kelvin
Reply | Threaded
Open this post in threaded view
|

Re: Problems with loading 'wordnet' in a standalone pc

Uwe Ligges-3
Looks like nobody answered so far:


Kelvin Lam wrote:
> Hi group,
>
> I have the following error code after submitting library(wordnet) in a
> standalone pc.  rJava is already in place.

Please read the posting guide and tell us:


- Which version of R?
- Which version of wordnet?
- Which version of rJava?
- Which version of Java?

If anywhere not the most recent one: Please upgrade and report again.


> Error in .jpackage(pkgname,lib.loc=libname)
> unused argument(s) (lib.loc=libname)
> Error: .onLoad failed in 'loadNamespace' for 'wordnet'
> Error: package/namespace load failed for 'wordnet'
>
> My guess is I miss something from the namespace but unfortunately I can't
> get to the internet.  Does anyone know what I'm missing (from the
> namespace?).  Thank you very much!

No, probably nothing is missing from the namespace, but probably too old
versions or strange libraries in use.

Best,
Uwe Ligges


> Kelvin

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: Problems with loading 'wordnet' in a standalone pc

Lamke
Thanks Uwe.  The wordnet is working now.  My previous configuration that causes the error was:

R - version 2.9.1
wordnet - version 0.1-4
rJava 0.6-2

After updating rJava to version 0.7-0 everything works now.


Uwe Ligges-3 wrote
Looks like nobody answered so far:


Kelvin Lam wrote:
> Hi group,
>
> I have the following error code after submitting library(wordnet) in a
> standalone pc.  rJava is already in place.

Please read the posting guide and tell us:


- Which version of R?
- Which version of wordnet?
- Which version of rJava?
- Which version of Java?

If anywhere not the most recent one: Please upgrade and report again.


> Error in .jpackage(pkgname,lib.loc=libname)
> unused argument(s) (lib.loc=libname)
> Error: .onLoad failed in 'loadNamespace' for 'wordnet'
> Error: package/namespace load failed for 'wordnet'
>
> My guess is I miss something from the namespace but unfortunately I can't
> get to the internet.  Does anyone know what I'm missing (from the
> namespace?).  Thank you very much!

No, probably nothing is missing from the namespace, but probably too old
versions or strange libraries in use.

Best,
Uwe Ligges


> Kelvin

______________________________________________
R-help@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.