R Installation problem

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

R Installation problem

Wang, Meihua
Dear R users,

I was trying to install "R" on an ALPHA running OSF1/V5.1 for individual
use, but warning messages came out when I run "./configure" and "make".
The following is part of output:

% ./configure  --prefix=$home/r
checking build system type... alphaev67-dec-osf5.1b
checking host system type... alphaev67-dec-osf5.1b
loading site script './config.site'
loading build specific script './config.site'
checking for pwd... /bin/pwd
checking whether builddir is srcdir... yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... missing
checking for gawk... gawk
checking for egrep... grep -E
checking whether ln -s works... yes
checking for ranlib... ranlib
checking for bison... bison -y
checking for ar... ar
checking for a BSD-compatible install... tools/install-sh -c
checking for sed... /usr/psc/bin/sed
checking for less... /usr/psc/gnu/bin/less
checking for perl... /usr/psc/bin/perl
checking whether perl version is at least 5.004... yes
checking for dvips... no
checking for tex... no
checking for latex... no
configure: WARNING: you cannot build DVI versions of the R manuals
checking for makeindex... no
checking for pdftex... no
checking for pdflatex... no
configure: WARNING: you cannot build PDF versions of the R manuals

   ............
   ...............

R is now configured for alphaev67-dec-osf5.1b

  Source directory:          .
  Installation directory:    /usr/users/1/mwang2/r

  C compiler:                gcc -mieee-with-inexact -g -O2
  C++ compiler:              g++ -mieee -g -O2
  Fortran compiler:          g77 -mieee -g -O2

  Interfaces supported:      X11
  External libraries:        readline
  Additional capabilities:   MBCS, NLS
  Options enabled:           R profiling

  Recommended packages:      yes

configure: WARNING: you cannot build DVI versions of the R manuals
configure: WARNING: you cannot build info or html versions of the R
manuals
configure: WARNING: you cannot build PDF versions of the R manuals
% make
Make: Cannot open /share/make/vars.mk.  Stop.
%

I read R Installation and Administration and tried "gmake" instead of
"make", unfortunatly it didn't help either.

I was wondering if anyone can help me out?

Thanks,

Meihua


        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html