R installation Ubuntu 10.04 missing dependency

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

R installation Ubuntu 10.04 missing dependency

John Kane-3
To upgrade to R.3.5.2 from 3.4.4 I have been following the
instructions at
https://www.r-bloggers.com/installation-of-r-3-5-on-ubuntu-18-04-lts-and-tips-for-spatial-packages/
.

I seem to have the repository properly connected and verified.

I am getting an error:
---------------------------------------------------------------------------------------------------
john@jonh-T510:~$ sudo apt install r-base r-base-core r-recommended
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 r-base-core : Depends: libreadline6 (>= 6.0) but it is not installable
               Recommends: r-base-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
-------------------------------------------------------------------------------------------------
Earlier I was getting another error
r-base-core : Depends: libpng12-0 but it is not installable
but that was cured by installing libpng12-0 via the Ubuntu Software app.

I cannot find what appears to be an installable version of libreadlines6.

Ubuntu reports that the up-to-date version of libreadlines7.

Should I consider this an R issue or an Ubuntu issue?

In any case, has anyone encountered the problem and beaten it?

Thanks

--
John Kane
Kingston ON Canada

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: R installation Ubuntu 10.04 missing dependency

Eric Berger
Hi John,
Is the subject line of your question correct? Ubuntu 10.04?
If that is not a typo, that could be contributing to your problem. I
believe that the current stable release of Ubuntu is 18.04.
According to the following link ubuntu 10.04 was released almost 10 years
ago and was "retired" about 5 years ago.

http://fridge.ubuntu.com/2015/03/18/ubuntu-10-04-lucid-lynx-reaches-end-of-life-on-april-30-2015/

HTH,
Eric


On Sun, Mar 3, 2019 at 7:10 AM John Kane <[hidden email]> wrote:

> To upgrade to R.3.5.2 from 3.4.4 I have been following the
> instructions at
>
> https://www.r-bloggers.com/installation-of-r-3-5-on-ubuntu-18-04-lts-and-tips-for-spatial-packages/
> .
>
> I seem to have the repository properly connected and verified.
>
> I am getting an error:
>
> ---------------------------------------------------------------------------------------------------
> john@jonh-T510:~$ sudo apt install r-base r-base-core r-recommended
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help resolve the situation:
>
> The following packages have unmet dependencies:
>  r-base-core : Depends: libreadline6 (>= 6.0) but it is not installable
>                Recommends: r-base-dev but it is not going to be installed
> E: Unable to correct problems, you have held broken packages.
>
> -------------------------------------------------------------------------------------------------
> Earlier I was getting another error
> r-base-core : Depends: libpng12-0 but it is not installable
> but that was cured by installing libpng12-0 via the Ubuntu Software app.
>
> I cannot find what appears to be an installable version of libreadlines6.
>
> Ubuntu reports that the up-to-date version of libreadlines7.
>
> Should I consider this an R issue or an Ubuntu issue?
>
> In any case, has anyone encountered the problem and beaten it?
>
> Thanks
>
> --
> John Kane
> Kingston ON Canada
>
> ______________________________________________
> [hidden email] mailing list -- To UNSUBSCRIBE and more, see
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide
> http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.
>

        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.