Read.delim error in 2.3.0 devel, not in 2.2.0

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Read.delim error in 2.3.0 devel, not in 2.2.0

Sean Davis
I get this error in R-devel, but not in R-2.2.0.  Any insight is
appreciated.

Error in read.delim(txtcon, header = TRUE, sep = "\t", na.strings = "NULL")
:
    recursive default argument reference


> sessionInfo()
Version 2.3.0 Under development (unstable) (2006-01-04 r36984)
powerpc-apple-darwin8.3.0

attached base packages:
[1] "methods"   "stats"     "graphics"  "grDevices" "utils"     "datasets"
[7] "base"    

other attached packages:
GEOquery
 "1.5.3"

Thanks,
Sean

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Reply | Threaded
Open this post in threaded view
|

Re: Read.delim error in 2.3.0 devel, not in 2.2.0

Prof Brian Ripley
On Mon, 23 Jan 2006, Sean Davis wrote:

> I get this error in R-devel, but not in R-2.2.0.  Any insight is
> appreciated.
>
> Error in read.delim(txtcon, header = TRUE, sep = "\t", na.strings = "NULL")
> :
>    recursive default argument reference

There is nothing we can reproduce here.  What is txtcon, for example?
I was unable to reproduce anything like this reading from a text
connection.

--
Brian D. Ripley,                  [hidden email]
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel