Requirement for pandoc 1.12.3 in R 3.1.3

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Requirement for pandoc 1.12.3 in R 3.1.3

Prof J C Nash (U30A)
Are other developers finding R 3.1.3 problematic because vignette
building requires pandoc 1.12.3, while Linux Mint 17 / Ubuntu 14.04 have
1.12.2.1? R 3.1.2 seems to work fine.

I'd very much like to avoid having to build as large a Linux package as
pandoc, which has given me issues outside of R (it leaves out words,
sentences or paragraphs when converting Latex to epub in a novel I'm
working on, and does so without warning). Possibly concerns like this
are why R has moved to a later pandoc.

Suggestions welcome.

John Nash

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Reply | Threaded
Open this post in threaded view
|

Re: Requirement for pandoc 1.12.3 in R 3.1.3

Prof Brian Ripley
On 12/03/2015 13:51, Prof J C Nash (U30A) wrote:
> Are other developers finding R 3.1.3 problematic because vignette
> building requires pandoc 1.12.3, while Linux Mint 17 / Ubuntu 14.04 have
> 1.12.2.1? R 3.1.2 seems to work fine.

R has no built-in support for non-Sweave vignettes, and there is no
mention of pandoc in the R 3.1.3 sources except for the manual:

'Complete checking of a package which contains a file @file{README.md}
needs @command{pandoc} installed: see
@uref{http://johnmacfarlane.net/@/pandoc/@/installing.html}.'

which is true (but is not done with R 3.1.3).

I suspect you are confusing an R update with an update of whatever
packages you use to process your vignettes: package rmarkdown has a
pandoc version requirement of

SystemRequirements: pandoc (>= 1.12.3) -

--
Brian D. Ripley,                  [hidden email]
Emeritus Professor of Applied Statistics, University of Oxford
1 South Parks Road, Oxford OX1 3TG, UK

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Reply | Threaded
Open this post in threaded view
|

Re: Requirement for pandoc 1.12.3 in R 3.1.3

J C Nash
Thanks Brian.

Indeed, the vignette is in markdown form. When I updated my system to
R 3.1.3 I ran update.packages() and this seems to have upset things
(including R-studio processing of markdown files).

I tried removing rmarkdown and reverting to an older version so that my
sessionInfo() is

Loading required package: rmarkdown
> sessionInfo()
R version 3.1.3 (2015-03-09)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Ubuntu 14.04.2 LTS

locale:
 [1] LC_CTYPE=en_CA.UTF-8       LC_NUMERIC=C
 [3] LC_TIME=en_CA.UTF-8        LC_COLLATE=en_CA.UTF-8
 [5] LC_MONETARY=en_CA.UTF-8    LC_MESSAGES=en_CA.UTF-8
 [7] LC_PAPER=en_CA.UTF-8       LC_NAME=C
 [9] LC_ADDRESS=C               LC_TELEPHONE=C
[11] LC_MEASUREMENT=en_CA.UTF-8 LC_IDENTIFICATION=C

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base

other attached packages:
[1] rmarkdown_0.3.3

loaded via a namespace (and not attached):
[1] digest_0.6.8    htmltools_0.2.6

I also made sure to remove all instances of rmarkdown before installing
the older version.

However,

R CMD build nls14

still gives lots of errors (these are related to content in the vignette
source and are, I believe, consequent on the warning about
engine$weave). The warning still refers to the later version of pandoc
which Ubuntu 14.04 repos don't yet have.

My current guess is some mismatch in the software infrastructure.  I
have another machine with R 3.1.2 and rmarkdown_0.3.3 that manages to
build the package without complaint, but it would be good to get this
sorted out. Pointers on where to look for a fix are welcome.

 R CMD build nls14
* checking for file ‘nls14/DESCRIPTION’ ... OK
* preparing ‘nls14’:
* checking DESCRIPTION meta-information ... OK
* installing the package to build vignettes
* creating vignettes ... ERROR
Warning in engine$weave(file, quiet = quiet, encoding = enc) :
  Pandoc (>= 1.12.3) and/or pandoc-citeproc is not available. Please
install both.
Error in fnDeriv(r1, "x") : Only single expressions allowed
Error in as.vector(x, "expression") :
  cannot coerce type 'closure' to vector of type 'expression'
Error in as.vector(x, "expression") :
  cannot coerce type 'closure' to vector of type 'expression'
Error in array(0, c(length(.value), 2L), list(NULL, c("x001", "x002",  :
  length of 'dimnames' [2] not equal to array extent
Error in D(~log(x), "x") : Function '`~`' is not in the derivatives table
Error in D(interme, "x") : Function '`~`' is not in the derivatives table
Error in deriv.default(interme, "x") :
  Function '`~`' is not in the derivatives table
Error in D(expression(log(x, base = 3)), "x") :
  only single-argument calls are supported
Error in deriv.formula(~log(x, base = 3), "x") :
  only single-argument calls are supported
Error in deriv.default(expression(log(x, base = 3)), "x") :
  only single-argument calls are supported
Error in deriv3.default(expression(log(x, base = 3)), "x") :
  only single-argument calls are supported
Error in D(expression(abs(x)), "x") :
  Function 'abs' is not in the derivatives table
Error in deriv.formula(~abs(x), "x") :
  Function 'abs' is not in the derivatives table
Error in D(expression(sign(x)), "x") :
  Function 'sign' is not in the derivatives table
Error in deriv.formula(~sign(x), "x") :
  Function 'sign' is not in the derivatives table
sh: 1: yacas: not found
Quitting from lines 629-641 (nls14tutorial.Rmd)
Error: processing vignette 'nls14tutorial.Rmd' failed with diagnostics:
cannot open the connection
Execution halted

For reference:

john@john-J6-2015 ~/current/nls14work $ cat /etc/os-release
NAME="Ubuntu"
VERSION="14.04.2 LTS, Trusty Tahr"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 14.04.2 LTS"
VERSION_ID="14.04"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"

john@john-J6-2015 ~/current/nls14work $ cat /etc/linuxmint/info
RELEASE=17.1
CODENAME=rebecca
EDITION="MATE 64-bit"
DESCRIPTION="Linux Mint 17.1 Rebecca"
DESKTOP=MATE
TOOLKIT=GTK
NEW_FEATURES_URL=http://www.linuxmint.com/rel_rebecca_mate_whatsnew.php
RELEASE_NOTES_URL=http://www.linuxmint.com/rel_rebecca_mate.php
USER_GUIDE_URL=help:linuxmint
GRUB_TITLE=Linux Mint 17.1 MATE 64-bit



john@john-J6-2015 ~/current/nls14work $ dpkg -l | grep -i pandoc
ii  libghc-pandoc-citeproc-data                 0.2-3build1
                            all          Pandoc support for Citation
Style Language - data files

ii  pandoc                                      1.12.2.1-1build2
                            amd64        general markup converter

ii  pandoc-citeproc                             0.2-3build1
                            amd64        Pandoc support for Citation
Style Language - tools

ii  pandoc-data                                 1.12.2.1-1build2
                            all          general markup converter - data
files

JN


On 15-03-12 10:21 AM, Prof Brian Ripley wrote:

> On 12/03/2015 13:51, Prof J C Nash (U30A) wrote:
>> Are other developers finding R 3.1.3 problematic because vignette
>> building requires pandoc 1.12.3, while Linux Mint 17 / Ubuntu 14.04 have
>> 1.12.2.1? R 3.1.2 seems to work fine.
>
> R has no built-in support for non-Sweave vignettes, and there is no
> mention of pandoc in the R 3.1.3 sources except for the manual:
>
> 'Complete checking of a package which contains a file @file{README.md}
> needs @command{pandoc} installed: see
> @uref{http://johnmacfarlane.net/@/pandoc/@/installing.html}.'
>
> which is true (but is not done with R 3.1.3).
>
> I suspect you are confusing an R update with an update of whatever
> packages you use to process your vignettes: package rmarkdown has a
> pandoc version requirement of
>
> SystemRequirements: pandoc (>= 1.12.3) -
>

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Reply | Threaded
Open this post in threaded view
|

Re: Requirement for pandoc 1.12.3 in R 3.1.3

Dan Tenenbaum-2


----- Original Message -----

> From: "John Nash" <[hidden email]>
> To: "Prof Brian Ripley" <[hidden email]>, [hidden email]
> Sent: Thursday, March 12, 2015 8:15:42 AM
> Subject: Re: [Rd] Requirement for pandoc 1.12.3 in R 3.1.3
>
> Thanks Brian.
>
> Indeed, the vignette is in markdown form. When I updated my system to
> R 3.1.3 I ran update.packages() and this seems to have upset things
> (including R-studio processing of markdown files).
>
> I tried removing rmarkdown and reverting to an older version so that
> my
> sessionInfo() is
>
> Loading required package: rmarkdown
> > sessionInfo()
> R version 3.1.3 (2015-03-09)
> Platform: x86_64-pc-linux-gnu (64-bit)
> Running under: Ubuntu 14.04.2 LTS
>
> locale:
>  [1] LC_CTYPE=en_CA.UTF-8       LC_NUMERIC=C
>  [3] LC_TIME=en_CA.UTF-8        LC_COLLATE=en_CA.UTF-8
>  [5] LC_MONETARY=en_CA.UTF-8    LC_MESSAGES=en_CA.UTF-8
>  [7] LC_PAPER=en_CA.UTF-8       LC_NAME=C
>  [9] LC_ADDRESS=C               LC_TELEPHONE=C
> [11] LC_MEASUREMENT=en_CA.UTF-8 LC_IDENTIFICATION=C
>
> attached base packages:
> [1] stats     graphics  grDevices utils     datasets  methods   base
>
> other attached packages:
> [1] rmarkdown_0.3.3
>
> loaded via a namespace (and not attached):
> [1] digest_0.6.8    htmltools_0.2.6
>
> I also made sure to remove all instances of rmarkdown before
> installing
> the older version.
>
> However,
>
> R CMD build nls14
>
> still gives lots of errors (these are related to content in the
> vignette
> source and are, I believe, consequent on the warning about
> engine$weave). The warning still refers to the later version of
> pandoc
> which Ubuntu 14.04 repos don't yet have.
>

You can always download the latest version of pandoc; it's available as a .deb file at https://github.com/jgm/pandoc/releases .

Dan


> My current guess is some mismatch in the software infrastructure.  I
> have another machine with R 3.1.2 and rmarkdown_0.3.3 that manages to
> build the package without complaint, but it would be good to get this
> sorted out. Pointers on where to look for a fix are welcome.
>
>  R CMD build nls14
> * checking for file ‘nls14/DESCRIPTION’ ... OK
> * preparing ‘nls14’:
> * checking DESCRIPTION meta-information ... OK
> * installing the package to build vignettes
> * creating vignettes ... ERROR
> Warning in engine$weave(file, quiet = quiet, encoding = enc) :
>   Pandoc (>= 1.12.3) and/or pandoc-citeproc is not available. Please
> install both.
> Error in fnDeriv(r1, "x") : Only single expressions allowed
> Error in as.vector(x, "expression") :
>   cannot coerce type 'closure' to vector of type 'expression'
> Error in as.vector(x, "expression") :
>   cannot coerce type 'closure' to vector of type 'expression'
> Error in array(0, c(length(.value), 2L), list(NULL, c("x001", "x002",
>  :
>   length of 'dimnames' [2] not equal to array extent
> Error in D(~log(x), "x") : Function '`~`' is not in the derivatives
> table
> Error in D(interme, "x") : Function '`~`' is not in the derivatives
> table
> Error in deriv.default(interme, "x") :
>   Function '`~`' is not in the derivatives table
> Error in D(expression(log(x, base = 3)), "x") :
>   only single-argument calls are supported
> Error in deriv.formula(~log(x, base = 3), "x") :
>   only single-argument calls are supported
> Error in deriv.default(expression(log(x, base = 3)), "x") :
>   only single-argument calls are supported
> Error in deriv3.default(expression(log(x, base = 3)), "x") :
>   only single-argument calls are supported
> Error in D(expression(abs(x)), "x") :
>   Function 'abs' is not in the derivatives table
> Error in deriv.formula(~abs(x), "x") :
>   Function 'abs' is not in the derivatives table
> Error in D(expression(sign(x)), "x") :
>   Function 'sign' is not in the derivatives table
> Error in deriv.formula(~sign(x), "x") :
>   Function 'sign' is not in the derivatives table
> sh: 1: yacas: not found
> Quitting from lines 629-641 (nls14tutorial.Rmd)
> Error: processing vignette 'nls14tutorial.Rmd' failed with
> diagnostics:
> cannot open the connection
> Execution halted
>
> For reference:
>
> john@john-J6-2015 ~/current/nls14work $ cat /etc/os-release
> NAME="Ubuntu"
> VERSION="14.04.2 LTS, Trusty Tahr"
> ID=ubuntu
> ID_LIKE=debian
> PRETTY_NAME="Ubuntu 14.04.2 LTS"
> VERSION_ID="14.04"
> HOME_URL="http://www.ubuntu.com/"
> SUPPORT_URL="http://help.ubuntu.com/"
> BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
>
> john@john-J6-2015 ~/current/nls14work $ cat /etc/linuxmint/info
> RELEASE=17.1
> CODENAME=rebecca
> EDITION="MATE 64-bit"
> DESCRIPTION="Linux Mint 17.1 Rebecca"
> DESKTOP=MATE
> TOOLKIT=GTK
> NEW_FEATURES_URL=http://www.linuxmint.com/rel_rebecca_mate_whatsnew.php
> RELEASE_NOTES_URL=http://www.linuxmint.com/rel_rebecca_mate.php
> USER_GUIDE_URL=help:linuxmint
> GRUB_TITLE=Linux Mint 17.1 MATE 64-bit
>
>
>
> john@john-J6-2015 ~/current/nls14work $ dpkg -l | grep -i pandoc
> ii  libghc-pandoc-citeproc-data                 0.2-3build1
>                             all          Pandoc support for Citation
> Style Language - data files
>
> ii  pandoc                                      1.12.2.1-1build2
>                             amd64        general markup converter
>
> ii  pandoc-citeproc                             0.2-3build1
>                             amd64        Pandoc support for Citation
> Style Language - tools
>
> ii  pandoc-data                                 1.12.2.1-1build2
>                             all          general markup converter -
>                             data
> files
>
> JN
>
>
> On 15-03-12 10:21 AM, Prof Brian Ripley wrote:
> > On 12/03/2015 13:51, Prof J C Nash (U30A) wrote:
> >> Are other developers finding R 3.1.3 problematic because vignette
> >> building requires pandoc 1.12.3, while Linux Mint 17 / Ubuntu
> >> 14.04 have
> >> 1.12.2.1? R 3.1.2 seems to work fine.
> >
> > R has no built-in support for non-Sweave vignettes, and there is no
> > mention of pandoc in the R 3.1.3 sources except for the manual:
> >
> > 'Complete checking of a package which contains a file
> > @file{README.md}
> > needs @command{pandoc} installed: see
> > @uref{http://johnmacfarlane.net/@/pandoc/@/installing.html}.'
> >
> > which is true (but is not done with R 3.1.3).
> >
> > I suspect you are confusing an R update with an update of whatever
> > packages you use to process your vignettes: package rmarkdown has a
> > pandoc version requirement of
> >
> > SystemRequirements: pandoc (>= 1.12.3) -
> >
>
> ______________________________________________
> [hidden email] mailing list
> https://stat.ethz.ch/mailman/listinfo/r-devel
>

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Reply | Threaded
Open this post in threaded view
|

Re: Requirement for pandoc 1.12.3 in R 3.1.3

Prof J C Nash (U30A)
Dan's suggestion to get latest pandoc got me part of the way to a
workaround. The other part was removing references in the vignette to
alpha versions of some software.

For info: pandoc 1.13.2 seems to have some bugs for conversion of LaTeX
to html or epub still (or at least the error messages point to the wrong
place). However, these are in work I'm doing outside of R, and I'll
pursue them with the pandoc developer(s).

JN


On 15-03-12 11:21 AM, Dan Tenenbaum wrote:

>
>
> ----- Original Message -----
>> From: "John Nash" <[hidden email]>
>> To: "Prof Brian Ripley" <[hidden email]>, [hidden email]
>> Sent: Thursday, March 12, 2015 8:15:42 AM
>> Subject: Re: [Rd] Requirement for pandoc 1.12.3 in R 3.1.3
>>
>> Thanks Brian.
>>
>> Indeed, the vignette is in markdown form. When I updated my system to
>> R 3.1.3 I ran update.packages() and this seems to have upset things
>> (including R-studio processing of markdown files).
>>
>> I tried removing rmarkdown and reverting to an older version so that
>> my
>> sessionInfo() is
>>
>> Loading required package: rmarkdown
>>> sessionInfo()
>> R version 3.1.3 (2015-03-09)
>> Platform: x86_64-pc-linux-gnu (64-bit)
>> Running under: Ubuntu 14.04.2 LTS
>>
>> locale:
>>  [1] LC_CTYPE=en_CA.UTF-8       LC_NUMERIC=C
>>  [3] LC_TIME=en_CA.UTF-8        LC_COLLATE=en_CA.UTF-8
>>  [5] LC_MONETARY=en_CA.UTF-8    LC_MESSAGES=en_CA.UTF-8
>>  [7] LC_PAPER=en_CA.UTF-8       LC_NAME=C
>>  [9] LC_ADDRESS=C               LC_TELEPHONE=C
>> [11] LC_MEASUREMENT=en_CA.UTF-8 LC_IDENTIFICATION=C
>>
>> attached base packages:
>> [1] stats     graphics  grDevices utils     datasets  methods   base
>>
>> other attached packages:
>> [1] rmarkdown_0.3.3
>>
>> loaded via a namespace (and not attached):
>> [1] digest_0.6.8    htmltools_0.2.6
>>
>> I also made sure to remove all instances of rmarkdown before
>> installing
>> the older version.
>>
>> However,
>>
>> R CMD build nls14
>>
>> still gives lots of errors (these are related to content in the
>> vignette
>> source and are, I believe, consequent on the warning about
>> engine$weave). The warning still refers to the later version of
>> pandoc
>> which Ubuntu 14.04 repos don't yet have.
>>
>
> You can always download the latest version of pandoc; it's available as a .deb file at https://github.com/jgm/pandoc/releases .
>
> Dan
>
>
>> My current guess is some mismatch in the software infrastructure.  I
>> have another machine with R 3.1.2 and rmarkdown_0.3.3 that manages to
>> build the package without complaint, but it would be good to get this
>> sorted out. Pointers on where to look for a fix are welcome.
>>
>>  R CMD build nls14
>> * checking for file ‘nls14/DESCRIPTION’ ... OK
>> * preparing ‘nls14’:
>> * checking DESCRIPTION meta-information ... OK
>> * installing the package to build vignettes
>> * creating vignettes ... ERROR
>> Warning in engine$weave(file, quiet = quiet, encoding = enc) :
>>   Pandoc (>= 1.12.3) and/or pandoc-citeproc is not available. Please
>> install both.
>> Error in fnDeriv(r1, "x") : Only single expressions allowed
>> Error in as.vector(x, "expression") :
>>   cannot coerce type 'closure' to vector of type 'expression'
>> Error in as.vector(x, "expression") :
>>   cannot coerce type 'closure' to vector of type 'expression'
>> Error in array(0, c(length(.value), 2L), list(NULL, c("x001", "x002",
>>  :
>>   length of 'dimnames' [2] not equal to array extent
>> Error in D(~log(x), "x") : Function '`~`' is not in the derivatives
>> table
>> Error in D(interme, "x") : Function '`~`' is not in the derivatives
>> table
>> Error in deriv.default(interme, "x") :
>>   Function '`~`' is not in the derivatives table
>> Error in D(expression(log(x, base = 3)), "x") :
>>   only single-argument calls are supported
>> Error in deriv.formula(~log(x, base = 3), "x") :
>>   only single-argument calls are supported
>> Error in deriv.default(expression(log(x, base = 3)), "x") :
>>   only single-argument calls are supported
>> Error in deriv3.default(expression(log(x, base = 3)), "x") :
>>   only single-argument calls are supported
>> Error in D(expression(abs(x)), "x") :
>>   Function 'abs' is not in the derivatives table
>> Error in deriv.formula(~abs(x), "x") :
>>   Function 'abs' is not in the derivatives table
>> Error in D(expression(sign(x)), "x") :
>>   Function 'sign' is not in the derivatives table
>> Error in deriv.formula(~sign(x), "x") :
>>   Function 'sign' is not in the derivatives table
>> sh: 1: yacas: not found
>> Quitting from lines 629-641 (nls14tutorial.Rmd)
>> Error: processing vignette 'nls14tutorial.Rmd' failed with
>> diagnostics:
>> cannot open the connection
>> Execution halted
>>
>> For reference:
>>
>> john@john-J6-2015 ~/current/nls14work $ cat /etc/os-release
>> NAME="Ubuntu"
>> VERSION="14.04.2 LTS, Trusty Tahr"
>> ID=ubuntu
>> ID_LIKE=debian
>> PRETTY_NAME="Ubuntu 14.04.2 LTS"
>> VERSION_ID="14.04"
>> HOME_URL="http://www.ubuntu.com/"
>> SUPPORT_URL="http://help.ubuntu.com/"
>> BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
>>
>> john@john-J6-2015 ~/current/nls14work $ cat /etc/linuxmint/info
>> RELEASE=17.1
>> CODENAME=rebecca
>> EDITION="MATE 64-bit"
>> DESCRIPTION="Linux Mint 17.1 Rebecca"
>> DESKTOP=MATE
>> TOOLKIT=GTK
>> NEW_FEATURES_URL=http://www.linuxmint.com/rel_rebecca_mate_whatsnew.php
>> RELEASE_NOTES_URL=http://www.linuxmint.com/rel_rebecca_mate.php
>> USER_GUIDE_URL=help:linuxmint
>> GRUB_TITLE=Linux Mint 17.1 MATE 64-bit
>>
>>
>>
>> john@john-J6-2015 ~/current/nls14work $ dpkg -l | grep -i pandoc
>> ii  libghc-pandoc-citeproc-data                 0.2-3build1
>>                             all          Pandoc support for Citation
>> Style Language - data files
>>
>> ii  pandoc                                      1.12.2.1-1build2
>>                             amd64        general markup converter
>>
>> ii  pandoc-citeproc                             0.2-3build1
>>                             amd64        Pandoc support for Citation
>> Style Language - tools
>>
>> ii  pandoc-data                                 1.12.2.1-1build2
>>                             all          general markup converter -
>>                             data
>> files
>>
>> JN
>>
>>
>> On 15-03-12 10:21 AM, Prof Brian Ripley wrote:
>>> On 12/03/2015 13:51, Prof J C Nash (U30A) wrote:
>>>> Are other developers finding R 3.1.3 problematic because vignette
>>>> building requires pandoc 1.12.3, while Linux Mint 17 / Ubuntu
>>>> 14.04 have
>>>> 1.12.2.1? R 3.1.2 seems to work fine.
>>>
>>> R has no built-in support for non-Sweave vignettes, and there is no
>>> mention of pandoc in the R 3.1.3 sources except for the manual:
>>>
>>> 'Complete checking of a package which contains a file
>>> @file{README.md}
>>> needs @command{pandoc} installed: see
>>> @uref{http://johnmacfarlane.net/@/pandoc/@/installing.html}.'
>>>
>>> which is true (but is not done with R 3.1.3).
>>>
>>> I suspect you are confusing an R update with an update of whatever
>>> packages you use to process your vignettes: package rmarkdown has a
>>> pandoc version requirement of
>>>
>>> SystemRequirements: pandoc (>= 1.12.3) -
>>>
>>
>> ______________________________________________
>> [hidden email] mailing list
>> https://stat.ethz.ch/mailman/listinfo/r-devel
>>

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel