Unable to load EBImage

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Unable to load EBImage

Lamke
Hi group,

I've spent half a day trying to figure this out and searched through different forums.  I've tried to load EBImage but am getting the following problem:

>Error in inDL(x, as.logical(local), as.logical(now), ...) :
>  cannot initialize ImageMagick
>Error: package/namespace load failed for 'EBImage'

My path is like this:
C:\\Program Files\\ImageMagick-6.6.1-Q16;C:\\GTK\\bin;C:\\WINDOWS\\system32;.......

My sessionInfo()

> sessionInfo()
R version 2.10.1 (2009-12-14)
i386-pc-mingw32

locale:
[1] LC_COLLATE=English_United States.1252  LC_CTYPE=English_United States.1252    LC_MONETARY=English_United States.1252
[4] LC_NUMERIC=C                           LC_TIME=English_United States.1252    

I've tried to remove EBImage and reinstall, shut down the PC and restart after installing and so forth.  Still it doesn't help much.  

Thanks for the help!!
Reply | Threaded
Open this post in threaded view
|

Re: Unable to load EBImage

Gregoire Pau-3
Hello Lamke,

EBImage is a Bioconductor package: please post on the Bioconductor
mailing list.

The issue you are reporting is due to a recent modification of the
ImageMagick API, on which EBImage relies to read/write images. We are
currently fixing this issue. In the meanwhile, please use a previous
version of ImageMagick (such as 6.5.x).

Hope this helps,
Best regards,

Greg
---
Gregoire Pau
EMBL Research officer
http://www.ebi.ac.uk/~gpau/


Lamke wrote:

> Hi group,
>
> I've spent half a day trying to figure this out and searched through
> different forums.  I've tried to load EBImage but am getting the following
> problem:
>
>> Error in inDL(x, as.logical(local), as.logical(now), ...) :
>>  cannot initialize ImageMagick
>> Error: package/namespace load failed for 'EBImage'
>
> My path is like this:
> C:\\Program
> Files\\ImageMagick-6.6.1-Q16;C:\\GTK\\bin;C:\\WINDOWS\\system32;.......
>
> My sessionInfo()
>
>> sessionInfo()
> R version 2.10.1 (2009-12-14)
> i386-pc-mingw32
>
> locale:
> [1] LC_COLLATE=English_United States.1252  LC_CTYPE=English_United
> States.1252    LC_MONETARY=English_United States.1252
> [4] LC_NUMERIC=C                           LC_TIME=English_United
> States.1252    
>
> I've tried to remove EBImage and reinstall, shut down the PC and restart
> after installing and so forth.  Still it doesn't help much.  
>
> Thanks for the help!!

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.