Why I can not get work the "tidyverse" and "corrr" libraries

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Why I can not get work the "tidyverse" and "corrr" libraries

greg holly
;

I need work on libraries "tidyverse" and "corrr". When I cal these, I am
getting the following error message. What can be done? Your help is highly
appreciated.

Greg

Error: package or namespace load failed for ‘tidyverse’ in loadNamespace(i,
c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
 namespace ‘rlang’ 0.3.0 is already loaded, but >= 0.3.1 is required
In addition: Warning message:
package ‘tidyverse’ was built under R version 3.5.3

        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: Why I can not get work the "tidyverse" and "corrr" libraries

Jeff Newmiller
From reading

> namespace ‘rlang’ 0.3.0 is already loaded, but >= 0.3.1 is required

it would seem that you need to upgrade your rlang package...

On April 17, 2019 10:19:48 AM PDT, greg holly <[hidden email]> wrote:

>;
>
>I need work on libraries "tidyverse" and "corrr". When I cal these, I
>am
>getting the following error message. What can be done? Your help is
>highly
>appreciated.
>
>Greg
>
>Error: package or namespace load failed for ‘tidyverse’ in
>loadNamespace(i,
>c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
> namespace ‘rlang’ 0.3.0 is already loaded, but >= 0.3.1 is required
>In addition: Warning message:
>package ‘tidyverse’ was built under R version 3.5.3
>
> [[alternative HTML version deleted]]
>
>______________________________________________
>[hidden email] mailing list -- To UNSUBSCRIBE and more, see
>https://stat.ethz.ch/mailman/listinfo/r-help
>PLEASE do read the posting guide
>http://www.R-project.org/posting-guide.html
>and provide commented, minimal, self-contained, reproducible code.

--
Sent from my phone. Please excuse my brevity.

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: Why I can not get work the "tidyverse" and "corrr" libraries

hadley wickham
On Wed, Apr 17, 2019 at 1:06 PM Jeff Newmiller <[hidden email]> wrote:
>
> From reading
>
> > namespace ‘rlang’ 0.3.0 is already loaded, but >= 0.3.1 is required
>
> it would seem that you need to upgrade your rlang package...

Typically this indicates you need to restart R.

Hadley

--
http://hadley.nz

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.