configure --with-pcre1 fails with latest R 4.0 on Ubuntu 14.04

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

configure --with-pcre1 fails with latest R 4.0 on Ubuntu 14.04

Hervé Pagès-2
Using --with-pcre1 to configure the latest R 4.0 (revision 77988) on an
Ubuntu 14.04.5 LTS system gives me the following error:

...
checking if lzma version >= 5.0.3... yes
checking for pcre2-config... no
checking for pcre_fullinfo in -lpcre... yes
checking pcre.h usability... yes
checking pcre.h presence... yes
checking for pcre.h... yes
checking pcre/pcre.h usability... no
checking pcre/pcre.h presence... no
checking for pcre/pcre.h... no
checking if PCRE1 version >= 8.32 and has UTF-8 support... no
checking whether PCRE support suffices... configure: error: pcre2
library and headers are required, or use --with-pcre1

Maybe the real problem is that the PCRE version on this OS is 8.31?

The error message is not particularly helpful.

Thanks,
H.

--
Hervé Pagès

Program in Computational Biology
Division of Public Health Sciences
Fred Hutchinson Cancer Research Center
1100 Fairview Ave. N, M1-B514
P.O. Box 19024
Seattle, WA 98109-1024

E-mail: [hidden email]
Phone:  (206) 667-5791
Fax:    (206) 667-1319

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Reply | Threaded
Open this post in threaded view
|

Re: configure --with-pcre1 fails with latest R 4.0 on Ubuntu 14.04

Tomas Kalibera
On 3/17/20 8:18 PM, Hervé Pagès wrote:

> Using --with-pcre1 to configure the latest R 4.0 (revision 77988) on
> an Ubuntu 14.04.5 LTS system gives me the following error:
>
> ...
> checking if lzma version >= 5.0.3... yes
> checking for pcre2-config... no
> checking for pcre_fullinfo in -lpcre... yes
> checking pcre.h usability... yes
> checking pcre.h presence... yes
> checking for pcre.h... yes
> checking pcre/pcre.h usability... no
> checking pcre/pcre.h presence... no
> checking for pcre/pcre.h... no
> checking if PCRE1 version >= 8.32 and has UTF-8 support... no
> checking whether PCRE support suffices... configure: error: pcre2
> library and headers are required, or use --with-pcre1
>
> Maybe the real problem is that the PCRE version on this OS is 8.31?

Yes, R requires PCRE version at least 8.32 as documented in R-Admin, and
this is since September 2019.

> The error message is not particularly helpful.

An earlier version of the message gave the requirement explicitly, when
people would have been more likely to have that old versions of PCRE1.
The few who still have it now need to see also the output line above to
get the requirement and/or look into the manual.

R 4.0 is still keeping support for PCRE1 (>=8.32), but PCRE2 should be
used whenever possible.

Best,
Tomas

>
> Thanks,
> H.
>

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Reply | Threaded
Open this post in threaded view
|

Re: configure --with-pcre1 fails with latest R 4.0 on Ubuntu 14.04

Hervé Pagès-2
Thanks Tomas. Any chance the old version of the error message could be
restored? It would definitely be more helpful than the current one. It's
confusing to get an error and be told to use --with-pcre1 when you're
already using it.

H.

On 3/18/20 01:08, Tomas Kalibera wrote:

> On 3/17/20 8:18 PM, Hervé Pagès wrote:
>> Using --with-pcre1 to configure the latest R 4.0 (revision 77988) on
>> an Ubuntu 14.04.5 LTS system gives me the following error:
>>
>> ...
>> checking if lzma version >= 5.0.3... yes
>> checking for pcre2-config... no
>> checking for pcre_fullinfo in -lpcre... yes
>> checking pcre.h usability... yes
>> checking pcre.h presence... yes
>> checking for pcre.h... yes
>> checking pcre/pcre.h usability... no
>> checking pcre/pcre.h presence... no
>> checking for pcre/pcre.h... no
>> checking if PCRE1 version >= 8.32 and has UTF-8 support... no
>> checking whether PCRE support suffices... configure: error: pcre2
>> library and headers are required, or use --with-pcre1
>>
>> Maybe the real problem is that the PCRE version on this OS is 8.31?
>
> Yes, R requires PCRE version at least 8.32 as documented in R-Admin, and
> this is since September 2019.
>
>> The error message is not particularly helpful.
>
> An earlier version of the message gave the requirement explicitly, when
> people would have been more likely to have that old versions of PCRE1.
> The few who still have it now need to see also the output line above to
> get the requirement and/or look into the manual.
>
> R 4.0 is still keeping support for PCRE1 (>=8.32), but PCRE2 should be
> used whenever possible.
>
> Best,
> Tomas
>
>>
>> Thanks,
>> H.
>>
>

--
Hervé Pagès

Program in Computational Biology
Division of Public Health Sciences
Fred Hutchinson Cancer Research Center
1100 Fairview Ave. N, M1-B514
P.O. Box 19024
Seattle, WA 98109-1024

E-mail: [hidden email]
Phone:  (206) 667-5791
Fax:    (206) 667-1319

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Reply | Threaded
Open this post in threaded view
|

Re: configure --with-pcre1 fails with latest R 4.0 on Ubuntu 14.04

Tomas Kalibera
On 3/18/20 6:11 PM, Hervé Pagès wrote:
> Thanks Tomas. Any chance the old version of the error message could be
> restored? It would definitely be more helpful than the current one.
> It's confusing to get an error and be told to use --with-pcre1 when
> you're already using it.

The message now gives the required version and UTF-8 support
requirement, so one does not have to look that one line up.
Thanks to Brian Ripley,

Tomas

>
>
> H.
>
> On 3/18/20 01:08, Tomas Kalibera wrote:
>> On 3/17/20 8:18 PM, Hervé Pagès wrote:
>>> Using --with-pcre1 to configure the latest R 4.0 (revision 77988) on
>>> an Ubuntu 14.04.5 LTS system gives me the following error:
>>>
>>> ...
>>> checking if lzma version >= 5.0.3... yes
>>> checking for pcre2-config... no
>>> checking for pcre_fullinfo in -lpcre... yes
>>> checking pcre.h usability... yes
>>> checking pcre.h presence... yes
>>> checking for pcre.h... yes
>>> checking pcre/pcre.h usability... no
>>> checking pcre/pcre.h presence... no
>>> checking for pcre/pcre.h... no
>>> checking if PCRE1 version >= 8.32 and has UTF-8 support... no
>>> checking whether PCRE support suffices... configure: error: pcre2
>>> library and headers are required, or use --with-pcre1
>>>
>>> Maybe the real problem is that the PCRE version on this OS is 8.31?
>>
>> Yes, R requires PCRE version at least 8.32 as documented in R-Admin,
>> and this is since September 2019.
>>
>>> The error message is not particularly helpful.
>>
>> An earlier version of the message gave the requirement explicitly,
>> when people would have been more likely to have that old versions of
>> PCRE1.
>> The few who still have it now need to see also the output line above
>> to get the requirement and/or look into the manual.
>>
>> R 4.0 is still keeping support for PCRE1 (>=8.32), but PCRE2 should
>> be used whenever possible.
>>
>> Best,
>> Tomas
>>
>>>
>>> Thanks,
>>> H.
>>>
>>
>

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Reply | Threaded
Open this post in threaded view
|

Re: configure --with-pcre1 fails with latest R 4.0 on Ubuntu 14.04

Hervé Pagès-2
Excellent. Thank you!   H.

On 3/20/20 23:55, Tomas Kalibera wrote:

> On 3/18/20 6:11 PM, Hervé Pagès wrote:
>> Thanks Tomas. Any chance the old version of the error message could be
>> restored? It would definitely be more helpful than the current one.
>> It's confusing to get an error and be told to use --with-pcre1 when
>> you're already using it.
>
> The message now gives the required version and UTF-8 support
> requirement, so one does not have to look that one line up.
> Thanks to Brian Ripley,
>
> Tomas
>
>>
>>
>> H.
>>
>> On 3/18/20 01:08, Tomas Kalibera wrote:
>>> On 3/17/20 8:18 PM, Hervé Pagès wrote:
>>>> Using --with-pcre1 to configure the latest R 4.0 (revision 77988) on
>>>> an Ubuntu 14.04.5 LTS system gives me the following error:
>>>>
>>>> ...
>>>> checking if lzma version >= 5.0.3... yes
>>>> checking for pcre2-config... no
>>>> checking for pcre_fullinfo in -lpcre... yes
>>>> checking pcre.h usability... yes
>>>> checking pcre.h presence... yes
>>>> checking for pcre.h... yes
>>>> checking pcre/pcre.h usability... no
>>>> checking pcre/pcre.h presence... no
>>>> checking for pcre/pcre.h... no
>>>> checking if PCRE1 version >= 8.32 and has UTF-8 support... no
>>>> checking whether PCRE support suffices... configure: error: pcre2
>>>> library and headers are required, or use --with-pcre1
>>>>
>>>> Maybe the real problem is that the PCRE version on this OS is 8.31?
>>>
>>> Yes, R requires PCRE version at least 8.32 as documented in R-Admin,
>>> and this is since September 2019.
>>>
>>>> The error message is not particularly helpful.
>>>
>>> An earlier version of the message gave the requirement explicitly,
>>> when people would have been more likely to have that old versions of
>>> PCRE1.
>>> The few who still have it now need to see also the output line above
>>> to get the requirement and/or look into the manual.
>>>
>>> R 4.0 is still keeping support for PCRE1 (>=8.32), but PCRE2 should
>>> be used whenever possible.
>>>
>>> Best,
>>> Tomas
>>>
>>>>
>>>> Thanks,
>>>> H.
>>>>
>>>
>>
>

--
Hervé Pagès

Program in Computational Biology
Division of Public Health Sciences
Fred Hutchinson Cancer Research Center
1100 Fairview Ave. N, M1-B514
P.O. Box 19024
Seattle, WA 98109-1024

E-mail: [hidden email]
Phone:  (206) 667-5791
Fax:    (206) 667-1319

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel