error in installing igraph

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

error in installing igraph

lily li
Hi R users,
I got warning messages when installing the package, and I pasted the
messages below. I checked updates that my R-studio is already the newest
version. I don't know how to solve the problem. Thanks for your help.

> library(igraph)
Error in dyn.load(file, DLLpath = DLLpath, ...) :
  unable to load shared object
'/Library/Frameworks/R.framework/Versions/3.2/Resources/library/igraph/libs/igraph.so':

dlopen(/Library/Frameworks/R.framework/Versions/3.2/Resources/library/igraph/libs/igraph.so,
6): Library not loaded:
/Library/Frameworks/R.framework/Versions/3.4/Resources/lib/libRlapack.dylib
  Referenced from:
/Library/Frameworks/R.framework/Versions/3.2/Resources/library/igraph/libs/igraph.so
  Reason: Incompatible library version: igraph.so requires version 3.4.0 or
later, but libRlapack.dylib provides version 3.2.0
In addition: Warning message:
package ‘igraph’ was built under R version 3.4.1
Error: package or namespace load failed for ‘igraph’

        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: error in installing igraph

Jeff Newmiller
This is a perfect example of a question that should have gone to the R-sig-mac mailing list. (Mentioned in the POSTING GUIDE... read it.) When you post there I recommend that you include the output of sessionInfo().
--
Sent from my phone. Please excuse my brevity.

On August 2, 2017 9:07:42 PM PDT, lily li <[hidden email]> wrote:

>Hi R users,
>I got warning messages when installing the package, and I pasted the
>messages below. I checked updates that my R-studio is already the
>newest
>version. I don't know how to solve the problem. Thanks for your help.
>
>> library(igraph)
>Error in dyn.load(file, DLLpath = DLLpath, ...) :
>  unable to load shared object
>'/Library/Frameworks/R.framework/Versions/3.2/Resources/library/igraph/libs/igraph.so':
>
>dlopen(/Library/Frameworks/R.framework/Versions/3.2/Resources/library/igraph/libs/igraph.so,
>6): Library not loaded:
>/Library/Frameworks/R.framework/Versions/3.4/Resources/lib/libRlapack.dylib
>  Referenced from:
>/Library/Frameworks/R.framework/Versions/3.2/Resources/library/igraph/libs/igraph.so
>Reason: Incompatible library version: igraph.so requires version 3.4.0
>or
>later, but libRlapack.dylib provides version 3.2.0
>In addition: Warning message:
>package ‘igraph’ was built under R version 3.4.1
>Error: package or namespace load failed for ‘igraph’
>
> [[alternative HTML version deleted]]
>
>______________________________________________
>[hidden email] mailing list -- To UNSUBSCRIBE and more, see
>https://stat.ethz.ch/mailman/listinfo/r-help
>PLEASE do read the posting guide
>http://www.R-project.org/posting-guide.html
>and provide commented, minimal, self-contained, reproducible code.

______________________________________________
[hidden email] mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.