html help not built

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

html help not built

jgarcia-2
Hi,

I've just installed R 2.10.1 for linux, and html help has not been built
(just the index page of each package but not the documentation for the
individual functions in the packages.

I cannot see any flag in the ./configure to set if html is going to be build.

Please could you tell me what should I do to biuld html files?

Thanks and best regards,
Javier
---

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: html help not built

Duncan Murdoch
On 07/04/2010 10:49 AM, [hidden email] wrote:
> Hi,
>
> I've just installed R 2.10.1 for linux, and html help has not been built
> (just the index page of each package but not the documentation for the
> individual functions in the packages.
>
> I cannot see any flag in the ./configure to set if html is going to be build.
>
> Please could you tell me what should I do to biuld html files?

Why would you want to build them before displaying them?  There are a
few uses for that sort of thing (e.g. Jon Baron's site that RSiteSearch
looks at), but you have to realize that you won't get the same files as
would be displayed to a normal user, links won't necessarily work, etc.

If you still want to do it, then just re-install all of your packages
with the "--html" option.

Duncan Murdoch

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: html help not built

jgarcia-2
Hi Duncan,
I must be misunderstanding something. It is not that I want them built at
installation time, but when I try to display the html help for any
function the html page is not built; e.g. cliking on the link to get() in
the base library, the message appears:

An error occurred while loading
file:///usr/local/lib64/R/library/base/html/get.html:
The file or folder /usr/local/lib64/R/library/base/html/get.html does not
exist.

Javier
---


> On 07/04/2010 10:49 AM, [hidden email] wrote:
>> Hi,
>>
>> I've just installed R 2.10.1 for linux, and html help has not been built
>> (just the index page of each package but not the documentation for the
>> individual functions in the packages.
>>
>> I cannot see any flag in the ./configure to set if html is going to be
>> build.
>>
>> Please could you tell me what should I do to biuld html files?
>
> Why would you want to build them before displaying them?  There are a
> few uses for that sort of thing (e.g. Jon Baron's site that RSiteSearch
> looks at), but you have to realize that you won't get the same files as
> would be displayed to a normal user, links won't necessarily work, etc.
>
> If you still want to do it, then just re-install all of your packages
> with the "--html" option.
>
> Duncan Murdoch
>

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Reply | Threaded
Open this post in threaded view
|

Re: html help not built

Duncan Murdoch
On 07/04/2010 11:19 AM, [hidden email] wrote:

> Hi Duncan,
> I must be misunderstanding something. It is not that I want them built at
> installation time, but when I try to display the html help for any
> function the html page is not built; e.g. cliking on the link to get() in
> the base library, the message appears:
>
> An error occurred while loading
> file:///usr/local/lib64/R/library/base/html/get.html:
> The file or folder /usr/local/lib64/R/library/base/html/get.html does not
> exist.
>  

It sounds as though you have an old library that will need to be rebuilt
to work with 2.10.1.  The link in the base page should be to something like

http://127.0.0.1:26057/library/base/html/get.html

(the port number will vary), not to

file:///usr/local/lib64/R/library/base/html/get.html

Duncan Murdoch


> Javier
> ---
>
>
> > On 07/04/2010 10:49 AM, [hidden email] wrote:
> >> Hi,
> >>
> >> I've just installed R 2.10.1 for linux, and html help has not been built
> >> (just the index page of each package but not the documentation for the
> >> individual functions in the packages.
> >>
> >> I cannot see any flag in the ./configure to set if html is going to be
> >> build.
> >>
> >> Please could you tell me what should I do to biuld html files?
> >
> > Why would you want to build them before displaying them?  There are a
> > few uses for that sort of thing (e.g. Jon Baron's site that RSiteSearch
> > looks at), but you have to realize that you won't get the same files as
> > would be displayed to a normal user, links won't necessarily work, etc.
> >
> > If you still want to do it, then just re-install all of your packages
> > with the "--html" option.
> >
> > Duncan Murdoch
> >
>

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.