passing extra arguments to devtools::build

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

passing extra arguments to devtools::build

Michael Friendly
This question was posed on SO :
https://stackoverflow.com/questions/58118495/passing-extra-argumenets-to-devtoolsbuild 
but there has been no useful reply.

Something seems to have changed in the |devtools|package, so that the
following commands, that used to run now give an error I can't decipher:

|>Sys.setenv(R_GSCMD="C:/Program
Files/gs/gs9.21/bin/gswin64c.exe")>devtools::build(args
=c('--resave-data','--compact-vignettes="gs+qpdf"'))The
filename,directory name,or volume label syntax is incorrect. Error
in(function(command =NULL,args =character(),error_on_status
=TRUE,:System command error|

I've tried other alternatives with other |devtools| commands, like just
passing a single argument, but still get the same error

|args ='--compact-vignettes="gs+qpdf"'devtools::check_win_devel(args=args)|

I'm using devtools 2.2.0, under R 3.5.2

--
Michael Friendly     Email: friendly AT yorku DOT ca
Professor, Psychology Dept. & Chair, ASA Statistical Graphics Section
York University      Voice: 416 736-2100 x66249
4700 Keele Street    Web: http://www.datavis.ca | @datavisFriendly
Toronto, ONT  M3J 1P3 CANADA


        [[alternative HTML version deleted]]

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Reply | Threaded
Open this post in threaded view
|

Re: passing extra arguments to devtools::build

Jan Gorecki
Dear Michael,

I think R-devel mailing list is not a proper place to report issues
with devtools. I would try filling an issue in their github
repository.
If you are able to reproduce this issue using plain R without any
extra packages, then please provide such example here.

Regards,
Jan Gorecki

On Fri, Sep 27, 2019 at 3:18 PM Michael Friendly <[hidden email]> wrote:

>
> This question was posed on SO :
> https://stackoverflow.com/questions/58118495/passing-extra-argumenets-to-devtoolsbuild
> but there has been no useful reply.
>
> Something seems to have changed in the |devtools|package, so that the
> following commands, that used to run now give an error I can't decipher:
>
> |>Sys.setenv(R_GSCMD="C:/Program
> Files/gs/gs9.21/bin/gswin64c.exe")>devtools::build(args
> =c('--resave-data','--compact-vignettes="gs+qpdf"'))The
> filename,directory name,or volume label syntax is incorrect. Error
> in(function(command =NULL,args =character(),error_on_status
> =TRUE,:System command error|
>
> I've tried other alternatives with other |devtools| commands, like just
> passing a single argument, but still get the same error
>
> |args ='--compact-vignettes="gs+qpdf"'devtools::check_win_devel(args=args)|
>
> I'm using devtools 2.2.0, under R 3.5.2
>
> --
> Michael Friendly     Email: friendly AT yorku DOT ca
> Professor, Psychology Dept. & Chair, ASA Statistical Graphics Section
> York University      Voice: 416 736-2100 x66249
> 4700 Keele Street    Web: http://www.datavis.ca | @datavisFriendly
> Toronto, ONT  M3J 1P3 CANADA
>
>
>         [[alternative HTML version deleted]]
>
> ______________________________________________
> [hidden email] mailing list
> https://stat.ethz.ch/mailman/listinfo/r-devel

______________________________________________
[hidden email] mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel